[Security Announce] [ MDKSA-2007:132 ] - Updated madwifi-source, wpa_supplicant packages fix vulnerabilities
Posted on: 06/21/2007 10:20 PM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:132
http://www.mandriva.com/security/
_______________________________________________________________________

Package : madwifi-source
Date : June 21, 2007
Affected: 2007.0, 2007.1
_______________________________________________________________________

Problem Description:

The 802.11 network stack in MadWifi prior to 0.9.3.1 would alloa remote
attackers to cause a denial of service (system hang) via a crafted
length field in nested 802.3 Ethernet frames in Fast Frame packets,
which results in a NULL pointer dereference (CVE-2007-2829).

The ath_beacon_config function in MadWifi prior to 0.9.3.1 would
allow a remote attacker to cause a denial of service (system crash)
via crafted beacon interval information when scanning for access
points, which triggered a divide-by-zero error (CVE-2007-2830).

An array index error in MadWifi prior to 0.9.3.1 would allow a
local user to cause a denial of service (system crash) and possibly
obtain kerenl memory contents, as well as possibly allowing for the
execution of arbitrary code via a large negative array index value
(CVE-2007-2831).

Updated packages have been updated to 0.9.3.1 to correct these
issues. Wpa_supplicant is built using madwifi-source and has been
rebuilt using 0.9.3.1 source.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2829
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2830
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2831
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.0:
12348dbfba8628bfa7594209190591eb 2007.0/i586/madwifi-source-0.9.3.1-1.1mdv2007.0.noarch.rpm
69f23c96b9e5419bb9add4553b875cce 2007.0/i586/wpa_gui-0.5.5-2.2mdv2007.0.i586.rpm
d09b5b0e4f5fdf4fc4db948dbffea169 2007.0/i586/wpa_supplicant-0.5.5-2.2mdv2007.0.i586.rpm
cbcd53386bcfebff8d220b27059e6b69 2007.0/SRPMS/madwifi-source-0.9.3.1-1.1mdv2007.0.src.rpm
59139f14e119e5c205df03a02771f070 2007.0/SRPMS/wpa_supplicant-0.5.5-2.2mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64:
12348dbfba8628bfa7594209190591eb 2007.0/x86_64/madwifi-source-0.9.3.1-1.1mdv2007.0.noarch.rpm
f17c658cae2dcfe6b3e97607584a2f2a 2007.0/x86_64/wpa_gui-0.5.5-2.2mdv2007.0.x86_64.rpm
71d9dc132a98d7113013e7a49459211d 2007.0/x86_64/wpa_supplicant-0.5.5-2.2mdv2007.0.x86_64.rpm
cbcd53386bcfebff8d220b27059e6b69 2007.0/SRPMS/madwifi-source-0.9.3.1-1.1mdv2007.0.src.rpm
59139f14e119e5c205df03a02771f070 2007.0/SRPMS/wpa_supplicant-0.5.5-2.2mdv2007.0.src.rpm

Mandriva Linux 2007.1:
1b51de79156fce38f5a8d1310632e2a4 2007.1/i586/madwifi-source-0.9.3.1-1.1mdv2007.1.noarch.rpm
32a18c21ab8217e4a076e9a2070b9c9b 2007.1/i586/wpa_gui-0.5.7-1.2mdv2007.1.i586.rpm
b11c90cf4a982d3651cc5485198dd4d1 2007.1/i586/wpa_supplicant-0.5.7-1.2mdv2007.1.i586.rpm
e7d7710a93440902d0ccd7b90ea6e939 2007.1/SRPMS/madwifi-source-0.9.3.1-1.1mdv2007.1.src.rpm
866afdd304a0bf415823a5db06b95066 2007.1/SRPMS/wpa_supplicant-0.5.7-1.2mdv2007.1.src.rpm

Mandriva Linux 2007.1/X86_64:
1b51de79156fce38f5a8d1310632e2a4 2007.1/x86_64/madwifi-source-0.9.3.1-1.1mdv2007.1.noarch.rpm
4ad0a1957ce6d6cf9a3608f6d1dacb31 2007.1/x86_64/wpa_gui-0.5.7-1.2mdv2007.1.x86_64.rpm
04cb9776f30939ee111f4c6004da311a 2007.1/x86_64/wpa_supplicant-0.5.7-1.2mdv2007.1.x86_64.rpm
e7d7710a93440902d0ccd7b90ea6e939 2007.1/SRPMS/madwifi-source-0.9.3.1-1.1mdv2007.1.src.rpm
866afdd304a0bf415823a5db06b95066 2007.1/SRPMS/wpa_supplicant-0.5.7-1.2mdv2007.1.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGeqEAmqjQ0CJFipgRAiUyAKCjNba+Ry7Xy+M/Ny8a91n6Crs72wCgk5i+
u+bHITE9fMYKWTw0EDsgDB4=
=c4ce
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007132__updated_madwifi_sourcewpa_supplicant_packages_fix_vulnerabilities.html)