[Security Announce] [ MDKSA-2007:123 ] - Updated libwmf packages fix vulnerability
Posted on: 06/14/2007 05:00 AM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:123
http://www.mandriva.com/security/
_______________________________________________________________________

Package : libwmf
Date : June 13, 2007
Affected: 2007.0, 2007.1, Corporate 3.0, Corporate 4.0
_______________________________________________________________________

Problem Description:

A flaw in libgd2 was found by Xavier Roche where it would not correctly
validate PNG callback results. If an application linked against
libgd2 was tricked into processing a specially-crafted PNG file, it
could cause a denial of service scenario via CPU resource consumption.

Libwmf uses an embedded copy of the gd source and may also be affected
by this issue.

The updated packages have been patched to prevent this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2756
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.0:
c86673dc09b72cf255a5f9aabd2ae559 2007.0/i586/libwmf-0.2.8.4-6.2mdv2007.0.i586.rpm
e3cefcb964c4a757ffbb8ff8339bdc74 2007.0/i586/libwmf0.2_7-0.2.8.4-6.2mdv2007.0.i586.rpm
b8fb89d10a40ec19a136f7e214f1589d 2007.0/i586/libwmf0.2_7-devel-0.2.8.4-6.2mdv2007.0.i586.rpm
f227ff8694cf40aeb285096dadfc4930 2007.0/SRPMS/libwmf-0.2.8.4-6.2mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64:
64522c5fbe3ad9a6b8f2e5186c6de79b 2007.0/x86_64/lib64wmf0.2_7-0.2.8.4-6.2mdv2007.0.x86_64.rpm
e6089ae8094546d292fb26254a5dc708 2007.0/x86_64/lib64wmf0.2_7-devel-0.2.8.4-6.2mdv2007.0.x86_64.rpm
7ab103ccf86cf95b37ed72cabc345a82 2007.0/x86_64/libwmf-0.2.8.4-6.2mdv2007.0.x86_64.rpm
f227ff8694cf40aeb285096dadfc4930 2007.0/SRPMS/libwmf-0.2.8.4-6.2mdv2007.0.src.rpm

Mandriva Linux 2007.1:
ad2ae717396c13a5b691f99528905f98 2007.1/i586/libwmf-0.2.8.4-12.1mdv2007.1.i586.rpm
5e3e35f2ce695ed9df84296deef64aa1 2007.1/i586/libwmf0.2_7-0.2.8.4-12.1mdv2007.1.i586.rpm
1e668a6e0fd5eb52b5126816501be257 2007.1/i586/libwmf0.2_7-devel-0.2.8.4-12.1mdv2007.1.i586.rpm
0080787c5d105cfd95499c98e4820c6a 2007.1/SRPMS/libwmf-0.2.8.4-12.1mdv2007.1.src.rpm

Mandriva Linux 2007.1/X86_64:
bc11327efaef5fdb3020e040061fbd7f 2007.1/x86_64/lib64wmf0.2_7-0.2.8.4-12.1mdv2007.1.x86_64.rpm
91c5138f0e731a527505d3a65977ca7d 2007.1/x86_64/lib64wmf0.2_7-devel-0.2.8.4-12.1mdv2007.1.x86_64.rpm
ffb53a097a0285a81595a8a8972c520d 2007.1/x86_64/libwmf-0.2.8.4-12.1mdv2007.1.x86_64.rpm
0080787c5d105cfd95499c98e4820c6a 2007.1/SRPMS/libwmf-0.2.8.4-12.1mdv2007.1.src.rpm

Corporate 3.0:
df34bd3f1bf63ed85b42067761bbec75 corporate/3.0/i586/libwmf-0.2.8-6.5.C30mdk.i586.rpm
ab2768da467d4d90766ef8bdacff3bb0 corporate/3.0/i586/libwmf0.2_7-0.2.8-6.5.C30mdk.i586.rpm
7b28d2b7075f95533ad0e500bf731e52 corporate/3.0/i586/libwmf0.2_7-devel-0.2.8-6.5.C30mdk.i586.rpm
cb342eb68910afac9faf167928e407a8 corporate/3.0/SRPMS/libwmf-0.2.8-6.5.C30mdk.src.rpm

Corporate 3.0/X86_64:
5028c0cb1a0723c865bcd034a3bff5c3 corporate/3.0/x86_64/lib64wmf0.2_7-0.2.8-6.5.C30mdk.x86_64.rpm
7a90b3e4e68e7ac0a5ed6e4a5da34030 corporate/3.0/x86_64/lib64wmf0.2_7-devel-0.2.8-6.5.C30mdk.x86_64.rpm
5e6358404e6abb0acd524c5b2ff5022b corporate/3.0/x86_64/libwmf-0.2.8-6.5.C30mdk.x86_64.rpm
cb342eb68910afac9faf167928e407a8 corporate/3.0/SRPMS/libwmf-0.2.8-6.5.C30mdk.src.rpm

Corporate 4.0:
aa434be3161e2bc7d18dbe182e0245cb corporate/4.0/i586/libwmf-0.2.8.3-6.5.20060mlcs4.i586.rpm
36dd1dc2dd893db122f8d7b24e44e36b corporate/4.0/i586/libwmf0.2_7-0.2.8.3-6.5.20060mlcs4.i586.rpm
f10c3894ed2d7627a638a2e057beaac1 corporate/4.0/i586/libwmf0.2_7-devel-0.2.8.3-6.5.20060mlcs4.i586.rpm
cdbe755c905cf36ec96639fd0c11481c corporate/4.0/SRPMS/libwmf-0.2.8.3-6.5.20060mlcs4.src.rpm

Corporate 4.0/X86_64:
86709521446c865ea2b4bd7b904405c9 corporate/4.0/x86_64/lib64wmf0.2_7-0.2.8.3-6.5.20060mlcs4.x86_64.rpm
43f2632444101c645c1c5fccd9fb65e7 corporate/4.0/x86_64/lib64wmf0.2_7-devel-0.2.8.3-6.5.20060mlcs4.x86_64.rpm
2f1b8932f135fc077352d6178d9dc490 corporate/4.0/x86_64/libwmf-0.2.8.3-6.5.20060mlcs4.x86_64.rpm
cdbe755c905cf36ec96639fd0c11481c corporate/4.0/SRPMS/libwmf-0.2.8.3-6.5.20060mlcs4.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGcHSRmqjQ0CJFipgRAkJZAKCvDway6hVZL0jQ+031Q49bUE5/lACfZDfn
pARkg6ci15qTu/mzS+azNds=
=SPPg
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007123__updated_libwmf_packages_fix_vulnerability.html)