[Security Announce] [ MDKSA-2007:075-1 ] - Updated qt4 packages to address utf8 decoder bug
Posted on: 04/11/2007 04:10 AM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:075-1
http://www.mandriva.com/security/
_______________________________________________________________________

Package : qt4
Date : April 10, 2007
Affected: 2007.1
_______________________________________________________________________

Problem Description:



Update:

Packages for Mandriva Linux 2007.1 are now available.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0242
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.1:
a4cd74f8087cb2aec07e5b82eb406c4d 2007.1/i586/libqassistant1-4.2.3-3.1mdv2007.1.i586.rpm
d09a0175fc9f255d38ab4cdd96d24249 2007.1/i586/libqt3support4-4.2.3-3.1mdv2007.1.i586.rpm
2873bad92fc4f94c110358103687c25a 2007.1/i586/libqt4-devel-4.2.3-3.1mdv2007.1.i586.rpm
97756de6ee69eadb5e1b47dc7bc32466 2007.1/i586/libqtcore4-4.2.3-3.1mdv2007.1.i586.rpm
826f74fa11278ef4426fe402137b1737 2007.1/i586/libqtdbus4-4.2.3-3.1mdv2007.1.i586.rpm
1f062c29cb35e528e7ef039af5183be9 2007.1/i586/libqtdesigner1-4.2.3-3.1mdv2007.1.i586.rpm
3a291151821dda03669489aa011e06a1 2007.1/i586/libqtgui4-4.2.3-3.1mdv2007.1.i586.rpm
4c4d65c220e445a7c8e109d285732369 2007.1/i586/libqtnetwork4-4.2.3-3.1mdv2007.1.i586.rpm
96a1671776034910616428d7afb75368 2007.1/i586/libqtopengl4-4.2.3-3.1mdv2007.1.i586.rpm
d7803bd64dff28e1c05354b112bb1cdf 2007.1/i586/libqtsql4-4.2.3-3.1mdv2007.1.i586.rpm
f8134e731ca758b1cba50c1dd79272a1 2007.1/i586/libqtsvg4-4.2.3-3.1mdv2007.1.i586.rpm
73aba7c1e2858ac06ea8e870af915c08 2007.1/i586/libqttest4-4.2.3-3.1mdv2007.1.i586.rpm
2d6b1c0deb81242349c543d270102c4e 2007.1/i586/libqtuitools4-4.2.3-3.1mdv2007.1.i586.rpm
e799d3ea46d688f1954687e55c938aa8 2007.1/i586/libqtxml4-4.2.3-3.1mdv2007.1.i586.rpm
aaac2a22e50dd01e66deccd2faf1dc09 2007.1/i586/qt4-accessibility-plugin-lib-4.2.3-3.1mdv2007.1.i586.rpm
bddc72caa64fba63f1c0345d59316453 2007.1/i586/qt4-assistant-4.2.3-3.1mdv2007.1.i586.rpm
1fc0db14126b29c525640229716865dc 2007.1/i586/qt4-codecs-plugin-lib-4.2.3-3.1mdv2007.1.i586.rpm
ee4f6c89ae9817e72bd148a3c11b4e6c 2007.1/i586/qt4-common-4.2.3-3.1mdv2007.1.i586.rpm
75afda5fac7e1b748696f32e7ec238b5 2007.1/i586/qt4-database-plugin-mysql-lib-4.2.3-3.1mdv2007.1.i586.rpm
3b51b5dd81ddd308bcdf198fa1ab78f0 2007.1/i586/qt4-database-plugin-odbc-lib-4.2.3-3.1mdv2007.1.i586.rpm
2e734d154ee8bee870871a7523cae862 2007.1/i586/qt4-database-plugin-pgsql-lib-4.2.3-3.1mdv2007.1.i586.rpm
a7ff3a867ff4736ae942d4b8702946ac 2007.1/i586/qt4-database-plugin-sqlite-lib-4.2.3-3.1mdv2007.1.i586.rpm
b3ec487e3182f27ada170d2e5607853c 2007.1/i586/qt4-designer-4.2.3-3.1mdv2007.1.i586.rpm
edae91e6435360f00292a15641ac16cb 2007.1/i586/qt4-doc-4.2.3-3.1mdv2007.1.i586.rpm
302a771ea43d9a30d0d60eb3a2ef8978 2007.1/i586/qt4-examples-4.2.3-3.1mdv2007.1.i586.rpm
bb5960bf1e3527afbb7adb17479d478b 2007.1/i586/qt4-linguist-4.2.3-3.1mdv2007.1.i586.rpm
5f6ba28eed9cd24effb186a32c2ee2e1 2007.1/i586/qt4-qvfb-4.2.3-3.1mdv2007.1.i586.rpm
ca7b2f0ef06f531c66cf07aaf8ece6d9 2007.1/i586/qt4-tutorial-4.2.3-3.1mdv2007.1.i586.rpm
6202f4bff99c06561f8bd2bd62989985 2007.1/SRPMS/qt4-4.2.3-3.1mdv2007.1.src.rpm

Mandriva Linux 2007.1/X86_64:
11243cfe1059c6fcb1f90ffa6158627d 2007.1/x86_64/lib64qassistant1-4.2.3-3.1mdv2007.1.x86_64.rpm
0c60addd3b5e79e32c83d11167666951 2007.1/x86_64/lib64qt3support4-4.2.3-3.1mdv2007.1.x86_64.rpm
2531f48c45dff403616d0c0ccba848cc 2007.1/x86_64/lib64qt4-devel-4.2.3-3.1mdv2007.1.x86_64.rpm
789cc7d7c25adf703e568b91977a80af 2007.1/x86_64/lib64qtcore4-4.2.3-3.1mdv2007.1.x86_64.rpm
506cfc430cc4b7d813b2490ea720ca42 2007.1/x86_64/lib64qtdbus4-4.2.3-3.1mdv2007.1.x86_64.rpm
f5466fcfb000d572839e4438de3274b2 2007.1/x86_64/lib64qtdesigner1-4.2.3-3.1mdv2007.1.x86_64.rpm
8a6ad3d57aa00b6281f7aa213011a33d 2007.1/x86_64/lib64qtgui4-4.2.3-3.1mdv2007.1.x86_64.rpm
2452fbf2a788b9db534f4d7a9529ae27 2007.1/x86_64/lib64qtnetwork4-4.2.3-3.1mdv2007.1.x86_64.rpm
482e1f9c99c3619cbfa86b9e9b71ae1b 2007.1/x86_64/lib64qtopengl4-4.2.3-3.1mdv2007.1.x86_64.rpm
8c63a15849b69cd114cda8eb30e4c536 2007.1/x86_64/lib64qtsql4-4.2.3-3.1mdv2007.1.x86_64.rpm
02a07c6c63dc7dafaf43df70f41618b9 2007.1/x86_64/lib64qtsvg4-4.2.3-3.1mdv2007.1.x86_64.rpm
ae6f83aaa78dda389339adcf246e60e5 2007.1/x86_64/lib64qttest4-4.2.3-3.1mdv2007.1.x86_64.rpm
505a402942b62d3b54f966f5ddc8a53a 2007.1/x86_64/lib64qtuitools4-4.2.3-3.1mdv2007.1.x86_64.rpm
51dfdf4631e9a6d2d7432b42fe96d88b 2007.1/x86_64/lib64qtxml4-4.2.3-3.1mdv2007.1.x86_64.rpm
0ad17a86f35ee172a50cb78d264fa2e2 2007.1/x86_64/qt4-accessibility-plugin-lib64-4.2.3-3.1mdv2007.1.x86_64.rpm
a1a51e78daf0d8881f16dc8f7b07a5dc 2007.1/x86_64/qt4-assistant-4.2.3-3.1mdv2007.1.x86_64.rpm
e265a3118ae727234e4a4629d3880b0c 2007.1/x86_64/qt4-codecs-plugin-lib64-4.2.3-3.1mdv2007.1.x86_64.rpm
9cbdac1dbd9577f2615aec437dd2a820 2007.1/x86_64/qt4-common-4.2.3-3.1mdv2007.1.x86_64.rpm
78fca500d8fc0b99f11cb725771fd425 2007.1/x86_64/qt4-database-plugin-mysql-lib64-4.2.3-3.1mdv2007.1.x86_64.rpm
0ba5ddc3f6c51c030e0a64e7c4b33bf2 2007.1/x86_64/qt4-database-plugin-odbc-lib64-4.2.3-3.1mdv2007.1.x86_64.rpm
24f3b137e7f37b315c32941ca8f58e93 2007.1/x86_64/qt4-database-plugin-pgsql-lib64-4.2.3-3.1mdv2007.1.x86_64.rpm
46ddc628bf0fb8d14c6c69c3f826d04b 2007.1/x86_64/qt4-database-plugin-sqlite-lib64-4.2.3-3.1mdv2007.1.x86_64.rpm
e18a5b04a7f3cb7589874f963fd19103 2007.1/x86_64/qt4-designer-4.2.3-3.1mdv2007.1.x86_64.rpm
98107870e8ab186b75084c8b06c63010 2007.1/x86_64/qt4-doc-4.2.3-3.1mdv2007.1.x86_64.rpm
2ee5093fe0eb73b11504280c766d5189 2007.1/x86_64/qt4-examples-4.2.3-3.1mdv2007.1.x86_64.rpm
072c393731dc65be6aa5be766ba4a8ab 2007.1/x86_64/qt4-linguist-4.2.3-3.1mdv2007.1.x86_64.rpm
779e7927c2794237ef63229abbfdf184 2007.1/x86_64/qt4-qvfb-4.2.3-3.1mdv2007.1.x86_64.rpm
7c3cb09e24ab578e3c3b007388531eb9 2007.1/x86_64/qt4-tutorial-4.2.3-3.1mdv2007.1.x86_64.rpm
6202f4bff99c06561f8bd2bd62989985 2007.1/SRPMS/qt4-4.2.3-3.1mdv2007.1.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGHCOamqjQ0CJFipgRAnp3AKCNd2uFyCPQjzuakePBzkRA/77+vACghXZt
B1k8y9Tl7nfpfBXwUnBNX+M=
=R1lg
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007075_1__updated_qt4_packages_to_address_utf8_decoder_bug.html)