[Security Announce] [ MDKSA-2007:021 ] - Updated xpdf packages fix crafted pdf file vulnerability
Posted on: 01/18/2007 11:05 PM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2007:021
http://www.mandriva.com/security/
_______________________________________________________________________

Package : xpdf
Date : January 18, 2007
Affected: 2007.0, Corporate 3.0, Corporate 4.0
_______________________________________________________________________

Problem Description:

The Adobe PDF specification 1.3, as implemented by xpdf 3.0.1 patch 2,
kpdf in KDE before 3.5.5, and other products, allows remote attackers
to have an unknown impact, possibly including denial of service
(infinite loop), arbitrary code execution, or memory corruption, via a
PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages
attribute that references an invalid page tree node.

The updated packages have been patched to correct this problem.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0104
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2007.0:
e34f95bfcc5bee00a123ee84d9e14aba 2007.0/i586/xpdf-3.01pl2-3.1mdv2007.0.i586.rpm
9fbbb1a928599ec327501ea350b8871a 2007.0/i586/xpdf-tools-3.01pl2-3.1mdv2007.0.i586.rpm
19112d086453c2fdb928011fe6f7aa0c 2007.0/SRPMS/xpdf-3.01pl2-3.1mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64:
76e9749a053f7162c894741884c89835 2007.0/x86_64/xpdf-3.01pl2-3.1mdv2007.0.x86_64.rpm
f20e65b356ec330fd60e095add93d04a 2007.0/x86_64/xpdf-tools-3.01pl2-3.1mdv2007.0.x86_64.rpm
19112d086453c2fdb928011fe6f7aa0c 2007.0/SRPMS/xpdf-3.01pl2-3.1mdv2007.0.src.rpm

Corporate 3.0:
39a410e5887ddda80b0a2c4541082d50 corporate/3.0/i586/xpdf-3.00-5.9.C30mdk.i586.rpm
d4e017b43f39e1dd0e3d8367c62633d2 corporate/3.0/SRPMS/xpdf-3.00-5.9.C30mdk.src.rpm

Corporate 3.0/X86_64:
e01a2822cf592a56d89a13b73b8fa133 corporate/3.0/x86_64/xpdf-3.00-5.9.C30mdk.x86_64.rpm
d4e017b43f39e1dd0e3d8367c62633d2 corporate/3.0/SRPMS/xpdf-3.00-5.9.C30mdk.src.rpm

Corporate 4.0:
9899a75731800c052d32a7e8cfceedf4 corporate/4.0/i586/xpdf-3.01-1.3.20060mlcs4.i586.rpm
0c9969ce74ae66d95ff902181f83e0e5 corporate/4.0/SRPMS/xpdf-3.01-1.3.20060mlcs4.src.rpm

Corporate 4.0/X86_64:
5d2343239f0e46efa4df3c81a0c14191 corporate/4.0/x86_64/xpdf-3.01-1.3.20060mlcs4.x86_64.rpm
0c9969ce74ae66d95ff902181f83e0e5 corporate/4.0/SRPMS/xpdf-3.01-1.3.20060mlcs4.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFr7Y6mqjQ0CJFipgRAlm4AKDovSG9ZcNC+0wPIkPbAeKFjiO1GgCfVdtX
8bsgpC4xTvUU6p70qCB5ffU=
=4Q/3
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2007021__updated_xpdf_packages_fix_crafted_pdf_file_vulnerability.html)