[Security Announce] [ MDKSA-2006:152 ] - Updated wireshark packages fix multiple vulnerabilities
Posted on: 08/26/2006 12:15 AM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2006:152
http://www.mandriva.com/security/
_______________________________________________________________________

Package : wireshark
Date : August 25, 2006
Affected: 2006.0
_______________________________________________________________________

Problem Description:

Vulnerabilities in the SCSI, DHCP, and SSCOP dissectors were discovered
in versions of wireshark less than 0.99.3, as well as an off-by-one
error in the IPsec ESP preference parser if compiled with ESP
decryption support.

This updated provides wireshark 0.99.3a which is not vulnerable to
these issues.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4330
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4331
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4332
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006:4333
http://www.wireshark.org/security/wnpa-sec-2006-02.html
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2006.0:
1f1b6dde31ccffecec0becac8030d9de 2006.0/RPMS/libwireshark0-0.99.3a-0.1.20060mdk.i586.rpm
cb9cdd31a4c90304c914321ab3dfd2a4 2006.0/RPMS/tshark-0.99.3a-0.1.20060mdk.i586.rpm
8e74c5353478976f0ee6d71e3b46e86a 2006.0/RPMS/wireshark-0.99.3a-0.1.20060mdk.i586.rpm
2e67c0eb582071bd8c2e54aca4f62ba2 2006.0/RPMS/wireshark-tools-0.99.3a-0.1.20060mdk.i586.rpm
6eec092b55f355784be22b3d882d3dd0 2006.0/SRPMS/wireshark-0.99.3a-0.1.20060mdk.src.rpm

Mandriva Linux 2006.0/X86_64:
37fa691ba28677df6151fea044cf8bab x86_64/2006.0/RPMS/lib64wireshark0-0.99.3a-0.1.20060mdk.x86_64.rpm
589494b9575fff2893a18e512bf16111 x86_64/2006.0/RPMS/tshark-0.99.3a-0.1.20060mdk.x86_64.rpm
2985ec930be990b4112fa43b126b5b2c x86_64/2006.0/RPMS/wireshark-0.99.3a-0.1.20060mdk.x86_64.rpm
29698141534040ce6b1dbb9cd9b3f995 x86_64/2006.0/RPMS/wireshark-tools-0.99.3a-0.1.20060mdk.x86_64.rpm
6eec092b55f355784be22b3d882d3dd0 x86_64/2006.0/SRPMS/wireshark-0.99.3a-0.1.20060mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQFE7zremqjQ0CJFipgRAteLAKDr+0EFhFCPqWs/3q7ZETGla1MA2QCg8TfP
C/n/UOGWePIE2rx4Ifk2YIQ=
=GRsZ
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2006152__updated_wireshark_packages_fix_multiple_vulnerabilities.html)