[Security Announce] [ MDKSA-2006:130 ] - Updated kdelibs packages fix konqueror crash vulnerability.
Posted on: 07/21/2006 02:12 AM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2006:130
http://www.mandriva.com/security/
_______________________________________________________________________

Package : kdelibs
Date : July 20, 2006
Affected: 2006.0
_______________________________________________________________________

Problem Description:

KDE Konqueror 3.5.1 and earlier allows remote attackers to cause a denial
of service (application crash) by calling the replaceChild method on a
DOM object, which triggers a null dereference, as demonstrated by calling
document.replaceChild with a 0 (zero) argument.

This issue does not affect Corporate 3.0.

Updated packages have been patched to correct this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3672
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2006.0:
9c08048d1eae88a7b1969464d026383d 2006.0/RPMS/kdelibs-common-3.4.2-31.4.20060mdk.i586.rpm
03181cb4ee659c54cde567e36bb8d0ee 2006.0/RPMS/kdelibs-devel-doc-3.4.2-31.4.20060mdk.i586.rpm
5a1e16d3e441004c80ced1a4537fa9a5 2006.0/RPMS/libkdecore4-3.4.2-31.4.20060mdk.i586.rpm
2dfd44b73866f4a8551f9368553a1d44 2006.0/RPMS/libkdecore4-devel-3.4.2-31.4.20060mdk.i586.rpm
76afd9e941b89499e0e3b4bf2045ffad 2006.0/SRPMS/kdelibs-3.4.2-31.4.20060mdk.src.rpm

Mandriva Linux 2006.0/X86_64:
5de19da9121964246ee06c9eab9ece91 x86_64/2006.0/RPMS/kdelibs-common-3.4.2-31.4.20060mdk.x86_64.rpm
392daaeb1744ea56dfd6005c0ee1500a x86_64/2006.0/RPMS/kdelibs-devel-doc-3.4.2-31.4.20060mdk.x86_64.rpm
4a2b6d8f83f9d5d00b2272334ddf6f24 x86_64/2006.0/RPMS/lib64kdecore4-3.4.2-31.4.20060mdk.x86_64.rpm
137d119a30a44a9abc4d221354883599 x86_64/2006.0/RPMS/lib64kdecore4-devel-3.4.2-31.4.20060mdk.x86_64.rpm
5a1e16d3e441004c80ced1a4537fa9a5 x86_64/2006.0/RPMS/libkdecore4-3.4.2-31.4.20060mdk.i586.rpm
2dfd44b73866f4a8551f9368553a1d44 x86_64/2006.0/RPMS/libkdecore4-devel-3.4.2-31.4.20060mdk.i586.rpm
76afd9e941b89499e0e3b4bf2045ffad x86_64/2006.0/SRPMS/kdelibs-3.4.2-31.4.20060mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQFEv+5ymqjQ0CJFipgRAqSDAJ4ycbtCUKmCDqnVlOhdr3Ttm4CD1gCglwCr
1qShFrVNRkicIV7VRZfOmiY=
=WFx4
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdksa_2006130__updated_kdelibs_packages_fix_konqueror_crash_vulnerability.html)