[Security Announce] [ MDKA-2007:124 ] - Updated openafs packages fix various bugs
Posted on: 11/30/2007 11:55 PM

The Mandriva Security Team published a new security update for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Advisory MDKA-2007:124
http://www.mandriva.com/security/
_______________________________________________________________________

Package : openafs
Date : November 30, 2007
Affected: 2008.0
_______________________________________________________________________

Problem Description:

This update addresses the following bugs in the openafs package:

The openafs kernel module does not work on the x86_64 platform,
triggering a kernel oops as soon as it is loaded.

The openafs package was compiled with wrong gcc 4.2 compiler
optimisations which prevented it from listing directory contents.

This update fixes these issues.
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2008.0:
c1548634edaefd0ee7f98488a0742a9b 2008.0/i586/dkms-libafs-1.4.4-6mdv2008.0.i586.rpm
779d6fe07792e9830b005cc567f23812 2008.0/i586/libopenafs1-1.4.4-6mdv2008.0.i586.rpm
8b391ad3c7136253767778db725bb30a 2008.0/i586/libopenafs1-devel-1.4.4-6mdv2008.0.i586.rpm
6ba260980a9624e7753c82c5a119e96d 2008.0/i586/openafs-1.4.4-6mdv2008.0.i586.rpm
b6ded5045fd37ae112e90c9b4c3a3fc7 2008.0/i586/openafs-client-1.4.4-6mdv2008.0.i586.rpm
49d809ab171ded1a17e19a7c57c91255 2008.0/i586/openafs-doc-1.4.4-6mdv2008.0.i586.rpm
08cc686cfa6a8e81c31b0c23285237bc 2008.0/i586/openafs-server-1.4.4-6mdv2008.0.i586.rpm
1a53e9b31fc38da5f8a5a9315e1570ab 2008.0/SRPMS/openafs-1.4.4-6mdv2008.0.src.rpm

Mandriva Linux 2008.0/X86_64:
db058a1f6a52924be67d5645ba8175ab 2008.0/x86_64/dkms-libafs-1.4.4-6mdv2008.0.x86_64.rpm
e8f7742f003b57bab70c279dbf4b34a3 2008.0/x86_64/lib64openafs1-1.4.4-6mdv2008.0.x86_64.rpm
f02324711a4e136b156278e005872a74 2008.0/x86_64/lib64openafs1-devel-1.4.4-6mdv2008.0.x86_64.rpm
e08ead17b477ee363c1b236c343b5fe1 2008.0/x86_64/openafs-1.4.4-6mdv2008.0.x86_64.rpm
0e3feddeb1682e9b31e108cc79bc7ccd 2008.0/x86_64/openafs-client-1.4.4-6mdv2008.0.x86_64.rpm
f58cd3f22d08cda2d93bc46b94d0eefd 2008.0/x86_64/openafs-doc-1.4.4-6mdv2008.0.x86_64.rpm
faaf1c96ec92007d2d25fdbec72c7e78 2008.0/x86_64/openafs-server-1.4.4-6mdv2008.0.x86_64.rpm
1a53e9b31fc38da5f8a5a9315e1570ab 2008.0/SRPMS/openafs-1.4.4-6mdv2008.0.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFHUFkDmqjQ0CJFipgRAtgpAJ0Uu8sAiI9TgPAFrWUgj73MQxRZiwCgyMYx
MG+wvONu4qMiOwjcfxIDEVg=
=lxHI
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/security_announce_mdka_2007124__updated_openafs_packages_fix_various_bugs.html)