RHSA-2009:1485-01 Moderate: postgresql security update
Posted on: 10/07/2009 06:00 PM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: postgresql security update
Advisory ID: RHSA-2009:1485-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2009-1485.html
Issue date: 2009-10-07
CVE Names: CVE-2009-3230
=====================================================================

1. Summary:

Updated postgresql packages that fix a security issue are now available for
Red Hat Enterprise Linux 3.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Desktop version 3 - i386, x86_64
Red Hat Enterprise Linux AS version 3 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux ES version 3 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 3 - i386, ia64, x86_64

3. Description:

PostgreSQL is an advanced object-relational database management system
(DBMS).

It was discovered that the upstream patch for CVE-2007-6600 included in the
Red Hat Security Advisory RHSA-2008:0039 did not include protection against
misuse of the RESET ROLE and RESET SESSION AUTHORIZATION commands. An
authenticated user could use this flaw to install malicious code that would
later execute with superuser privileges. (CVE-2009-3230)

All PostgreSQL users should upgrade to these updated packages, which
contain a backported patch to correct this issue. If you are running a
PostgreSQL server, the postgresql service must be restarted for this update
to take effect.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

522085 - CVE-2009-3230 postgresql: SQL privilege escalation, incomplete fix for CVE-2007-6600

6. Package List:

Red Hat Enterprise Linux AS version 3:

Source:
ftp://updates.redhat.com/enterprise/3AS/en/os/SRPMS/rh-postgresql-7.3.21-2.src.rpm

i386:
rh-postgresql-7.3.21-2.i386.rpm
rh-postgresql-contrib-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-devel-7.3.21-2.i386.rpm
rh-postgresql-docs-7.3.21-2.i386.rpm
rh-postgresql-jdbc-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-pl-7.3.21-2.i386.rpm
rh-postgresql-python-7.3.21-2.i386.rpm
rh-postgresql-server-7.3.21-2.i386.rpm
rh-postgresql-tcl-7.3.21-2.i386.rpm
rh-postgresql-test-7.3.21-2.i386.rpm

ia64:
rh-postgresql-7.3.21-2.ia64.rpm
rh-postgresql-contrib-7.3.21-2.ia64.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.ia64.rpm
rh-postgresql-devel-7.3.21-2.ia64.rpm
rh-postgresql-docs-7.3.21-2.ia64.rpm
rh-postgresql-jdbc-7.3.21-2.ia64.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.ia64.rpm
rh-postgresql-pl-7.3.21-2.ia64.rpm
rh-postgresql-python-7.3.21-2.ia64.rpm
rh-postgresql-server-7.3.21-2.ia64.rpm
rh-postgresql-tcl-7.3.21-2.ia64.rpm
rh-postgresql-test-7.3.21-2.ia64.rpm

ppc:
rh-postgresql-7.3.21-2.ppc.rpm
rh-postgresql-contrib-7.3.21-2.ppc.rpm
rh-postgresql-debuginfo-7.3.21-2.ppc.rpm
rh-postgresql-debuginfo-7.3.21-2.ppc64.rpm
rh-postgresql-devel-7.3.21-2.ppc.rpm
rh-postgresql-docs-7.3.21-2.ppc.rpm
rh-postgresql-jdbc-7.3.21-2.ppc.rpm
rh-postgresql-libs-7.3.21-2.ppc.rpm
rh-postgresql-libs-7.3.21-2.ppc64.rpm
rh-postgresql-pl-7.3.21-2.ppc.rpm
rh-postgresql-python-7.3.21-2.ppc.rpm
rh-postgresql-server-7.3.21-2.ppc.rpm
rh-postgresql-tcl-7.3.21-2.ppc.rpm
rh-postgresql-test-7.3.21-2.ppc.rpm

s390:
rh-postgresql-7.3.21-2.s390.rpm
rh-postgresql-contrib-7.3.21-2.s390.rpm
rh-postgresql-debuginfo-7.3.21-2.s390.rpm
rh-postgresql-devel-7.3.21-2.s390.rpm
rh-postgresql-docs-7.3.21-2.s390.rpm
rh-postgresql-jdbc-7.3.21-2.s390.rpm
rh-postgresql-libs-7.3.21-2.s390.rpm
rh-postgresql-pl-7.3.21-2.s390.rpm
rh-postgresql-python-7.3.21-2.s390.rpm
rh-postgresql-server-7.3.21-2.s390.rpm
rh-postgresql-tcl-7.3.21-2.s390.rpm
rh-postgresql-test-7.3.21-2.s390.rpm

s390x:
rh-postgresql-7.3.21-2.s390x.rpm
rh-postgresql-contrib-7.3.21-2.s390x.rpm
rh-postgresql-debuginfo-7.3.21-2.s390.rpm
rh-postgresql-debuginfo-7.3.21-2.s390x.rpm
rh-postgresql-devel-7.3.21-2.s390x.rpm
rh-postgresql-docs-7.3.21-2.s390x.rpm
rh-postgresql-jdbc-7.3.21-2.s390x.rpm
rh-postgresql-libs-7.3.21-2.s390.rpm
rh-postgresql-libs-7.3.21-2.s390x.rpm
rh-postgresql-pl-7.3.21-2.s390x.rpm
rh-postgresql-python-7.3.21-2.s390x.rpm
rh-postgresql-server-7.3.21-2.s390x.rpm
rh-postgresql-tcl-7.3.21-2.s390x.rpm
rh-postgresql-test-7.3.21-2.s390x.rpm

x86_64:
rh-postgresql-7.3.21-2.x86_64.rpm
rh-postgresql-contrib-7.3.21-2.x86_64.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.x86_64.rpm
rh-postgresql-devel-7.3.21-2.x86_64.rpm
rh-postgresql-docs-7.3.21-2.x86_64.rpm
rh-postgresql-jdbc-7.3.21-2.x86_64.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.x86_64.rpm
rh-postgresql-pl-7.3.21-2.x86_64.rpm
rh-postgresql-python-7.3.21-2.x86_64.rpm
rh-postgresql-server-7.3.21-2.x86_64.rpm
rh-postgresql-tcl-7.3.21-2.x86_64.rpm
rh-postgresql-test-7.3.21-2.x86_64.rpm

Red Hat Desktop version 3:

Source:
ftp://updates.redhat.com/enterprise/3desktop/en/os/SRPMS/rh-postgresql-7.3.21-2.src.rpm

i386:
rh-postgresql-7.3.21-2.i386.rpm
rh-postgresql-contrib-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-devel-7.3.21-2.i386.rpm
rh-postgresql-docs-7.3.21-2.i386.rpm
rh-postgresql-jdbc-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-pl-7.3.21-2.i386.rpm
rh-postgresql-python-7.3.21-2.i386.rpm
rh-postgresql-server-7.3.21-2.i386.rpm
rh-postgresql-tcl-7.3.21-2.i386.rpm
rh-postgresql-test-7.3.21-2.i386.rpm

x86_64:
rh-postgresql-7.3.21-2.x86_64.rpm
rh-postgresql-contrib-7.3.21-2.x86_64.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.x86_64.rpm
rh-postgresql-devel-7.3.21-2.x86_64.rpm
rh-postgresql-docs-7.3.21-2.x86_64.rpm
rh-postgresql-jdbc-7.3.21-2.x86_64.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.x86_64.rpm
rh-postgresql-pl-7.3.21-2.x86_64.rpm
rh-postgresql-python-7.3.21-2.x86_64.rpm
rh-postgresql-server-7.3.21-2.x86_64.rpm
rh-postgresql-tcl-7.3.21-2.x86_64.rpm
rh-postgresql-test-7.3.21-2.x86_64.rpm

Red Hat Enterprise Linux ES version 3:

Source:
ftp://updates.redhat.com/enterprise/3ES/en/os/SRPMS/rh-postgresql-7.3.21-2.src.rpm

i386:
rh-postgresql-7.3.21-2.i386.rpm
rh-postgresql-contrib-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-devel-7.3.21-2.i386.rpm
rh-postgresql-docs-7.3.21-2.i386.rpm
rh-postgresql-jdbc-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-pl-7.3.21-2.i386.rpm
rh-postgresql-python-7.3.21-2.i386.rpm
rh-postgresql-server-7.3.21-2.i386.rpm
rh-postgresql-tcl-7.3.21-2.i386.rpm
rh-postgresql-test-7.3.21-2.i386.rpm

ia64:
rh-postgresql-7.3.21-2.ia64.rpm
rh-postgresql-contrib-7.3.21-2.ia64.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.ia64.rpm
rh-postgresql-devel-7.3.21-2.ia64.rpm
rh-postgresql-docs-7.3.21-2.ia64.rpm
rh-postgresql-jdbc-7.3.21-2.ia64.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.ia64.rpm
rh-postgresql-pl-7.3.21-2.ia64.rpm
rh-postgresql-python-7.3.21-2.ia64.rpm
rh-postgresql-server-7.3.21-2.ia64.rpm
rh-postgresql-tcl-7.3.21-2.ia64.rpm
rh-postgresql-test-7.3.21-2.ia64.rpm

x86_64:
rh-postgresql-7.3.21-2.x86_64.rpm
rh-postgresql-contrib-7.3.21-2.x86_64.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.x86_64.rpm
rh-postgresql-devel-7.3.21-2.x86_64.rpm
rh-postgresql-docs-7.3.21-2.x86_64.rpm
rh-postgresql-jdbc-7.3.21-2.x86_64.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.x86_64.rpm
rh-postgresql-pl-7.3.21-2.x86_64.rpm
rh-postgresql-python-7.3.21-2.x86_64.rpm
rh-postgresql-server-7.3.21-2.x86_64.rpm
rh-postgresql-tcl-7.3.21-2.x86_64.rpm
rh-postgresql-test-7.3.21-2.x86_64.rpm

Red Hat Enterprise Linux WS version 3:

Source:
ftp://updates.redhat.com/enterprise/3WS/en/os/SRPMS/rh-postgresql-7.3.21-2.src.rpm

i386:
rh-postgresql-7.3.21-2.i386.rpm
rh-postgresql-contrib-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-devel-7.3.21-2.i386.rpm
rh-postgresql-docs-7.3.21-2.i386.rpm
rh-postgresql-jdbc-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-pl-7.3.21-2.i386.rpm
rh-postgresql-python-7.3.21-2.i386.rpm
rh-postgresql-server-7.3.21-2.i386.rpm
rh-postgresql-tcl-7.3.21-2.i386.rpm
rh-postgresql-test-7.3.21-2.i386.rpm

ia64:
rh-postgresql-7.3.21-2.ia64.rpm
rh-postgresql-contrib-7.3.21-2.ia64.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.ia64.rpm
rh-postgresql-devel-7.3.21-2.ia64.rpm
rh-postgresql-docs-7.3.21-2.ia64.rpm
rh-postgresql-jdbc-7.3.21-2.ia64.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.ia64.rpm
rh-postgresql-pl-7.3.21-2.ia64.rpm
rh-postgresql-python-7.3.21-2.ia64.rpm
rh-postgresql-server-7.3.21-2.ia64.rpm
rh-postgresql-tcl-7.3.21-2.ia64.rpm
rh-postgresql-test-7.3.21-2.ia64.rpm

x86_64:
rh-postgresql-7.3.21-2.x86_64.rpm
rh-postgresql-contrib-7.3.21-2.x86_64.rpm
rh-postgresql-debuginfo-7.3.21-2.i386.rpm
rh-postgresql-debuginfo-7.3.21-2.x86_64.rpm
rh-postgresql-devel-7.3.21-2.x86_64.rpm
rh-postgresql-docs-7.3.21-2.x86_64.rpm
rh-postgresql-jdbc-7.3.21-2.x86_64.rpm
rh-postgresql-libs-7.3.21-2.i386.rpm
rh-postgresql-libs-7.3.21-2.x86_64.rpm
rh-postgresql-pl-7.3.21-2.x86_64.rpm
rh-postgresql-python-7.3.21-2.x86_64.rpm
rh-postgresql-server-7.3.21-2.x86_64.rpm
rh-postgresql-tcl-7.3.21-2.x86_64.rpm
rh-postgresql-test-7.3.21-2.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3230
http://www.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2009 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFKzMMLXlSAg2UNWIIRAnEQAJ4hiF1DpuVz9O5R8MdZky7pfsFhigCeIwGl
CdzKgIJTzIiTIJJaIf3961Y=
=oAmT
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_20091485_01_moderate_postgresql_security_update.html)