RHSA-2009:1127-01 Critical: kdelibs security update
Posted on: 06/25/2009 07:50 PM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: kdelibs security update
Advisory ID: RHSA-2009:1127-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2009-1127.html
Issue date: 2009-06-25
CVE Names: CVE-2009-1687 CVE-2009-1690 CVE-2009-1698
=====================================================================

1. Summary:

Updated kdelibs packages that fix multiple security issues are now
available for Red Hat Enterprise Linux 4 and 5.

This update has been rated as having critical security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64
RHEL Desktop Workstation (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64

3. Description:

The kdelibs packages provide libraries for the K Desktop Environment (KDE).

A flaw was found in the way the KDE CSS parser handled content for the
CSS "style" attribute. A remote attacker could create a specially-crafted
CSS equipped HTML page, which once visited by an unsuspecting user, could
cause a denial of service (Konqueror crash) or, potentially, execute
arbitrary code with the privileges of the user running Konqueror.
(CVE-2009-1698)

A flaw was found in the way the KDE HTML parser handled content for the
HTML "head" element. A remote attacker could create a specially-crafted
HTML page, which once visited by an unsuspecting user, could cause a denial
of service (Konqueror crash) or, potentially, execute arbitrary code with
the privileges of the user running Konqueror. (CVE-2009-1690)

An integer overflow flaw, leading to a heap-based buffer overflow, was
found in the way the KDE JavaScript garbage collector handled memory
allocation requests. A remote attacker could create a specially-crafted
HTML page, which once visited by an unsuspecting user, could cause a denial
of service (Konqueror crash) or, potentially, execute arbitrary code with
the privileges of the user running Konqueror. (CVE-2009-1687)

Users should upgrade to these updated packages, which contain backported
patches to correct these issues. The desktop must be restarted (log out,
then log back in) for this update to take effect.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

505571 - CVE-2009-1690 kdelibs: KHTML Incorrect handling lt;headgt; element content once the lt;headgt; element was removed (DoS, ACE)
506453 - CVE-2009-1687 kdelibs: Integer overflow in KJS JavaScript garbage collector
506469 - CVE-2009-1698 kdelibs: KHTML CSS parser - incorrect handling CSS "style" attribute content (DoS, ACE)

6. Package List:

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/kdelibs-3.3.1-14.el4.src.rpm

i386:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-devel-3.3.1-14.el4.i386.rpm

ia64:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-3.3.1-14.el4.ia64.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.ia64.rpm
kdelibs-devel-3.3.1-14.el4.ia64.rpm

ppc:
kdelibs-3.3.1-14.el4.ppc.rpm
kdelibs-3.3.1-14.el4.ppc64.rpm
kdelibs-debuginfo-3.3.1-14.el4.ppc.rpm
kdelibs-debuginfo-3.3.1-14.el4.ppc64.rpm
kdelibs-devel-3.3.1-14.el4.ppc.rpm

s390:
kdelibs-3.3.1-14.el4.s390.rpm
kdelibs-debuginfo-3.3.1-14.el4.s390.rpm
kdelibs-devel-3.3.1-14.el4.s390.rpm

s390x:
kdelibs-3.3.1-14.el4.s390.rpm
kdelibs-3.3.1-14.el4.s390x.rpm
kdelibs-debuginfo-3.3.1-14.el4.s390.rpm
kdelibs-debuginfo-3.3.1-14.el4.s390x.rpm
kdelibs-devel-3.3.1-14.el4.s390x.rpm

x86_64:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-3.3.1-14.el4.x86_64.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.x86_64.rpm
kdelibs-devel-3.3.1-14.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/kdelibs-3.3.1-14.el4.src.rpm

i386:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-devel-3.3.1-14.el4.i386.rpm

x86_64:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-3.3.1-14.el4.x86_64.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.x86_64.rpm
kdelibs-devel-3.3.1-14.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/kdelibs-3.3.1-14.el4.src.rpm

i386:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-devel-3.3.1-14.el4.i386.rpm

ia64:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-3.3.1-14.el4.ia64.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.ia64.rpm
kdelibs-devel-3.3.1-14.el4.ia64.rpm

x86_64:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-3.3.1-14.el4.x86_64.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.x86_64.rpm
kdelibs-devel-3.3.1-14.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/kdelibs-3.3.1-14.el4.src.rpm

i386:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-devel-3.3.1-14.el4.i386.rpm

ia64:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-3.3.1-14.el4.ia64.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.ia64.rpm
kdelibs-devel-3.3.1-14.el4.ia64.rpm

x86_64:
kdelibs-3.3.1-14.el4.i386.rpm
kdelibs-3.3.1-14.el4.x86_64.rpm
kdelibs-debuginfo-3.3.1-14.el4.i386.rpm
kdelibs-debuginfo-3.3.1-14.el4.x86_64.rpm
kdelibs-devel-3.3.1-14.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/kdelibs-3.5.4-22.el5_3.src.rpm

i386:
kdelibs-3.5.4-22.el5_3.i386.rpm
kdelibs-apidocs-3.5.4-22.el5_3.i386.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.i386.rpm

x86_64:
kdelibs-3.5.4-22.el5_3.i386.rpm
kdelibs-3.5.4-22.el5_3.x86_64.rpm
kdelibs-apidocs-3.5.4-22.el5_3.x86_64.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.i386.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.x86_64.rpm

RHEL Desktop Workstation (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/kdelibs-3.5.4-22.el5_3.src.rpm

i386:
kdelibs-debuginfo-3.5.4-22.el5_3.i386.rpm
kdelibs-devel-3.5.4-22.el5_3.i386.rpm

x86_64:
kdelibs-debuginfo-3.5.4-22.el5_3.i386.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.x86_64.rpm
kdelibs-devel-3.5.4-22.el5_3.i386.rpm
kdelibs-devel-3.5.4-22.el5_3.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/kdelibs-3.5.4-22.el5_3.src.rpm

i386:
kdelibs-3.5.4-22.el5_3.i386.rpm
kdelibs-apidocs-3.5.4-22.el5_3.i386.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.i386.rpm
kdelibs-devel-3.5.4-22.el5_3.i386.rpm

ia64:
kdelibs-3.5.4-22.el5_3.ia64.rpm
kdelibs-apidocs-3.5.4-22.el5_3.ia64.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.ia64.rpm
kdelibs-devel-3.5.4-22.el5_3.ia64.rpm

ppc:
kdelibs-3.5.4-22.el5_3.ppc.rpm
kdelibs-3.5.4-22.el5_3.ppc64.rpm
kdelibs-apidocs-3.5.4-22.el5_3.ppc.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.ppc.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.ppc64.rpm
kdelibs-devel-3.5.4-22.el5_3.ppc.rpm
kdelibs-devel-3.5.4-22.el5_3.ppc64.rpm

s390x:
kdelibs-3.5.4-22.el5_3.s390.rpm
kdelibs-3.5.4-22.el5_3.s390x.rpm
kdelibs-apidocs-3.5.4-22.el5_3.s390x.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.s390.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.s390x.rpm
kdelibs-devel-3.5.4-22.el5_3.s390.rpm
kdelibs-devel-3.5.4-22.el5_3.s390x.rpm

x86_64:
kdelibs-3.5.4-22.el5_3.i386.rpm
kdelibs-3.5.4-22.el5_3.x86_64.rpm
kdelibs-apidocs-3.5.4-22.el5_3.x86_64.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.i386.rpm
kdelibs-debuginfo-3.5.4-22.el5_3.x86_64.rpm
kdelibs-devel-3.5.4-22.el5_3.i386.rpm
kdelibs-devel-3.5.4-22.el5_3.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1687
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1690
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1698
http://www.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2009 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFKQ6kVXlSAg2UNWIIRAo9XAJwKpMEhv/37duSqRlfqWFPKJuf6EwCfeAdz
lPsEfDtUGZRxsZL1OqEvr54=
=qIbs
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_20091127_01_critical_kdelibs_security_update.html)