RHSA-2009:0474-01 Moderate: acpid security update
Posted on: 05/07/2009 02:15 PM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: acpid security update
Advisory ID: RHSA-2009:0474-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2009-0474.html
Issue date: 2009-05-07
CVE Names: CVE-2009-0798
=====================================================================

1. Summary:

An updated acpid package that fixes one security issue is now available
for Red Hat Enterprise Linux 2.1, 3, 4, and 5.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - ia64
Red Hat Linux Advanced Workstation 2.1 - ia64
Red Hat Enterprise Linux AS version 3 - ia64, x86_64
Red Hat Desktop version 3 - x86_64
Red Hat Enterprise Linux ES version 3 - ia64, x86_64
Red Hat Enterprise Linux WS version 3 - ia64, x86_64
Red Hat Enterprise Linux AS version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, x86_64

3. Description:

acpid is a daemon that dispatches ACPI (Advanced Configuration and Power
Interface) events to user-space programs.

Anthony de Almeida Lopes of Outpost24 AB reported a denial of service flaw
in the acpid daemon's error handling. If an attacker could exhaust the
sockets open to acpid, the daemon would enter an infinite loop, consuming
most CPU resources and preventing acpid from communicating with legitimate
processes. (CVE-2009-0798)

Users are advised to upgrade to this updated package, which contains a
backported patch to correct this issue.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

494443 - CVE-2009-0798 acpid: too many open files DoS

6. Package List:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 :

Source:
ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/acpid-1.0.1-3.src.rpm

ia64:
acpid-1.0.1-3.ia64.rpm

Red Hat Linux Advanced Workstation 2.1:

Source:
ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/acpid-1.0.1-3.src.rpm

ia64:
acpid-1.0.1-3.ia64.rpm

Red Hat Enterprise Linux AS version 3:

Source:
ftp://updates.redhat.com/enterprise/3AS/en/os/SRPMS/acpid-1.0.2-4.src.rpm

ia64:
acpid-1.0.2-4.ia64.rpm
acpid-debuginfo-1.0.2-4.ia64.rpm

x86_64:
acpid-1.0.2-4.x86_64.rpm
acpid-debuginfo-1.0.2-4.x86_64.rpm

Red Hat Desktop version 3:

Source:
ftp://updates.redhat.com/enterprise/3desktop/en/os/SRPMS/acpid-1.0.2-4.src.rpm

x86_64:
acpid-1.0.2-4.x86_64.rpm
acpid-debuginfo-1.0.2-4.x86_64.rpm

Red Hat Enterprise Linux ES version 3:

Source:
ftp://updates.redhat.com/enterprise/3ES/en/os/SRPMS/acpid-1.0.2-4.src.rpm

ia64:
acpid-1.0.2-4.ia64.rpm
acpid-debuginfo-1.0.2-4.ia64.rpm

x86_64:
acpid-1.0.2-4.x86_64.rpm
acpid-debuginfo-1.0.2-4.x86_64.rpm

Red Hat Enterprise Linux WS version 3:

Source:
ftp://updates.redhat.com/enterprise/3WS/en/os/SRPMS/acpid-1.0.2-4.src.rpm

ia64:
acpid-1.0.2-4.ia64.rpm
acpid-debuginfo-1.0.2-4.ia64.rpm

x86_64:
acpid-1.0.2-4.x86_64.rpm
acpid-debuginfo-1.0.2-4.x86_64.rpm

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/acpid-1.0.3-2.el4_7.1.src.rpm

i386:
acpid-1.0.3-2.el4_7.1.i386.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.i386.rpm

ia64:
acpid-1.0.3-2.el4_7.1.ia64.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.ia64.rpm

x86_64:
acpid-1.0.3-2.el4_7.1.x86_64.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/acpid-1.0.3-2.el4_7.1.src.rpm

i386:
acpid-1.0.3-2.el4_7.1.i386.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.i386.rpm

x86_64:
acpid-1.0.3-2.el4_7.1.x86_64.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/acpid-1.0.3-2.el4_7.1.src.rpm

i386:
acpid-1.0.3-2.el4_7.1.i386.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.i386.rpm

ia64:
acpid-1.0.3-2.el4_7.1.ia64.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.ia64.rpm

x86_64:
acpid-1.0.3-2.el4_7.1.x86_64.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/acpid-1.0.3-2.el4_7.1.src.rpm

i386:
acpid-1.0.3-2.el4_7.1.i386.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.i386.rpm

ia64:
acpid-1.0.3-2.el4_7.1.ia64.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.ia64.rpm

x86_64:
acpid-1.0.3-2.el4_7.1.x86_64.rpm
acpid-debuginfo-1.0.3-2.el4_7.1.x86_64.rpm

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/acpid-1.0.4-7.el5_3.1.src.rpm

i386:
acpid-1.0.4-7.el5_3.1.i386.rpm
acpid-debuginfo-1.0.4-7.el5_3.1.i386.rpm

x86_64:
acpid-1.0.4-7.el5_3.1.x86_64.rpm
acpid-debuginfo-1.0.4-7.el5_3.1.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/acpid-1.0.4-7.el5_3.1.src.rpm

i386:
acpid-1.0.4-7.el5_3.1.i386.rpm
acpid-debuginfo-1.0.4-7.el5_3.1.i386.rpm

ia64:
acpid-1.0.4-7.el5_3.1.ia64.rpm
acpid-debuginfo-1.0.4-7.el5_3.1.ia64.rpm

x86_64:
acpid-1.0.4-7.el5_3.1.x86_64.rpm
acpid-debuginfo-1.0.4-7.el5_3.1.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0798
http://www.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2009 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFKAtM/XlSAg2UNWIIRAiaYAJ9MQYyTPAVgG2/e75hkNvCJllf3QACfZmKJ
j+KxVEO9pejENvy0T+Ef7rE=
=OjLT
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_20090474_01_moderate_acpid_security_update.html)