RHSA-2009:0444-01 Important: giflib security update
Posted on: 04/22/2009 08:55 PM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Important: giflib security update
Advisory ID: RHSA-2009:0444-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2009-0444.html
Issue date: 2009-04-22
CVE Names: CVE-2005-2974 CVE-2005-3350
=====================================================================

1. Summary:

Updated giflib packages that fix several security issues are now available
for Red Hat Enterprise Linux 5.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64
RHEL Desktop Workstation (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64

3. Description:

The giflib packages contain a shared library of functions for loading and
saving GIF image files. This library is API and ABI compatible with
libungif, the library that supported uncompressed GIF image files while the
Unisys LZW patent was in effect.

Several flaws were discovered in the way giflib decodes GIF images. An
attacker could create a carefully crafted GIF image that could cause an
application using giflib to crash or, possibly, execute arbitrary code when
opened by a victim. (CVE-2005-2974, CVE-2005-3350)

All users of giflib are advised to upgrade to these updated packages, which
contain backported patches to resolve these issues. All running
applications using giflib must be restarted for the update to take effect.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

494823 - CVE-2005-3350 giflib/libunfig: memory corruption via a crafted GIF
494826 - CVE-2005-2974 giflib/libunfig: NULL pointer dereference crash

6. Package List:

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/giflib-4.1.3-7.1.el5_3.1.src.rpm

i386:
giflib-4.1.3-7.1.el5_3.1.i386.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.i386.rpm
giflib-utils-4.1.3-7.1.el5_3.1.i386.rpm

x86_64:
giflib-4.1.3-7.1.el5_3.1.i386.rpm
giflib-4.1.3-7.1.el5_3.1.x86_64.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.i386.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.x86_64.rpm
giflib-utils-4.1.3-7.1.el5_3.1.x86_64.rpm

RHEL Desktop Workstation (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/giflib-4.1.3-7.1.el5_3.1.src.rpm

i386:
giflib-debuginfo-4.1.3-7.1.el5_3.1.i386.rpm
giflib-devel-4.1.3-7.1.el5_3.1.i386.rpm

x86_64:
giflib-debuginfo-4.1.3-7.1.el5_3.1.i386.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.x86_64.rpm
giflib-devel-4.1.3-7.1.el5_3.1.i386.rpm
giflib-devel-4.1.3-7.1.el5_3.1.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/giflib-4.1.3-7.1.el5_3.1.src.rpm

i386:
giflib-4.1.3-7.1.el5_3.1.i386.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.i386.rpm
giflib-devel-4.1.3-7.1.el5_3.1.i386.rpm
giflib-utils-4.1.3-7.1.el5_3.1.i386.rpm

ia64:
giflib-4.1.3-7.1.el5_3.1.ia64.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.ia64.rpm
giflib-devel-4.1.3-7.1.el5_3.1.ia64.rpm
giflib-utils-4.1.3-7.1.el5_3.1.ia64.rpm

ppc:
giflib-4.1.3-7.1.el5_3.1.ppc.rpm
giflib-4.1.3-7.1.el5_3.1.ppc64.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.ppc.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.ppc64.rpm
giflib-devel-4.1.3-7.1.el5_3.1.ppc.rpm
giflib-devel-4.1.3-7.1.el5_3.1.ppc64.rpm
giflib-utils-4.1.3-7.1.el5_3.1.ppc.rpm

s390x:
giflib-4.1.3-7.1.el5_3.1.s390.rpm
giflib-4.1.3-7.1.el5_3.1.s390x.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.s390.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.s390x.rpm
giflib-devel-4.1.3-7.1.el5_3.1.s390.rpm
giflib-devel-4.1.3-7.1.el5_3.1.s390x.rpm
giflib-utils-4.1.3-7.1.el5_3.1.s390x.rpm

x86_64:
giflib-4.1.3-7.1.el5_3.1.i386.rpm
giflib-4.1.3-7.1.el5_3.1.x86_64.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.i386.rpm
giflib-debuginfo-4.1.3-7.1.el5_3.1.x86_64.rpm
giflib-devel-4.1.3-7.1.el5_3.1.i386.rpm
giflib-devel-4.1.3-7.1.el5_3.1.x86_64.rpm
giflib-utils-4.1.3-7.1.el5_3.1.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2974
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3350
http://www.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2009 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFJ71cKXlSAg2UNWIIRAmrPAJ4jcuVPgKlrDBLIb2kSfL1oZVhhGQCeKJd3
xE9FcS2yXniv8trTUfjiScM=
=5rFW
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_20090444_01_important_giflib_security_update.html)