RHSA-2008:0618-01 Moderate: vim security update
Posted on: 11/25/2008 11:05 AM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: vim security update
Advisory ID: RHSA-2008:0618-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2008-0618.html
Issue date: 2008-11-25
CVE Names: CVE-2008-2712 CVE-2008-4101
=====================================================================

1. Summary:

Updated vim packages that fix security issues are now available for Red Hat
Enterprise Linux 2.1.

This update has been rated as having moderate security impact by the Red Hat
Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - i386, ia64
Red Hat Linux Advanced Workstation 2.1 - ia64
Red Hat Enterprise Linux ES version 2.1 - i386
Red Hat Enterprise Linux WS version 2.1 - i386

3. Description:

Vim (Visual editor IMproved) is an updated and improved version of the vi
editor.

Several input sanitization flaws were found in Vim's keyword and tag
handling. If Vim looked up a document's maliciously crafted tag or keyword,
it was possible to execute arbitrary code as the user running Vim.
(CVE-2008-4101)

Several input sanitization flaws were found in various Vim system
functions. If a user opened a specially crafted file, it was possible to
execute arbitrary code as the user running Vim. (CVE-2008-2712)

All Vim users are advised to upgrade to these updated packages, which
contain backported patches to correct these issues.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/FAQ_58_10188

5. Bugs fixed (http://bugzilla.redhat.com/):

451759 - CVE-2008-2712 vim: command execution via scripts not sanitizing inputs to execute and system
461927 - CVE-2008-4101 vim: arbitrary code execution in commands: K, Control-], g]

6. Package List:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 :

Source:
ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/vim-6.0-7.25.src.rpm

i386:
vim-X11-6.0-7.25.i386.rpm
vim-common-6.0-7.25.i386.rpm
vim-enhanced-6.0-7.25.i386.rpm
vim-minimal-6.0-7.25.i386.rpm

ia64:
vim-X11-6.0-7.25.ia64.rpm
vim-common-6.0-7.25.ia64.rpm
vim-enhanced-6.0-7.25.ia64.rpm
vim-minimal-6.0-7.25.ia64.rpm

Red Hat Linux Advanced Workstation 2.1:

Source:
ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/vim-6.0-7.25.src.rpm

ia64:
vim-X11-6.0-7.25.ia64.rpm
vim-common-6.0-7.25.ia64.rpm
vim-enhanced-6.0-7.25.ia64.rpm
vim-minimal-6.0-7.25.ia64.rpm

Red Hat Enterprise Linux ES version 2.1:

Source:
ftp://updates.redhat.com/enterprise/2.1ES/en/os/SRPMS/vim-6.0-7.25.src.rpm

i386:
vim-X11-6.0-7.25.i386.rpm
vim-common-6.0-7.25.i386.rpm
vim-enhanced-6.0-7.25.i386.rpm
vim-minimal-6.0-7.25.i386.rpm

Red Hat Enterprise Linux WS version 2.1:

Source:
ftp://updates.redhat.com/enterprise/2.1WS/en/os/SRPMS/vim-6.0-7.25.src.rpm

i386:
vim-X11-6.0-7.25.i386.rpm
vim-common-6.0-7.25.i386.rpm
vim-enhanced-6.0-7.25.i386.rpm
vim-minimal-6.0-7.25.i386.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2712
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-4101
http://www.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2008 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFJK76zXlSAg2UNWIIRAlfMAJ49jvlkwgpJCRvRUQ15d66rYVTMhQCgmYob
EHfIJ/0gkPusICXsv2IIlkY=
=1G6l
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_20080618_01_moderate_vim_security_update.html)