RHSA-2008:0161-01 Important: cups security update
Posted on: 02/25/2008 04:35 PM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Important: cups security update
Advisory ID: RHSA-2008:0161-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2008-0161.html
Issue date: 2008-02-25
CVE Names: CVE-2008-0596 CVE-2008-0597
=====================================================================

1. Summary:

Updated cups packages that fix two security issues are now available
for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

The Common UNIX Printing System (CUPS) provides a portable printing layer
for UNIX(R) operating systems.

A flaw was found in the way CUPS handled the addition and removal of remote
shared printers via IPP. A remote attacker could send malicious UDP IPP
packets causing the CUPS daemon to attempt to dereference already freed
memory and crash. (CVE-2008-0597)

A memory management flaw was found in the way CUPS handled the addition and
removal of remote shared printers via IPP. When shared printer was
removed, allocated memory was not properly freed, leading to a memory leak
possibly causing CUPS daemon crash after exhausting available memory.
(CVE-2008-0596)

These issues were found during the investigation of CVE-2008-0882, which
did not affect Red Hat Enterprise Linux 4.

Note that the default configuration of CUPS on Red Hat Enterprise Linux
4 allow requests of this type only from the local subnet.

All CUPS users are advised to upgrade to these updated packages, which
contain backported patches to resolve these issues.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/FAQ_58_10188

5. Bugs fixed (http://bugzilla.redhat.com/):

433825 - CVE-2008-0596 cups: memory leak handling IPP browse requests
433847 - CVE-2008-0597 cups: dereference of free'd memory handling IPP browse requests

6. Package List:

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/cups-1.1.22-0.rc1.9.20.2.el4_6.5.src.rpm

i386:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm

ia64:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm

ppc:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.ppc.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.ppc.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.ppc64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.ppc.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.ppc.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.ppc64.rpm

s390:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.s390.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.s390.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.s390.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.s390.rpm

s390x:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.s390x.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.s390.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.s390x.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.s390x.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.s390.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.s390x.rpm

x86_64:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/cups-1.1.22-0.rc1.9.20.2.el4_6.5.src.rpm

i386:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm

x86_64:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/cups-1.1.22-0.rc1.9.20.2.el4_6.5.src.rpm

i386:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm

ia64:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm

x86_64:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/cups-1.1.22-0.rc1.9.20.2.el4_6.5.src.rpm

i386:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm

ia64:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.ia64.rpm

x86_64:
cups-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-debuginfo-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-devel-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.i386.rpm
cups-libs-1.1.22-0.rc1.9.20.2.el4_6.5.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0596
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0597
http://www.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2008 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFHws+eXlSAg2UNWIIRAiLDAJ9/0vK7RxY5i8MPBSf5tvl/RM7lVACcCjUz
3IQgbJDXzJ9xpD+OUjWES7Y=
=B2Se
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_20080161_01_important_cups_security_update.html)