RHSA-2006:0674-01 Critical: flash-plugin security update
Posted on: 09/12/2006 07:55 PM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ---------------------------------------------------------------------
Red Hat Security Advisory

Synopsis: Critical: flash-plugin security update
Advisory ID: RHSA-2006:0674-01
Advisory URL: https://rhn.redhat.com/errata/RHSA-2006-0674.html
Issue date: 2006-09-12
Updated on: 2006-09-12
Product: Red Hat Enterprise Linux Extras
CVE Names: CVE-2006-3311 CVE-2006-3587 CVE-2006-3588
- ---------------------------------------------------------------------

1. Summary:

An updated Adobe Flash Player package that fixes security issues is now
available.

This update has been rated as having critical security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 3 Extras - i386
Red Hat Desktop version 3 Extras - i386
Red Hat Enterprise Linux ES version 3 Extras - i386
Red Hat Enterprise Linux WS version 3 Extras - i386
Red Hat Enterprise Linux AS version 4 Extras - i386
Red Hat Desktop version 4 Extras - i386
Red Hat Enterprise Linux ES version 4 Extras - i386
Red Hat Enterprise Linux WS version 4 Extras - i386

3. Problem description:

The flash-plugin package contains a Firefox-compatible Adobe Flash Player
browser plug-in.

Security issues were discovered in the Adobe Flash Player. It may be
possible to execute arbitrary code on a victim's machine if the victim
opens a malicious Adobe Flash file. (CVE-2006-3311, CVE-2006-3587,
CVE-2006-3588)

Users of Adobe Flash Player should upgrade to this updated package, which
contains version 7.0.68 and is not vulnerable to this issue.

Red Hat would like to thank Adobe for notifying us of these issues.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains
the desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/):

205983 - CVE-2006-3311 Multiple flash-plug flaws (CVE-2006-3587 CVE-2006-3588)

6. RPMs required:

Red Hat Enterprise Linux AS version 3 Extras:

i386:
e499c9e86a4f9bb37aaba7354984118a flash-plugin-7.0.68-1.el3.i386.rpm

Red Hat Desktop version 3 Extras:

i386:
e499c9e86a4f9bb37aaba7354984118a flash-plugin-7.0.68-1.el3.i386.rpm

Red Hat Enterprise Linux ES version 3 Extras:

i386:
e499c9e86a4f9bb37aaba7354984118a flash-plugin-7.0.68-1.el3.i386.rpm

Red Hat Enterprise Linux WS version 3 Extras:

i386:
e499c9e86a4f9bb37aaba7354984118a flash-plugin-7.0.68-1.el3.i386.rpm

Red Hat Enterprise Linux AS version 4 Extras:

i386:
f6e5fb516fc4edc28ca5c79fa2581f8f flash-plugin-7.0.68-1.el4.i386.rpm

Red Hat Desktop version 4 Extras:

i386:
f6e5fb516fc4edc28ca5c79fa2581f8f flash-plugin-7.0.68-1.el4.i386.rpm

Red Hat Enterprise Linux ES version 4 Extras:

i386:
f6e5fb516fc4edc28ca5c79fa2581f8f flash-plugin-7.0.68-1.el4.i386.rpm

Red Hat Enterprise Linux WS version 4 Extras:

i386:
f6e5fb516fc4edc28ca5c79fa2581f8f flash-plugin-7.0.68-1.el4.i386.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3311
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3587
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3588
http://www.adobe.com/support/security/bulletins/apsb06-11.html
http://www.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2006 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQFFBwHhXlSAg2UNWIIRAgH5AKCPz2dbYkmda0bu/lgwe/UJwu0y/ACgwG8v
Pkbuws411+Jy6thzIJd3/jg=
=fUuR
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_20060674_01_critical_flash_plugin_security_update.html)