RHSA-2005:803-01 Critical: lynx security update
Posted on: 10/17/2005 01:52 AM

A new update is available for Red Hat Enterprise Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ---------------------------------------------------------------------
Red Hat Security Advisory

Synopsis: Critical: lynx security update
Advisory ID: RHSA-2005:803-01
Advisory URL: https://rhn.redhat.com/errata/RHSA-2005-803.html
Issue date: 2005-10-17
Updated on: 2005-10-17
Product: Red Hat Enterprise Linux
CVE Names: CAN-2005-3120
- ---------------------------------------------------------------------

1. Summary:

An updated lynx package that corrects a security flaw is now available.

This update has been rated as having critical security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - i386, ia64
Red Hat Linux Advanced Workstation 2.1 - ia64
Red Hat Enterprise Linux ES version 2.1 - i386
Red Hat Enterprise Linux WS version 2.1 - i386
Red Hat Enterprise Linux AS version 3 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Desktop version 3 - i386, x86_64
Red Hat Enterprise Linux ES version 3 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 3 - i386, ia64, x86_64
Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

Lynx is a text-based Web browser.

Ulf Harnhammar discovered a stack overflow bug in Lynx when handling
connections to NNTP (news) servers. An attacker could create a web page
redirecting to a malicious news server which could execute arbitrary code
as the user running lynx. The Common Vulnerabilities and Exposures project
assigned the name CAN-2005-3120 to this issue.

Users should update to this erratum package, which contains a backported
patch to correct this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/):

170253 - CAN-2005-3120 lynx buffer overflow


6. RPMs required:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm

i386:
0d17fa55fcb0d090b95b70aee84b9d32 lynx-2.8.4-18.1.1.i386.rpm

ia64:
c6bf49b71290710e76a3e188d45a5c96 lynx-2.8.4-18.1.1.ia64.rpm

Red Hat Linux Advanced Workstation 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm

ia64:
c6bf49b71290710e76a3e188d45a5c96 lynx-2.8.4-18.1.1.ia64.rpm

Red Hat Enterprise Linux ES version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1ES/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm

i386:
0d17fa55fcb0d090b95b70aee84b9d32 lynx-2.8.4-18.1.1.i386.rpm

Red Hat Enterprise Linux WS version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1WS/en/os/SRPMS/lynx-2.8.4-18.1.1.src.rpm
60a69f80b73d527c0245b4ed65a5cbb7 lynx-2.8.4-18.1.1.src.rpm

i386:
0d17fa55fcb0d090b95b70aee84b9d32 lynx-2.8.4-18.1.1.i386.rpm

Red Hat Enterprise Linux AS version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3AS/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm

i386:
4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm

ia64:
78719dbe540537935c8ff0580a2e0d81 lynx-2.8.5-11.1.ia64.rpm

ppc:
f2eac36b447292abc662862220bfb06a lynx-2.8.5-11.1.ppc.rpm

s390:
0a54265e85c70269d716143f516ba4c8 lynx-2.8.5-11.1.s390.rpm

s390x:
e6954205d07620602060a637f256427b lynx-2.8.5-11.1.s390x.rpm

x86_64:
d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm

Red Hat Desktop version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3desktop/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm

i386:
4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm

x86_64:
d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm

Red Hat Enterprise Linux ES version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3ES/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm

i386:
4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm

ia64:
78719dbe540537935c8ff0580a2e0d81 lynx-2.8.5-11.1.ia64.rpm

x86_64:
d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm

Red Hat Enterprise Linux WS version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3WS/en/os/SRPMS/lynx-2.8.5-11.1.src.rpm
ca0e6cecdbe5d962ba2e0e25906f06c3 lynx-2.8.5-11.1.src.rpm

i386:
4fbf85314f748e70d688d4ef9f1ff039 lynx-2.8.5-11.1.i386.rpm

ia64:
78719dbe540537935c8ff0580a2e0d81 lynx-2.8.5-11.1.ia64.rpm

x86_64:
d5b28eee28b96bfc485c931bc70f6c8a lynx-2.8.5-11.1.x86_64.rpm

Red Hat Enterprise Linux AS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm

i386:
4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm

ia64:
8e3a4b2cc33e6df7fef19930cc691989 lynx-2.8.5-18.1.ia64.rpm

ppc:
e6e33d53c3eca23c054c697b2c950bde lynx-2.8.5-18.1.ppc.rpm

s390:
03c82d440c67572bf89a32af3b736794 lynx-2.8.5-18.1.s390.rpm

s390x:
b6c47ed03460baeeab046340e937c857 lynx-2.8.5-18.1.s390x.rpm

x86_64:
02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm

i386:
4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm

x86_64:
02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm

i386:
4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm

ia64:
8e3a4b2cc33e6df7fef19930cc691989 lynx-2.8.5-18.1.ia64.rpm

x86_64:
02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/lynx-2.8.5-18.1.src.rpm
ffba2de47eba8a232bc7105f5cbefd3d lynx-2.8.5-18.1.src.rpm

i386:
4513cdfc3723631c7782f6352cdc6b15 lynx-2.8.5-18.1.i386.rpm

ia64:
8e3a4b2cc33e6df7fef19930cc691989 lynx-2.8.5-18.1.ia64.rpm

x86_64:
02db15ab7e3205f8909e6f7e859f84f3 lynx-2.8.5-18.1.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?nameƊN-2005-3120

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2005 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQFDU1jxXlSAg2UNWIIRAn7VAKCnW7/kMwAob48Dgf+QTHXCLjBgJwCcCbyL
pTJbDK8BrZGuj6koo+AcWb8=
=kALV
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_2005803_01_critical_lynx_security_update.html)