RHSA-2005:393-01: Important: kdelibs security update
Posted on: 05/17/2005 01:52 PM

A kdelibs update has been released for Red Hat Enterprise Linux 4

----------------------------------------------------------------------
Red Hat Security Advisory

Synopsis: Important: kdelibs security update
Advisory ID: RHSA-2005:393-01
Advisory URL: https://rhn.redhat.com/errata/RHSA-2005-393.html
Issue date: 2005-05-17
Updated on: 2005-05-17
Product: Red Hat Enterprise Linux
CVE Names: CAN-2005-1046
----------------------------------------------------------------------

1. Summary:

Updated kdelibs packages that fix a flaw in kimgio input validation are now available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

KDE is a graphical desktop environment for the X Window System. Konqueror is the file manager for the K Desktop Environment.

A source code audit performed by the KDE security team discovered several vulnerabilities in the PCX and other image file format readers.

A buffer overflow was found in the kimgio library for KDE 3.4.0. An attacker could create a carefully crafted PCX image in such a way that it would cause kimgio to execute arbitrary code when processing the image. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2005-1046 to this issue.

All users of kdelibs should upgrade to these updated packages, which contain a backported security patch to correct these issues.

4. Solution:

Before applying this update, make sure that all previously-released errata relevant to your system have been applied. Use Red Hat Network to download and update your packages. To launch the Red Hat Update Agent, use the following command:

up2date

For information on how to install packages manually, refer to the following Web page for the System Administration or Customization guide specific to your system:

http://www.redhat.com/docs/manuals/enterprise/

5. RPMs required:

Red Hat Enterprise Linux AS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/kdelibs-3.3.1-3.10.src.rpm
bce4c06fafe21d3efe6861baccdb336f kdelibs-3.3.1-3.10.src.rpm

i386:
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
663a4623ae7b79383c901ddd604f40c1 kdelibs-devel-3.3.1-3.10.i386.rpm

ia64:
d71ca353358cc55e8b095909b33a384a kdelibs-3.3.1-3.10.ia64.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
6a6aee95de4b0e2c648cb333230e956c kdelibs-devel-3.3.1-3.10.ia64.rpm

ppc:
08f0b8a2dd54fcc21fd32bd713b10625 kdelibs-3.3.1-3.10.ppc.rpm
2a5859b0b379c8cd5019e312afb75d13 kdelibs-3.3.1-3.10.ppc64.rpm
933042fd45c59372b1ed3dab95cb8608 kdelibs-devel-3.3.1-3.10.ppc.rpm

s390:
7528c1d9e4bd655f1dbb29b0f784bd03 kdelibs-3.3.1-3.10.s390.rpm
6cbfdb4ed57dd476416a4626b234878a kdelibs-devel-3.3.1-3.10.s390.rpm

s390x:
d6c32e2c18773a37c24c0764c26ff8da kdelibs-3.3.1-3.10.s390x.rpm
7528c1d9e4bd655f1dbb29b0f784bd03 kdelibs-3.3.1-3.10.s390.rpm
9f7ad40ee12f4fdf898320d61943108d kdelibs-devel-3.3.1-3.10.s390x.rpm

x86_64:
d732485d3f1c19f0caa1e3c93acacd1d kdelibs-3.3.1-3.10.x86_64.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
84cba787f9f5c96b6ef205a269864d26 kdelibs-devel-3.3.1-3.10.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/kdelibs-3.3.1-3.10.src.rpm
bce4c06fafe21d3efe6861baccdb336f kdelibs-3.3.1-3.10.src.rpm

i386:
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
663a4623ae7b79383c901ddd604f40c1 kdelibs-devel-3.3.1-3.10.i386.rpm

x86_64:
d732485d3f1c19f0caa1e3c93acacd1d kdelibs-3.3.1-3.10.x86_64.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
84cba787f9f5c96b6ef205a269864d26 kdelibs-devel-3.3.1-3.10.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/kdelibs-3.3.1-3.10.src.rpm
bce4c06fafe21d3efe6861baccdb336f kdelibs-3.3.1-3.10.src.rpm

i386:
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
663a4623ae7b79383c901ddd604f40c1 kdelibs-devel-3.3.1-3.10.i386.rpm

ia64:
d71ca353358cc55e8b095909b33a384a kdelibs-3.3.1-3.10.ia64.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
6a6aee95de4b0e2c648cb333230e956c kdelibs-devel-3.3.1-3.10.ia64.rpm

x86_64:
d732485d3f1c19f0caa1e3c93acacd1d kdelibs-3.3.1-3.10.x86_64.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
84cba787f9f5c96b6ef205a269864d26 kdelibs-devel-3.3.1-3.10.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/kdelibs-3.3.1-3.10.src.rpm
bce4c06fafe21d3efe6861baccdb336f kdelibs-3.3.1-3.10.src.rpm

i386:
663a4623ae7b79383c901ddd604f40c1 kdelibs-devel-3.3.1-3.10.i386.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm

ia64:
d71ca353358cc55e8b095909b33a384a kdelibs-3.3.1-3.10.ia64.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
6a6aee95de4b0e2c648cb333230e956c kdelibs-devel-3.3.1-3.10.ia64.rpm

x86_64:
d732485d3f1c19f0caa1e3c93acacd1d kdelibs-3.3.1-3.10.x86_64.rpm
f3fd454b5cc31b9b64160fef728f8e2b kdelibs-3.3.1-3.10.i386.rpm
84cba787f9f5c96b6ef205a269864d26 kdelibs-devel-3.3.1-3.10.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://www.redhat.com/security/team/key/#package

6. References:

http://bugs.kde.org/102328
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1046

7. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact details at https://www.redhat.com/security/team/contact/

Copyright 2005 Red Hat, Inc.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_2005393_01_important_kdelibs_security_update.html)