RHSA-2005:036-01: Low: vim security update
Posted on: 02/15/2005 01:39 PM

A vim security update is available for Red Hat Enterprise Linux 4

----------------------------------------------------------------------
Red Hat Security Advisory

Synopsis: Low: vim security update
Advisory ID: RHSA-2005:036-01
Advisory URL: https://rhn.redhat.com/errata/RHSA-2005-036.html
Issue date: 2005-02-15
Updated on: 2005-02-15
Product: Red Hat Enterprise Linux
CVE Names: CAN-2004-1138 CAN-2005-0069
----------------------------------------------------------------------

1. Summary:

Updated vim packages that fix security vulnerabilities are now available for Red Hat Enterprise Linux 4.

This update has been rated as having low security impact by the Red Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

VIM (Vi IMproved) is an updated and improved version of the vi screen-based editor.

Ciaran McCreesh discovered a modeline vulnerability in VIM. An attacker could create a text file containing a specially crafted modeline which could cause arbitrary command execution when viewed by a victim using VIM. The Common Vulnerabilities and Exposures project has assigned the name CAN-2004-1138 to this issue. Please note that this issue only affects users who have modelines and filetype plugins enabled, which is not the default.

The Debian Security Audit Project discovered an insecure temporary file usage in VIM. A local user could overwrite or create files as a different user who happens to run one of the the vulnerable utilities. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name
CAN-2005-0069 to this issue.

All users of VIM are advised to upgrade to these erratum packages, which contain backported patches for these issues.

4. Solution:

Before applying this update, make sure that all previously-released errata relevant to your system have been applied. Use Red Hat Network to download and update your packages. To launch the Red Hat Update Agent, use the following command:

up2date

For information on how to install packages manually, refer to the following Web page for the System Administration or Customization guide specific to your system:

http://www.redhat.com/docs/manuals/enterprise/

5. Bug IDs fixed (http://bugzilla.redhat.com/):

144187 - CAN-2004-1138 vim arbitrary command execution vulnerability
144880 - CAN-2005-0069 vim unsafe temporary file usage.

6. RPMs required:

Red Hat Enterprise Linux AS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/vim-6.3.046-0.40E.4.src.rpm
c96fd67779f1d099a58a7a0743ce6928 vim-6.3.046-0.40E.4.src.rpm

i386:
dd31e23fcbdb6bade1294d31174f5103 vim-X11-6.3.046-0.40E.4.i386.rpm
f4c5333040a94853faf12be26ba382ed vim-common-6.3.046-0.40E.4.i386.rpm
33be00e17c1107915e305043f136119e vim-enhanced-6.3.046-0.40E.4.i386.rpm
1a8c629691d5782e80fc8956effdacd1 vim-minimal-6.3.046-0.40E.4.i386.rpm

ia64:
b10674df5347e8d9e2a613ef2023279e vim-X11-6.3.046-0.40E.4.ia64.rpm
8473b75ed1d176059ab23d7b897d56f2 vim-common-6.3.046-0.40E.4.ia64.rpm
f5e7c7f0856b427e776ebc3712b636a7 vim-enhanced-6.3.046-0.40E.4.ia64.rpm
6a469afce1bad5b376fa06d3e41fb418 vim-minimal-6.3.046-0.40E.4.ia64.rpm

ppc:
c829b578e44be749f702bba972dc6aaf vim-X11-6.3.046-0.40E.4.ppc.rpm
75b89a824a1ef85720daab79d4643994 vim-common-6.3.046-0.40E.4.ppc.rpm
8ed3cc589a078b1a98241ef5f66a4635 vim-enhanced-6.3.046-0.40E.4.ppc.rpm
ff9420a3210b7d9fec7c22ac84cd45b0 vim-minimal-6.3.046-0.40E.4.ppc.rpm

s390:
48904dd9de9b25720c4c43a147683298 vim-X11-6.3.046-0.40E.4.s390.rpm
4bd0c5889d0b90459ecaf49c105a3b26 vim-common-6.3.046-0.40E.4.s390.rpm
6c9a14e740ef7bb2e6ba4569adf65339 vim-enhanced-6.3.046-0.40E.4.s390.rpm
98de86875b9d54219b2f37ca303a41ed vim-minimal-6.3.046-0.40E.4.s390.rpm

s390x:
97c53980f49b3bcc057bec6e197f9f79 vim-X11-6.3.046-0.40E.4.s390x.rpm
123bf0b4f37202089e1c5336e8d3527a vim-common-6.3.046-0.40E.4.s390x.rpm
747c5efa7e3f93757475dc9743c19d75 vim-enhanced-6.3.046-0.40E.4.s390x.rpm
d691bc9d0fd6ec63fbcf8cdf5abfef4e vim-minimal-6.3.046-0.40E.4.s390x.rpm

x86_64:
5e8698376c3c385d5041499f462b0c2a vim-X11-6.3.046-0.40E.4.x86_64.rpm
73074abbe35bef46b42d41e36319391e vim-common-6.3.046-0.40E.4.x86_64.rpm
050e7da706e074b4571376f3c93e0267 vim-enhanced-6.3.046-0.40E.4.x86_64.rpm
3864e1d8b4cff3314120f99c30887483 vim-minimal-6.3.046-0.40E.4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/vim-6.3.046-0.40E.4.src.rpm
c96fd67779f1d099a58a7a0743ce6928 vim-6.3.046-0.40E.4.src.rpm

i386:
dd31e23fcbdb6bade1294d31174f5103 vim-X11-6.3.046-0.40E.4.i386.rpm
f4c5333040a94853faf12be26ba382ed vim-common-6.3.046-0.40E.4.i386.rpm
33be00e17c1107915e305043f136119e vim-enhanced-6.3.046-0.40E.4.i386.rpm
1a8c629691d5782e80fc8956effdacd1 vim-minimal-6.3.046-0.40E.4.i386.rpm

x86_64:
5e8698376c3c385d5041499f462b0c2a vim-X11-6.3.046-0.40E.4.x86_64.rpm
73074abbe35bef46b42d41e36319391e vim-common-6.3.046-0.40E.4.x86_64.rpm
050e7da706e074b4571376f3c93e0267 vim-enhanced-6.3.046-0.40E.4.x86_64.rpm
3864e1d8b4cff3314120f99c30887483 vim-minimal-6.3.046-0.40E.4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/vim-6.3.046-0.40E.4.src.rpm
c96fd67779f1d099a58a7a0743ce6928 vim-6.3.046-0.40E.4.src.rpm

i386:
dd31e23fcbdb6bade1294d31174f5103 vim-X11-6.3.046-0.40E.4.i386.rpm
f4c5333040a94853faf12be26ba382ed vim-common-6.3.046-0.40E.4.i386.rpm
33be00e17c1107915e305043f136119e vim-enhanced-6.3.046-0.40E.4.i386.rpm
1a8c629691d5782e80fc8956effdacd1 vim-minimal-6.3.046-0.40E.4.i386.rpm

ia64:
b10674df5347e8d9e2a613ef2023279e vim-X11-6.3.046-0.40E.4.ia64.rpm
8473b75ed1d176059ab23d7b897d56f2 vim-common-6.3.046-0.40E.4.ia64.rpm
f5e7c7f0856b427e776ebc3712b636a7 vim-enhanced-6.3.046-0.40E.4.ia64.rpm
6a469afce1bad5b376fa06d3e41fb418 vim-minimal-6.3.046-0.40E.4.ia64.rpm

x86_64:
5e8698376c3c385d5041499f462b0c2a vim-X11-6.3.046-0.40E.4.x86_64.rpm
73074abbe35bef46b42d41e36319391e vim-common-6.3.046-0.40E.4.x86_64.rpm
050e7da706e074b4571376f3c93e0267 vim-enhanced-6.3.046-0.40E.4.x86_64.rpm
3864e1d8b4cff3314120f99c30887483 vim-minimal-6.3.046-0.40E.4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/vim-6.3.046-0.40E.4.src.rpm
c96fd67779f1d099a58a7a0743ce6928 vim-6.3.046-0.40E.4.src.rpm

i386:
dd31e23fcbdb6bade1294d31174f5103 vim-X11-6.3.046-0.40E.4.i386.rpm
f4c5333040a94853faf12be26ba382ed vim-common-6.3.046-0.40E.4.i386.rpm
33be00e17c1107915e305043f136119e vim-enhanced-6.3.046-0.40E.4.i386.rpm
1a8c629691d5782e80fc8956effdacd1 vim-minimal-6.3.046-0.40E.4.i386.rpm

ia64:
b10674df5347e8d9e2a613ef2023279e vim-X11-6.3.046-0.40E.4.ia64.rpm
8473b75ed1d176059ab23d7b897d56f2 vim-common-6.3.046-0.40E.4.ia64.rpm
f5e7c7f0856b427e776ebc3712b636a7 vim-enhanced-6.3.046-0.40E.4.ia64.rpm
6a469afce1bad5b376fa06d3e41fb418 vim-minimal-6.3.046-0.40E.4.ia64.rpm

x86_64:
5e8698376c3c385d5041499f462b0c2a vim-X11-6.3.046-0.40E.4.x86_64.rpm
73074abbe35bef46b42d41e36319391e vim-common-6.3.046-0.40E.4.x86_64.rpm
050e7da706e074b4571376f3c93e0267 vim-enhanced-6.3.046-0.40E.4.x86_64.rpm
3864e1d8b4cff3314120f99c30887483 vim-minimal-6.3.046-0.40E.4.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://www.redhat.com/security/team/key/#package

7. References:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=289560
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1138
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0069

8. Contact:

The Red Hat security contact is secalert@redhat.com. More contact details at https://www.redhat.com/security/team/contact/

Copyright 2005 Red Hat, Inc.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_2005036_01_low_vim_security_update.html)