RHSA-2005:021-01: Moderate: kdegraphics security update
Posted on: 04/12/2005 12:10 PM

A kdegraphics security update is available for Red Hat Enterprise Linux 2.1 and 3

----------------------------------------------------------------------
Red Hat Security Advisory

Synopsis: Moderate: kdegraphics security update
Advisory ID: RHSA-2005:021-01
Advisory URL: https://rhn.redhat.com/errata/RHSA-2005-021.html
Issue date: 2005-04-12
Updated on: 2005-04-12
Product: Red Hat Enterprise Linux
CVE Names: CAN-2004-0803 CAN-2004-0886 CAN-2004-0804
----------------------------------------------------------------------

1. Summary:

Updated kdegraphics packages that resolve multiple security issues in kfax are now available.

This update has been rated as having moderate security impact by the Red Hat Security Response Team

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - i386, ia64
Red Hat Linux Advanced Workstation 2.1 - ia64
Red Hat Enterprise Linux ES version 2.1 - i386
Red Hat Enterprise Linux WS version 2.1 - i386
Red Hat Enterprise Linux AS version 3 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Desktop version 3 - i386, x86_64
Red Hat Enterprise Linux ES version 3 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 3 - i386, ia64, x86_64

3. Problem description:

The kdegraphics package contains graphics applications for the K Desktop Environment.

During a source code audit, Chris Evans discovered a number of integer overflow bugs that affect libtiff. The kfax application contains a copy of the libtiff code used for parsing TIFF files and is therefore affected by these bugs. An attacker who has the ability to trick a user into opening a malicious TIFF file could cause kfax to crash or possibly execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CAN-2004-0886 and CAN-2004-0804 to these issues.

Additionally, a number of buffer overflow bugs that affect libtiff have been found. The kfax application contains a copy of the libtiff code used for parsing TIFF files and is therefore affected by these bugs. An attacker who has the ability to trick a user into opening a malicious TIFF file could cause kfax to crash or possibly execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2004-0803 to this issue.

Users of kfax should upgrade to these updated packages, which contain backported patches and are not vulnerable to this issue.

4. Solution:

Before applying this update, make sure that all previously-released errata relevant to your system have been applied. Use Red Hat Network to download and update your packages. To launch the Red Hat Update Agent, use the following command:

up2date

For information on how to install packages manually, refer to the following Web page for the System Administration or Customization guide specific to your system:

http://www.redhat.com/docs/manuals/enterprise/

5. Bug IDs fixed (http://bugzilla.redhat.com/):

135470 - CAN-2004-0886 multiple integer overflows in libtiff
135466 - CAN-2004-0803 buffer overflows in libtiff

6. RPMs required:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/kdegraphics-2.2.2-4.3.src.rpm
765074535aeb59f12d8dac357f7f9b9d kdegraphics-2.2.2-4.3.src.rpm

i386:
7981553ce8dc8008f4082ec508d9c81b kdegraphics-2.2.2-4.3.i386.rpm
ca21293d2cc1c94fed9cd80a657ccfcf kdegraphics-devel-2.2.2-4.3.i386.rpm

ia64:
3e5155a70b34ac63d2e8f78c36227c03 kdegraphics-2.2.2-4.3.ia64.rpm
9048cccb8784a8fb03fea0be1c378c68 kdegraphics-devel-2.2.2-4.3.ia64.rpm

Red Hat Linux Advanced Workstation 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/kdegraphics-2.2.2-4.3.src.rpm
765074535aeb59f12d8dac357f7f9b9d kdegraphics-2.2.2-4.3.src.rpm

ia64:
3e5155a70b34ac63d2e8f78c36227c03 kdegraphics-2.2.2-4.3.ia64.rpm
9048cccb8784a8fb03fea0be1c378c68 kdegraphics-devel-2.2.2-4.3.ia64.rpm

Red Hat Enterprise Linux ES version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1ES/en/os/SRPMS/kdegraphics-2.2.2-4.3.src.rpm
765074535aeb59f12d8dac357f7f9b9d kdegraphics-2.2.2-4.3.src.rpm

i386:
7981553ce8dc8008f4082ec508d9c81b kdegraphics-2.2.2-4.3.i386.rpm
ca21293d2cc1c94fed9cd80a657ccfcf kdegraphics-devel-2.2.2-4.3.i386.rpm

Red Hat Enterprise Linux WS version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1WS/en/os/SRPMS/kdegraphics-2.2.2-4.3.src.rpm
765074535aeb59f12d8dac357f7f9b9d kdegraphics-2.2.2-4.3.src.rpm

i386:
7981553ce8dc8008f4082ec508d9c81b kdegraphics-2.2.2-4.3.i386.rpm
ca21293d2cc1c94fed9cd80a657ccfcf kdegraphics-devel-2.2.2-4.3.i386.rpm

Red Hat Enterprise Linux AS version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3AS/en/os/SRPMS/kdegraphics-3.1.3-3.7.src.rpm
098d4365a90e1ecd3fa326b4eaeafdf9 kdegraphics-3.1.3-3.7.src.rpm

i386:
a768939d2774477968e5bc9016455788 kdegraphics-3.1.3-3.7.i386.rpm
2e4a2609ea06483c8636f375a2d93de3 kdegraphics-devel-3.1.3-3.7.i386.rpm

ia64:
34eae83f27922303b9c286a21f881c75 kdegraphics-3.1.3-3.7.ia64.rpm
37895d0ebd1a73d2b98fe400cf1af084 kdegraphics-devel-3.1.3-3.7.ia64.rpm

ppc:
175a1cbb8a9301399e8b8392429f16b1 kdegraphics-3.1.3-3.7.ppc.rpm
a5a416457f1b3f528853f1912aab9d5c kdegraphics-devel-3.1.3-3.7.ppc.rpm

s390:
5901640cbf50090ee322bd9344118178 kdegraphics-3.1.3-3.7.s390.rpm
04c4183f594689db2f249b4a15334e36 kdegraphics-devel-3.1.3-3.7.s390.rpm

s390x:
af23175c04e0f09065f40a868a1ba64a kdegraphics-3.1.3-3.7.s390x.rpm
2fe972d585215ebc13ac99d5c12941d4 kdegraphics-devel-3.1.3-3.7.s390x.rpm

x86_64:
4a9b219edbf5739ccdd46b78070098cc kdegraphics-3.1.3-3.7.x86_64.rpm
93f19316014856fc2fddf27c245363ec kdegraphics-devel-3.1.3-3.7.x86_64.rpm

Red Hat Desktop version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3desktop/en/os/SRPMS/kdegraphics-3.1.3-3.7.src.rpm
098d4365a90e1ecd3fa326b4eaeafdf9 kdegraphics-3.1.3-3.7.src.rpm

i386:
a768939d2774477968e5bc9016455788 kdegraphics-3.1.3-3.7.i386.rpm
2e4a2609ea06483c8636f375a2d93de3 kdegraphics-devel-3.1.3-3.7.i386.rpm

x86_64:
4a9b219edbf5739ccdd46b78070098cc kdegraphics-3.1.3-3.7.x86_64.rpm
93f19316014856fc2fddf27c245363ec kdegraphics-devel-3.1.3-3.7.x86_64.rpm

Red Hat Enterprise Linux ES version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3ES/en/os/SRPMS/kdegraphics-3.1.3-3.7.src.rpm
098d4365a90e1ecd3fa326b4eaeafdf9 kdegraphics-3.1.3-3.7.src.rpm

i386:
a768939d2774477968e5bc9016455788 kdegraphics-3.1.3-3.7.i386.rpm
2e4a2609ea06483c8636f375a2d93de3 kdegraphics-devel-3.1.3-3.7.i386.rpm

ia64:
34eae83f27922303b9c286a21f881c75 kdegraphics-3.1.3-3.7.ia64.rpm
37895d0ebd1a73d2b98fe400cf1af084 kdegraphics-devel-3.1.3-3.7.ia64.rpm

x86_64:
4a9b219edbf5739ccdd46b78070098cc kdegraphics-3.1.3-3.7.x86_64.rpm
93f19316014856fc2fddf27c245363ec kdegraphics-devel-3.1.3-3.7.x86_64.rpm

Red Hat Enterprise Linux WS version 3:

SRPMS:
ftp://updates.redhat.com/enterprise/3WS/en/os/SRPMS/kdegraphics-3.1.3-3.7.src.rpm
098d4365a90e1ecd3fa326b4eaeafdf9 kdegraphics-3.1.3-3.7.src.rpm

i386:
a768939d2774477968e5bc9016455788 kdegraphics-3.1.3-3.7.i386.rpm
2e4a2609ea06483c8636f375a2d93de3 kdegraphics-devel-3.1.3-3.7.i386.rpm

ia64:
34eae83f27922303b9c286a21f881c75 kdegraphics-3.1.3-3.7.ia64.rpm
37895d0ebd1a73d2b98fe400cf1af084 kdegraphics-devel-3.1.3-3.7.ia64.rpm

x86_64:
4a9b219edbf5739ccdd46b78070098cc kdegraphics-3.1.3-3.7.x86_64.rpm
93f19316014856fc2fddf27c245363ec kdegraphics-devel-3.1.3-3.7.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0803
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0886
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0804

8. Contact:

The Red Hat security contact is lt;secalert@redhat.comgt;. More contact details at https://www.redhat.com/security/team/contact/

Copyright 2005 Red Hat, Inc.



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_2005021_01_moderate_kdegraphics_security_update.html)