RHSA-2004:440-01: An updated lha package fixes security vulnerability
Posted on: 09/07/2004 12:21 PM

An updated lha package is available for Red Hat Enterprise Linux 2.1

----------------------------------------------------------------------
Red Hat Security Advisory

Synopsis: An updated lha package fixes security vulnerability
Advisory ID: RHSA-2004:440-01
Issue date: 2004-09-07
Updated on: 2004-09-07
Product: Red Hat Enterprise Linux
Obsoletes: RHSA-2004:178
CVE Names: CAN-2004-0771 CAN-2004-0769 CAN-2004-0694 CAN-2004-0745
----------------------------------------------------------------------

1. Summary:

An updated lha package that fixes a buffer overflow is now available.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - i386, ia64
Red Hat Linux Advanced Workstation 2.1 - ia64
Red Hat Enterprise Linux ES version 2.1 - i386
Red Hat Enterprise Linux WS version 2.1 - i386

3. Problem description:

LHA is an archiving and compression utility for LHarc format archives.

Lukasz Wojtow discovered a stack-based buffer overflow in all versions of lha up to and including version 1.14. A carefully created archive could allow an attacker to execute arbitrary code when a victim extracts or tests the archive. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2004-0769 to this issue.

Buffer overflows were discovered in the command line processing of all versions of lha up to and including version 1.14. If a malicious user can trick a victim into passing a specially crafted command line to the lha command, it is possible that arbitrary code could be executed. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CAN-2004-0771 and CAN-2004-0694 to these issues.

Thomas Biege discovered a shell meta character command execution vulnerability in all versions of lha up to and including 1.14. An attacker could create a directory with shell meta characters in its name which could lead to arbitrary command execution. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2004-0745 to this issue.

Users of lha should update to this updated package which contains backported patches and is not vulnerable to these issues.

4. Solution:

Before applying this update, make sure that all previously-released errata relevant to your system have been applied. Use Red Hat Network to download and update your packages. To launch the Red Hat Update Agent, use the following command:

up2date

For information on how to install packages manually, refer to the following Web page for the System Administration or Customization guide specific to your system:

http://www.redhat.com/docs/manuals/enterprise/

5. Bug IDs fixed (http://bugzilla.redhat.com/ for more info):

126740 - Buffer overflow in lha

6. RPMs required:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AS/en/os/SRPMS/lha-1.00-17.3.src.rpm
b1b6d9d7d549331766f710ba6c5bf494 lha-1.00-17.3.src.rpm

i386:
3247304974c5a1ee592a1095a3a8c265 lha-1.00-17.3.i386.rpm

ia64:
1d13c396eab707b0603464455b4065e0 lha-1.00-17.3.ia64.rpm

Red Hat Linux Advanced Workstation 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1AW/en/os/SRPMS/lha-1.00-17.3.src.rpm
b1b6d9d7d549331766f710ba6c5bf494 lha-1.00-17.3.src.rpm

ia64:
1d13c396eab707b0603464455b4065e0 lha-1.00-17.3.ia64.rpm

Red Hat Enterprise Linux ES version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1ES/en/os/SRPMS/lha-1.00-17.3.src.rpm
b1b6d9d7d549331766f710ba6c5bf494 lha-1.00-17.3.src.rpm

i386:
3247304974c5a1ee592a1095a3a8c265 lha-1.00-17.3.i386.rpm

Red Hat Enterprise Linux WS version 2.1:

SRPMS:
ftp://updates.redhat.com/enterprise/2.1WS/en/os/SRPMS/lha-1.00-17.3.src.rpm
b1b6d9d7d549331766f710ba6c5bf494 lha-1.00-17.3.src.rpm

i386:
3247304974c5a1ee592a1095a3a8c265 lha-1.00-17.3.i386.rpm

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://www.redhat.com/security/team/key.html#package

7. References:

http://marc.theaimsgroup.com/?l=bugtraqm=108668791510153
http://lw.ftw.zamosc.pl/lha-exploit.txt
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0771
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0769
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0694
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0745

8. Contact:

The Red Hat security contact is secalert@redhat.com. More contact details at https://www.redhat.com/security/team/contact.html

Copyright 2004 Red Hat, Inc.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rhsa_2004440_01_an_updated_lha_package_fixes_security_vulnerability.html)