RH: Updated Ethereal packages fix security issues
Posted on: 07/03/2003 09:17 PM

Updated Ethereal packages for Red Hat Linux has been released

Ethereal is a program for monitoring network traffic.

A number of security issues affect Ethereal. By exploiting these issues it may be possible to make Ethereal crash or run arbitrary code by injecting a purposefully malformed packet onto the wire or by convincing someone to read a malformed packet trace file.

Multiple off-by-one vulnerabilities exist in Ethereal 0.9.11 and earlier in the AIM, GIOP Gryphon, OSPF, PPTP, Quake, Quake2, Quake3, Rsync, SMB, SMPP, and TSP dissectors. They do not properly use the tvb_get_nstringz and tvb_get_nstringz0 functions. Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2003-0356 to these issues.

Multiple integer overflow vulnerabilities exist in Ethereal 0.9.11 and earlier in the Mount and PPP dissectors. (CAN-2003-0357)

A vulnerability in the DCERPC dissector exists in Ethereal 0.9.12 and earlier, allowing remote attackers to cause a denial of service (memory consumption) via a certain NDR string. (CAN-2003-0428 )

The OSI dissector in Ethereal 0.9.12 and earlier causes by invalid IPv4 or IPv6 prefix lengths, possibly triggering a buffer overflow. (CAN-2003-0429)

The SPNEGO dissector in Ethereal 0.9.12 and earlier allows remote attackers to cause a denial of service (crash) via an invalid ASN.1 value. (CAN-2003-0430)

The tvb_get_nstringz0 function in Ethereal 0.9.12 and earlier does not properly handle a zero-length buffer size. (CAN-2003-0431)

Ethereal 0.9.12 and earlier does not handle certain strings properly in the BGP, WTP, DNS, 802.11, ISAKMP, WSP, CLNP, ISIS, and RMI dissectors. (CAN-2003-0432)

Users of Ethereal should update to the erratum packages containing Ethereal version 0.9.13, which are not vulnerable to these issues.

Read more


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rh_updated_ethereal_packages_fix_security_issues.html)