Red Hat Security Updates
Posted on: 05/21/2003 10:14 PM

Red Hat has released 3 new security updates for Red Hat Linux

RHBA-2003:143-10: Updated modutils package corrects PLT relocation bug
The modutils package contains the software necessary to load and unload kernel modules.

A prior version of modutils had a bug that caused PLT relocations to be resolved incorrectly when loading a module. This bug would result in a crash when a module containing PLT relocations was loaded. This patch corrects the problem.

Read more

RHBA-2003:144-07: Updated kernel packages correct TLB flush problem
The Linux kernel handles the basic functions of the operating system.

A flaw has been discovered in the kernel code handling translation lookaside buffer flushing. The flaw made it possible for a multithreaded process (with threads running on more than one processor) to fail to note that the TLB should be flushed for every processor on which the process's
threads had run.

The upgraded kernel packages contained in this erratum corrects the problem.

Read more

RHSA-2003:175-06: Updated gnupg packages fix validation bug
When evaluating trust values for different UIDs assigned to a given key, GnuPG versions earlier than 1.2.2 would incorrectly associate the trust value of the UID with the highest trust value with every UID assigned to that key. This would prevent an expected warning message from being generated.

All users are advised to upgrade to these errata packages which include patches from the GnuPG development team that correct this issue for GnuPG versions 1.0.7 and 1.2.1. This update also upgrades Red Hat Linux 7.1, 7.2, and 7.3 users to GnuPG version 1.0.7.

Read more




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/red_hat_security_updates_3d5f.html)