RAR/Chromium Updates for Gentoo Linux
Posted on: 09/26/2017 07:32 AM

The following updates has been released for Gentoo Linux:

GLSA 201709-24 : RAR, UnRAR: Multiple vulnerabilities
GLSA 201709-25 : Chromium: Multiple vulnerabilities

GLSA 201709-24 : RAR, UnRAR: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201709-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: RAR, UnRAR: Multiple vulnerabilities
Date: September 25, 2017
Bugs: #622342, #628182, #628184
ID: 201709-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in RAR and UnRAR, the worst of
which may allow attackers to execute arbitrary code.

Background
==========

RAR and UnRAR provide command line interfaces for compressing and
decompressing RAR files.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-arch/rar < 5.5.0_p20170811 >= 5.5.0_p20170811
2 app-arch/unrar < 5.5.7 >= 5.5.7
-------------------------------------------------------------------
2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in RAR and UnRAR. Please
review the referenced CVE identifiers for details.

Impact
======

A remote attacker, by enticing a user to open a specially crafted RAR,
could possibly execute arbitrary code with the privileges of the
process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All RAR users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/rar-5.5.0_p20170811"

All UnRAR users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/unrar-5.5.7"

References
==========

[ 1 ] CVE-2012-6706
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-6706
[ 2 ] CVE-2017-12940
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12940
[ 3 ] CVE-2017-12941
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12941
[ 4 ] CVE-2017-12942
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12942

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201709-24

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



GLSA 201709-25 : Chromium: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201709-25
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Chromium: Multiple vulnerabilities
Date: September 25, 2017
Bugs: #631784
ID: 201709-25

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Chromium, the worst of
which could result in the execution of arbitrary code.

Background
==========

Chromium is an open-source browser project that aims to build a safer,
faster, and more stable way for all users to experience the web.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-client/chromium < 61.0.3163.100 >= 61.0.3163.100

Description
===========

Multiple vulnerabilities have been discovered in Chromium. Please
review the referenced CVE identifiers for details.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Chromium users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=www-client/chromium-61.0.3163.100"

References
==========

[ 1 ] CVE-2017-5121
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5121
[ 2 ] CVE-2017-5122
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5122

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201709-25

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5






Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rarchromium_updates_for_gentoo_linux.html)