Rails security update for Debian
Posted on: 06/14/2011 11:02 PM

A rails security update is available for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2260-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
June 14, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : rails
Vulnerability : several
Problem type : remote
Debian-specific: no
CVE ID : CVE-2009-3086 CVE-2009-4214
Debian Bug : 545063 558685

Two vulnerabilities were discovered in Ruby on Rails, a web
application framework. The Common Vulnerabilities and Exposures
project identifies the following problems:

CVE-2009-3086
The cookie store may be vulnerability to a timing attack,
potentially allowing remote attackers to forge message
digests.

CVE-2009-4214
A cross-site scripting vulnerability in the strip_tags
function allows remote user-assisted attackers to inject
arbitrary web script.

For the oldstable distribution (lenny), these problems have been fixed
in version 2.1.0-7+lenny0.2.

For the other distributions, these problems have been fixed in version
2.2.3-2.

We recommend that you upgrade your rails packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/rails_security_update_for_debian_d199.html)