QEMU/Kernel-Firmware/ImageMagick Updates for openSUSE
Posted on: 01/05/2018 10:19 PM

The following updates has been released for openSUSE:

openSUSE-SU-2018:0025-1: important: Security update for ImageMagick
openSUSE-SU-2018:0026-1: important: Security update for kernel-firmware
openSUSE-SU-2018:0030-1: important: Security update for qemu

openSUSE-SU-2018:0025-1: important: Security update for ImageMagick
openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0025-1
Rating: important
References: #1052460 #1055053 #1055063 #1056550 #1057723
#1058422 #1063049 #1063050
Cross-References: CVE-2017-12563 CVE-2017-12691 CVE-2017-13061
CVE-2017-13062 CVE-2017-14042 CVE-2017-14174
CVE-2017-14343 CVE-2017-15277 CVE-2017-15281

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes 9 vulnerabilities is now available.

Description:

This update for ImageMagick fixes the following issues:

- security update (xcf.c):
* CVE-2017-14343: Memory leak vulnerability in ReadXCFImage could lead
to denial of service via a crafted file. CVE-2017-12691: The
ReadOneLayer function in coders/xcf.c allows remote attackers to cause
a denial of service (memory consumption) via a crafted file.
[bsc#1058422]

- security update (pnm.c):
* CVE-2017-14042: A memory allocation failure was discovered in the
ReadPNMImage function in coders/pnm.c and could lead to remote denial
of service [bsc#1056550]

- security update (psd.c):
* CVE-2017-15281: ReadPSDImage allows remote attackers to cause a denial
of service (application crash) or possibly have unspecified other
impact via a crafted file [bsc#1063049]
* CVE-2017-13061: A length-validation vulnerability was found in the
function ReadPSDLayersInternal in coders/psd.c, which allows attackers
to cause a denial of service (ReadPSDImage memory exhaustion) via a
crafted file. [bsc#1055063]
* CVE-2017-12563: A Memory exhaustion vulnerability was found in the
function ReadPSDImage in coders/psd.c, which allows attackers to cause
a denial of service. [bsc#1052460]
* CVE-2017-14174: Due to a lack of an EOF check (End of File) in
ReadPSDLayersInternal could cause huge CPU consumption, when a crafted
PSD file, which claims a large "length" field in the header but does
not contain sufficient backing data, is provided, the loop over
\"length\" would consume huge CPU resources, since there is no EOF
check inside the loop.[bsc#1057723]

- security update (meta.c):
* CVE-2017-13062: Amemory leak vulnerability was found in the function
formatIPTC in coders/meta.c, which allows attackers to cause a denial
of service (WriteMETAImage memory consumption) via a crafted file
[bsc#1055053]

- security update (gif.c):
* CVE-2017-15277: ReadGIFImage in coders/gif.c leaves the palette
uninitialized when processing a GIF file that has neither a global nor
local palette. If the affected product is used as a library loaded
into a process that operates on interesting data, this data sometimes
can be leaked via the uninitialized palette.[bsc#1063050]

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-7=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2018-7=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

ImageMagick-6.8.8.1-43.1
ImageMagick-debuginfo-6.8.8.1-43.1
ImageMagick-debugsource-6.8.8.1-43.1
ImageMagick-devel-6.8.8.1-43.1
ImageMagick-extra-6.8.8.1-43.1
ImageMagick-extra-debuginfo-6.8.8.1-43.1
libMagick++-6_Q16-3-6.8.8.1-43.1
libMagick++-6_Q16-3-debuginfo-6.8.8.1-43.1
libMagick++-devel-6.8.8.1-43.1
libMagickCore-6_Q16-1-6.8.8.1-43.1
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-43.1
libMagickWand-6_Q16-1-6.8.8.1-43.1
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-43.1
perl-PerlMagick-6.8.8.1-43.1
perl-PerlMagick-debuginfo-6.8.8.1-43.1

- openSUSE Leap 42.3 (noarch):

ImageMagick-doc-6.8.8.1-43.1

- openSUSE Leap 42.3 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-43.1
libMagick++-6_Q16-3-32bit-6.8.8.1-43.1
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-43.1
libMagick++-devel-32bit-6.8.8.1-43.1
libMagickCore-6_Q16-1-32bit-6.8.8.1-43.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-43.1
libMagickWand-6_Q16-1-32bit-6.8.8.1-43.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-43.1

- openSUSE Leap 42.2 (i586 x86_64):

ImageMagick-6.8.8.1-30.15.1
ImageMagick-debuginfo-6.8.8.1-30.15.1
ImageMagick-debugsource-6.8.8.1-30.15.1
ImageMagick-devel-6.8.8.1-30.15.1
ImageMagick-extra-6.8.8.1-30.15.1
ImageMagick-extra-debuginfo-6.8.8.1-30.15.1
libMagick++-6_Q16-3-6.8.8.1-30.15.1
libMagick++-6_Q16-3-debuginfo-6.8.8.1-30.15.1
libMagick++-devel-6.8.8.1-30.15.1
libMagickCore-6_Q16-1-6.8.8.1-30.15.1
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-30.15.1
libMagickWand-6_Q16-1-6.8.8.1-30.15.1
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-30.15.1
perl-PerlMagick-6.8.8.1-30.15.1
perl-PerlMagick-debuginfo-6.8.8.1-30.15.1

- openSUSE Leap 42.2 (noarch):

ImageMagick-doc-6.8.8.1-30.15.1

- openSUSE Leap 42.2 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-30.15.1
libMagick++-6_Q16-3-32bit-6.8.8.1-30.15.1
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-30.15.1
libMagick++-devel-32bit-6.8.8.1-30.15.1
libMagickCore-6_Q16-1-32bit-6.8.8.1-30.15.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-30.15.1
libMagickWand-6_Q16-1-32bit-6.8.8.1-30.15.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-30.15.1


References:

https://www.suse.com/security/cve/CVE-2017-12563.html
https://www.suse.com/security/cve/CVE-2017-12691.html
https://www.suse.com/security/cve/CVE-2017-13061.html
https://www.suse.com/security/cve/CVE-2017-13062.html
https://www.suse.com/security/cve/CVE-2017-14042.html
https://www.suse.com/security/cve/CVE-2017-14174.html
https://www.suse.com/security/cve/CVE-2017-14343.html
https://www.suse.com/security/cve/CVE-2017-15277.html
https://www.suse.com/security/cve/CVE-2017-15281.html
https://bugzilla.suse.com/1052460
https://bugzilla.suse.com/1055053
https://bugzilla.suse.com/1055063
https://bugzilla.suse.com/1056550
https://bugzilla.suse.com/1057723
https://bugzilla.suse.com/1058422
https://bugzilla.suse.com/1063049
https://bugzilla.suse.com/1063050


openSUSE-SU-2018:0026-1: important: Security update for kernel-firmware
openSUSE Security Update: Security update for kernel-firmware
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0026-1
Rating: important
References: #1068032
Cross-References: CVE-2017-5715
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for kernel-firmware fixes the following issues:

- Add microcode_amd_fam17h.bin (bsc#1068032 CVE-2017-5715)

This new firmware disables branch prediction on AMD family 17h processor
to mitigate an attack on the branch predictor that could lead to
information disclosure from e.g. kernel memory (bsc#1068032 CVE-2017-5715).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2018-9=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (noarch):

kernel-firmware-20170530-7.12.1
ucode-amd-20170530-7.12.1


References:

https://www.suse.com/security/cve/CVE-2017-5715.html
https://bugzilla.suse.com/1068032


openSUSE-SU-2018:0030-1: important: Security update for qemu
openSUSE Security Update: Security update for qemu
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0030-1
Rating: important
References: #1052825 #1068032
Cross-References: CVE-2017-5715
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:



This update for qemu fixes the following issues:

A new feature was added:

- Support EPYC vCPU type (bsc#1052825 fate#324038)

Also a mitigation for a security problem has been applied:

- CVE-2017-5715: QEMU was updated to allow passing through new MSR and
CPUID flags from the host VM to the CPU, to allow enabling/disabling
branch prediction features in the Intel CPU. (bsc#1068032)

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-8=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

qemu-linux-user-2.9.1-38.1
qemu-linux-user-debuginfo-2.9.1-38.1
qemu-linux-user-debugsource-2.9.1-38.1

- openSUSE Leap 42.3 (x86_64):

qemu-2.9.1-38.1
qemu-arm-2.9.1-38.1
qemu-arm-debuginfo-2.9.1-38.1
qemu-block-curl-2.9.1-38.1
qemu-block-curl-debuginfo-2.9.1-38.1
qemu-block-dmg-2.9.1-38.1
qemu-block-dmg-debuginfo-2.9.1-38.1
qemu-block-iscsi-2.9.1-38.1
qemu-block-iscsi-debuginfo-2.9.1-38.1
qemu-block-rbd-2.9.1-38.1
qemu-block-rbd-debuginfo-2.9.1-38.1
qemu-block-ssh-2.9.1-38.1
qemu-block-ssh-debuginfo-2.9.1-38.1
qemu-debugsource-2.9.1-38.1
qemu-extra-2.9.1-38.1
qemu-extra-debuginfo-2.9.1-38.1
qemu-guest-agent-2.9.1-38.1
qemu-guest-agent-debuginfo-2.9.1-38.1
qemu-ksm-2.9.1-38.1
qemu-kvm-2.9.1-38.1
qemu-lang-2.9.1-38.1
qemu-ppc-2.9.1-38.1
qemu-ppc-debuginfo-2.9.1-38.1
qemu-s390-2.9.1-38.1
qemu-s390-debuginfo-2.9.1-38.1
qemu-testsuite-2.9.1-38.2
qemu-tools-2.9.1-38.1
qemu-tools-debuginfo-2.9.1-38.1
qemu-x86-2.9.1-38.1
qemu-x86-debuginfo-2.9.1-38.1

- openSUSE Leap 42.3 (noarch):

qemu-ipxe-1.0.0-38.1
qemu-seabios-1.10.2-38.1
qemu-sgabios-8-38.1
qemu-vgabios-1.10.2-38.1


References:

https://www.suse.com/security/cve/CVE-2017-5715.html
https://bugzilla.suse.com/1052825
https://bugzilla.suse.com/1068032





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/qemukernel_firmwareimagemagick_updates_for_opensuse.html)