Python/Java Security Updates for RHEL
Posted on: 05/05/2011 09:02 PM

Redhat has released the following security updates for RHEL: [RHSA-2011:0492-01] Moderate: python security update, [RHSA-2011:0491-01] Moderate: python security update, and [RHSA-2011:0490-01] Critical: java-1.4.2-ibm security update

[RHSA-2011:0492-01] Moderate: python security update
=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: python security update
Advisory ID: RHSA-2011:0492-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2011-0492.html
Issue date: 2011-05-05
CVE Names: CVE-2009-3720 CVE-2010-3493 CVE-2011-1015
CVE-2011-1521
=====================================================================

1. Summary:

Updated python packages that fix multiple security issues are now available
for Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

RHEL Desktop Workstation (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64

3. Description:

Python is an interpreted, interactive, object-oriented programming
language.

A flaw was found in the Python urllib and urllib2 libraries where they
would not differentiate between different target URLs when handling
automatic redirects. This caused Python applications using these modules to
follow any new URL that they understood, including the "file://" URL type.
This could allow a remote server to force a local Python application to
read a local file instead of the remote one, possibly exposing local files
that were not meant to be exposed. (CVE-2011-1521)

A race condition was found in the way the Python smtpd module handled new
connections. A remote user could use this flaw to cause a Python script
using the smtpd module to terminate. (CVE-2010-3493)

An information disclosure flaw was found in the way the Python
CGIHTTPServer module processed certain HTTP GET requests. A remote attacker
could use a specially-crafted request to obtain the CGI script's source
code. (CVE-2011-1015)

A buffer over-read flaw was found in the way the Python Expat parser
handled malformed UTF-8 sequences when processing XML files. A
specially-crafted XML file could cause Python applications using the Python
Expat parser to crash while parsing the file. (CVE-2009-3720)

This update makes Python use the system Expat library rather than its own
internal copy; therefore, users must have the version of Expat shipped with
RHSA-2009:1625 installed, or a later version, to resolve the CVE-2009-3720
issue.

All Python users should upgrade to these updated packages, which contain
backported patches to correct these issues.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

531697 - CVE-2009-3720 expat: buffer over-read and crash on XML with malformed UTF-8 sequences
632200 - CVE-2010-3493 Python: SMTP proxy RFC 2821 module DoS (uncaught exception) (Issue #9129)
680094 - CVE-2011-1015 python (CGIHTTPServer): CGI script source code disclosure
690560 - CVE-2011-1521 python (urllib, urllib2): Improper management of ftp:// and file:// URL schemes (Issue #11662)

6. Package List:

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/python-2.4.3-44.el5.src.rpm

i386:
python-2.4.3-44.el5.i386.rpm
python-debuginfo-2.4.3-44.el5.i386.rpm
python-libs-2.4.3-44.el5.i386.rpm
python-tools-2.4.3-44.el5.i386.rpm
tkinter-2.4.3-44.el5.i386.rpm

x86_64:
python-2.4.3-44.el5.x86_64.rpm
python-debuginfo-2.4.3-44.el5.x86_64.rpm
python-libs-2.4.3-44.el5.x86_64.rpm
python-tools-2.4.3-44.el5.x86_64.rpm
tkinter-2.4.3-44.el5.x86_64.rpm

RHEL Desktop Workstation (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/python-2.4.3-44.el5.src.rpm

i386:
python-debuginfo-2.4.3-44.el5.i386.rpm
python-devel-2.4.3-44.el5.i386.rpm

x86_64:
python-debuginfo-2.4.3-44.el5.i386.rpm
python-debuginfo-2.4.3-44.el5.x86_64.rpm
python-devel-2.4.3-44.el5.i386.rpm
python-devel-2.4.3-44.el5.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/python-2.4.3-44.el5.src.rpm

i386:
python-2.4.3-44.el5.i386.rpm
python-debuginfo-2.4.3-44.el5.i386.rpm
python-devel-2.4.3-44.el5.i386.rpm
python-libs-2.4.3-44.el5.i386.rpm
python-tools-2.4.3-44.el5.i386.rpm
tkinter-2.4.3-44.el5.i386.rpm

ia64:
python-2.4.3-44.el5.ia64.rpm
python-debuginfo-2.4.3-44.el5.i386.rpm
python-debuginfo-2.4.3-44.el5.ia64.rpm
python-devel-2.4.3-44.el5.ia64.rpm
python-libs-2.4.3-44.el5.i386.rpm
python-libs-2.4.3-44.el5.ia64.rpm
python-tools-2.4.3-44.el5.ia64.rpm
tkinter-2.4.3-44.el5.ia64.rpm

ppc:
python-2.4.3-44.el5.ppc.rpm
python-debuginfo-2.4.3-44.el5.ppc.rpm
python-debuginfo-2.4.3-44.el5.ppc64.rpm
python-devel-2.4.3-44.el5.ppc.rpm
python-devel-2.4.3-44.el5.ppc64.rpm
python-libs-2.4.3-44.el5.ppc.rpm
python-libs-2.4.3-44.el5.ppc64.rpm
python-tools-2.4.3-44.el5.ppc.rpm
tkinter-2.4.3-44.el5.ppc.rpm

s390x:
python-2.4.3-44.el5.s390x.rpm
python-debuginfo-2.4.3-44.el5.s390.rpm
python-debuginfo-2.4.3-44.el5.s390x.rpm
python-devel-2.4.3-44.el5.s390.rpm
python-devel-2.4.3-44.el5.s390x.rpm
python-libs-2.4.3-44.el5.s390x.rpm
python-tools-2.4.3-44.el5.s390x.rpm
tkinter-2.4.3-44.el5.s390x.rpm

x86_64:
python-2.4.3-44.el5.x86_64.rpm
python-debuginfo-2.4.3-44.el5.i386.rpm
python-debuginfo-2.4.3-44.el5.x86_64.rpm
python-devel-2.4.3-44.el5.i386.rpm
python-devel-2.4.3-44.el5.x86_64.rpm
python-libs-2.4.3-44.el5.x86_64.rpm
python-tools-2.4.3-44.el5.x86_64.rpm
tkinter-2.4.3-44.el5.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2009-3720.html
https://www.redhat.com/security/data/cve/CVE-2010-3493.html
https://www.redhat.com/security/data/cve/CVE-2011-1015.html
https://www.redhat.com/security/data/cve/CVE-2011-1521.html
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2011 Red Hat, Inc.

[RHSA-2011:0491-01] Moderate: python security update

=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: python security update
Advisory ID: RHSA-2011:0491-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2011-0491.html
Issue date: 2011-05-05
CVE Names: CVE-2009-3720 CVE-2010-1634 CVE-2010-2089
CVE-2010-3493 CVE-2011-1015 CVE-2011-1521
=====================================================================

1. Summary:

Updated python packages that fix multiple security issues are now available
for Red Hat Enterprise Linux 4.

The Red Hat Security Response Team has rated this update as having moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

Python is an interpreted, interactive, object-oriented programming
language.

A flaw was found in the Python urllib and urllib2 libraries where they
would not differentiate between different target URLs when handling
automatic redirects. This caused Python applications using these modules to
follow any new URL that they understood, including the "file://" URL type.
This could allow a remote server to force a local Python application to
read a local file instead of the remote one, possibly exposing local files
that were not meant to be exposed. (CVE-2011-1521)

Multiple flaws were found in the Python audioop module. Supplying certain
inputs could cause the audioop module to crash or, possibly, execute
arbitrary code. (CVE-2010-1634, CVE-2010-2089)

A race condition was found in the way the Python smtpd module handled new
connections. A remote user could use this flaw to cause a Python script
using the smtpd module to terminate. (CVE-2010-3493)

An information disclosure flaw was found in the way the Python
CGIHTTPServer module processed certain HTTP GET requests. A remote attacker
could use a specially-crafted request to obtain the CGI script's source
code. (CVE-2011-1015)

A buffer over-read flaw was found in the way the Python Expat parser
handled malformed UTF-8 sequences when processing XML files. A
specially-crafted XML file could cause Python applications using the Python
Expat parser to crash while parsing the file. (CVE-2009-3720)

This update makes Python use the system Expat library rather than its own
internal copy; therefore, users must have the version of Expat shipped with
RHSA-2009:1625 installed, or a later version, to resolve the CVE-2009-3720
issue.

All Python users should upgrade to these updated packages, which contain
backported patches to correct these issues.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

531697 - CVE-2009-3720 expat: buffer over-read and crash on XML with malformed UTF-8 sequences
590690 - CVE-2010-1634 python: audioop: incorrect integer overflow checks
598197 - CVE-2010-2089 Python: Memory corruption in audioop module
632200 - CVE-2010-3493 Python: SMTP proxy RFC 2821 module DoS (uncaught exception) (Issue #9129)
680094 - CVE-2011-1015 python (CGIHTTPServer): CGI script source code disclosure
690560 - CVE-2011-1521 python (urllib, urllib2): Improper management of ftp:// and file:// URL schemes (Issue #11662)

6. Package List:

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/python-2.3.4-14.10.el4.src.rpm

i386:
python-2.3.4-14.10.el4.i386.rpm
python-debuginfo-2.3.4-14.10.el4.i386.rpm
python-devel-2.3.4-14.10.el4.i386.rpm
python-docs-2.3.4-14.10.el4.i386.rpm
python-tools-2.3.4-14.10.el4.i386.rpm
tkinter-2.3.4-14.10.el4.i386.rpm

ia64:
python-2.3.4-14.10.el4.ia64.rpm
python-debuginfo-2.3.4-14.10.el4.ia64.rpm
python-devel-2.3.4-14.10.el4.ia64.rpm
python-docs-2.3.4-14.10.el4.ia64.rpm
python-tools-2.3.4-14.10.el4.ia64.rpm
tkinter-2.3.4-14.10.el4.ia64.rpm

ppc:
python-2.3.4-14.10.el4.ppc.rpm
python-debuginfo-2.3.4-14.10.el4.ppc.rpm
python-devel-2.3.4-14.10.el4.ppc.rpm
python-docs-2.3.4-14.10.el4.ppc.rpm
python-tools-2.3.4-14.10.el4.ppc.rpm
tkinter-2.3.4-14.10.el4.ppc.rpm

s390:
python-2.3.4-14.10.el4.s390.rpm
python-debuginfo-2.3.4-14.10.el4.s390.rpm
python-devel-2.3.4-14.10.el4.s390.rpm
python-docs-2.3.4-14.10.el4.s390.rpm
python-tools-2.3.4-14.10.el4.s390.rpm
tkinter-2.3.4-14.10.el4.s390.rpm

s390x:
python-2.3.4-14.10.el4.s390x.rpm
python-debuginfo-2.3.4-14.10.el4.s390x.rpm
python-devel-2.3.4-14.10.el4.s390x.rpm
python-docs-2.3.4-14.10.el4.s390x.rpm
python-tools-2.3.4-14.10.el4.s390x.rpm
tkinter-2.3.4-14.10.el4.s390x.rpm

x86_64:
python-2.3.4-14.10.el4.x86_64.rpm
python-debuginfo-2.3.4-14.10.el4.x86_64.rpm
python-devel-2.3.4-14.10.el4.x86_64.rpm
python-docs-2.3.4-14.10.el4.x86_64.rpm
python-tools-2.3.4-14.10.el4.x86_64.rpm
tkinter-2.3.4-14.10.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/python-2.3.4-14.10.el4.src.rpm

i386:
python-2.3.4-14.10.el4.i386.rpm
python-debuginfo-2.3.4-14.10.el4.i386.rpm
python-devel-2.3.4-14.10.el4.i386.rpm
python-docs-2.3.4-14.10.el4.i386.rpm
python-tools-2.3.4-14.10.el4.i386.rpm
tkinter-2.3.4-14.10.el4.i386.rpm

x86_64:
python-2.3.4-14.10.el4.x86_64.rpm
python-debuginfo-2.3.4-14.10.el4.x86_64.rpm
python-devel-2.3.4-14.10.el4.x86_64.rpm
python-docs-2.3.4-14.10.el4.x86_64.rpm
python-tools-2.3.4-14.10.el4.x86_64.rpm
tkinter-2.3.4-14.10.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/python-2.3.4-14.10.el4.src.rpm

i386:
python-2.3.4-14.10.el4.i386.rpm
python-debuginfo-2.3.4-14.10.el4.i386.rpm
python-devel-2.3.4-14.10.el4.i386.rpm
python-docs-2.3.4-14.10.el4.i386.rpm
python-tools-2.3.4-14.10.el4.i386.rpm
tkinter-2.3.4-14.10.el4.i386.rpm

ia64:
python-2.3.4-14.10.el4.ia64.rpm
python-debuginfo-2.3.4-14.10.el4.ia64.rpm
python-devel-2.3.4-14.10.el4.ia64.rpm
python-docs-2.3.4-14.10.el4.ia64.rpm
python-tools-2.3.4-14.10.el4.ia64.rpm
tkinter-2.3.4-14.10.el4.ia64.rpm

x86_64:
python-2.3.4-14.10.el4.x86_64.rpm
python-debuginfo-2.3.4-14.10.el4.x86_64.rpm
python-devel-2.3.4-14.10.el4.x86_64.rpm
python-docs-2.3.4-14.10.el4.x86_64.rpm
python-tools-2.3.4-14.10.el4.x86_64.rpm
tkinter-2.3.4-14.10.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/python-2.3.4-14.10.el4.src.rpm

i386:
python-2.3.4-14.10.el4.i386.rpm
python-debuginfo-2.3.4-14.10.el4.i386.rpm
python-devel-2.3.4-14.10.el4.i386.rpm
python-docs-2.3.4-14.10.el4.i386.rpm
python-tools-2.3.4-14.10.el4.i386.rpm
tkinter-2.3.4-14.10.el4.i386.rpm

ia64:
python-2.3.4-14.10.el4.ia64.rpm
python-debuginfo-2.3.4-14.10.el4.ia64.rpm
python-devel-2.3.4-14.10.el4.ia64.rpm
python-docs-2.3.4-14.10.el4.ia64.rpm
python-tools-2.3.4-14.10.el4.ia64.rpm
tkinter-2.3.4-14.10.el4.ia64.rpm

x86_64:
python-2.3.4-14.10.el4.x86_64.rpm
python-debuginfo-2.3.4-14.10.el4.x86_64.rpm
python-devel-2.3.4-14.10.el4.x86_64.rpm
python-docs-2.3.4-14.10.el4.x86_64.rpm
python-tools-2.3.4-14.10.el4.x86_64.rpm
tkinter-2.3.4-14.10.el4.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2009-3720.html
https://www.redhat.com/security/data/cve/CVE-2010-1634.html
https://www.redhat.com/security/data/cve/CVE-2010-2089.html
https://www.redhat.com/security/data/cve/CVE-2010-3493.html
https://www.redhat.com/security/data/cve/CVE-2011-1015.html
https://www.redhat.com/security/data/cve/CVE-2011-1521.html
https://access.redhat.com/security/updates/classification/#moderate
https://rhn.redhat.com/errata/RHSA-2009-1625.html

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2011 Red Hat, Inc.

[RHSA-2011:0490-01] Critical: java-1.4.2-ibm security update
=====================================================================
Red Hat Security Advisory

Synopsis: Critical: java-1.4.2-ibm security update
Advisory ID: RHSA-2011:0490-01
Product: Red Hat Enterprise Linux Extras
Advisory URL: https://rhn.redhat.com/errata/RHSA-2011-0490.html
Issue date: 2011-05-05
CVE Names: CVE-2010-4447 CVE-2010-4448 CVE-2010-4454
CVE-2010-4462 CVE-2010-4465 CVE-2010-4466
CVE-2010-4473 CVE-2010-4475 CVE-2011-0311
=====================================================================

1. Summary:

Updated java-1.4.2-ibm packages that fix several security issues are now
available for Red Hat Enterprise Linux 4 Extras and Red Hat Enterprise
Linux 5 Supplementary.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Desktop version 4 Extras - i386, x86_64
Red Hat Enterprise Linux AS version 4 Extras - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux ES version 4 Extras - i386, ia64, x86_64
Red Hat Enterprise Linux Server Supplementary (v. 5) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux WS version 4 Extras - i386, ia64, x86_64

3. Description:

The IBM 1.4.2 SR13-FP9 Java release includes the IBM Java 2 Runtime
Environment and the IBM Java 2 Software Development Kit.

This update fixes several vulnerabilities in the IBM Java 2 Runtime
Environment and the IBM Java 2 Software Development Kit. Detailed
vulnerability descriptions are linked from the IBM "Security alerts" page,
listed in the References section. (CVE-2010-4447, CVE-2010-4448,
CVE-2010-4454, CVE-2010-4462, CVE-2010-4465, CVE-2010-4466, CVE-2010-4473,
CVE-2010-4475, CVE-2011-0311)

All users of java-1.4.2-ibm are advised to upgrade to these updated
packages, which contain the IBM 1.4.2 SR13-FP9 Java release. All running
instances of IBM Java must be restarted for this update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

675984 - CVE-2010-4465 OpenJDK Swing timer-based security manager bypass (6907662)
676023 - CVE-2010-4448 OpenJDK DNS cache poisoning by untrusted applets (6981922)
677957 - CVE-2010-4475 JDK unspecified vulnerability in Deployment component
677958 - CVE-2010-4473 JDK unspecified vulnerability in Sound component
677961 - CVE-2010-4466 JDK unspecified vulnerability in Deployment component
677966 - CVE-2010-4462 JDK unspecified vulnerability in Sound component
677967 - CVE-2010-4454 JDK unspecified vulnerability in Sound component
677970 - CVE-2010-4447 JDK unspecified vulnerability in Deployment component
702349 - CVE-2011-0311 IBM JDK Class file parsing denial-of-service

6. Package List:

Red Hat Enterprise Linux AS version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.ia64.rpm

ppc:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.ppc64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.ppc64.rpm

s390:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el4.s390.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.s390.rpm

s390x:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.s390x.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.s390x.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.s390x.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.s390x.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.x86_64.rpm

Red Hat Desktop version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.i386.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.ia64.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4 Extras:

i386:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el4.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.ia64.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el4.x86_64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 5):

i386:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.i386.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.x86_64.rpm

Red Hat Enterprise Linux Server Supplementary (v. 5):

i386:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.i386.rpm

ia64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.ia64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.ia64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.ia64.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.ia64.rpm

ppc:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.ppc64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.ppc.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.ppc64.rpm

s390x:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.s390x.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.s390x.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.s390x.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.s390.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.s390x.rpm

x86_64:
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-demo-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-devel-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-javacomm-1.4.2.13.9-1jpp.1.el5.x86_64.rpm
java-1.4.2-ibm-jdbc-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-plugin-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.i386.rpm
java-1.4.2-ibm-src-1.4.2.13.9-1jpp.1.el5.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-4447.html
https://www.redhat.com/security/data/cve/CVE-2010-4448.html
https://www.redhat.com/security/data/cve/CVE-2010-4454.html
https://www.redhat.com/security/data/cve/CVE-2010-4462.html
https://www.redhat.com/security/data/cve/CVE-2010-4465.html
https://www.redhat.com/security/data/cve/CVE-2010-4466.html
https://www.redhat.com/security/data/cve/CVE-2010-4473.html
https://www.redhat.com/security/data/cve/CVE-2010-4475.html
https://www.redhat.com/security/data/cve/CVE-2011-0311.html
https://access.redhat.com/security/updates/classification/#critical
http://www.ibm.com/developerworks/java/jdk/alerts/

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2011 Red Hat, Inc.




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/pythonjava_security_updates_for_rhel.html)