PySwfdec 0.4.4
Posted on: 04/30/2007 06:18 PM

Version 0.4.4 of the Python bindings for PySwfdec is available

http://swfdec.freedesktop.org/download/pyswfdec/0.4/pyswfdec-0.4.4.tar.gz
MD5: f25aa70d2ca96e89411e91cb7357e39c

The bindings are updated with the new Swfdec API 0.4.4

PySwfdec 0.4.4 (Apr 30 2007)
=================================

o First public release (Gian Mario)

Blurb:
=====

Swfdec [1] is the library for decoding and rendering Flash animations. It is still in heavy development. The intended audience are developers or people using it for pretested Flash animations (think embedded here). If you use it on unknown content, expect it to have issues and don't be surprised if it rashes. If you encounter such a crash however, make sure to file a bug [2] immediately.

PySwfdec is a wrapper which exposes the Swfdec API to the python world. It is fairly complete; most of the API are covered.

The documentation is a work in progress, needs quite a lot of work in order to cover 100% of the API, anyway help will be greatly appreciated.

Like the GTK+ library, PyGTK and Swfdec itself PySwfdec is licensed under the GNU LGPL, so is suitable for use in both free software and proprietary applications.

PySwfdec requires:
====================

o Swfdec = 0.4.4
o PyGObject gt;= 2.10.1 (2.11.3 to build the docs)
o PyGTK gt;= 2.10.4

Bug reports should go to
https://launchpad.net/pyswfdec/

[1] http://swfdec.freedesktop.org/wiki/
[2] https://bugzilla.freedesktop.org Use the swfdec component.

cheers
--
Gian Mario Tagliaretti


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/pyswfdec_044.html)