Procmail/Konversation/Lynx-Cur/Imagemagick Updates for Debian
Posted on: 11/18/2017 09:12 AM

The following updates has been released for Debian GNU/Linux:

DLA 1173-1: procmail security update
DLA 1174-1: konversation security update
DLA 1175-1: lynx-cur security update
DSA 4040-1: imagemagick security update

DLA 1173-1: procmail security update



Package : procmail
Version : 3.22-20+deb7u2
CVE ID : CVE-2017-16844
Debian Bug : #876511

It was discovered that there was a heap-based buffer overflow in procmail, a
tool used to sort incoming mail into various directories and filter out spam
messages.

For Debian 7 "Wheezy", this issue has been fixed in procmail version
3.22-20+deb7u2.

We recommend that you upgrade your procmail packages.





DLA 1174-1: konversation security update



Package : konversation
Version : 1.4-1+deb7u2
CVE ID : CVE-2017-15923
Debian Bug : #881586

It was discovered that there was a denial of service vulnerability in the
konversation IRC client related to parsing of color formatting codes.

For Debian 7 "Wheezy", this issue has been fixed in konversation version
1.4-1+deb7u2.

We recommend that you upgrade your konversation packages.





DLA 1175-1: lynx-cur security update



Package : lynx-cur
Version : 2.8.8dev.12-2+deb7u2
CVE ID : CVE-2017-1000211

It was discovered that there was a use-after-free vulnerability in the
HTML parser of lynx-cur, a terminal-based web browser. This could have
led to memory/information disclosure.

For Debian 7 "Wheezy", this issue has been fixed in lynx-cur version
2.8.8dev.12-2+deb7u2.

We recommend that you upgrade your lynx-cur packages.





DSA 4040-1: imagemagick security update



- -------------------------------------------------------------------------
Debian Security Advisory DSA-4040-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
November 17, 2017 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : imagemagick
CVE ID : CVE-2017-11352 CVE-2017-11640 CVE-2017-12431
CVE-2017-12640 CVE-2017-12877 CVE-2017-12983
CVE-2017-13134 CVE-2017-13139 CVE-2017-13144
CVE-2017-13758 CVE-2017-13769 CVE-2017-14224
CVE-2017-14607 CVE-2017-14682 CVE-2017-14989
CVE-2017-15277 CVE-2017-16546

This update fixes several vulnerabilities in imagemagick: Various memory
handling problems and cases of missing or incomplete input sanitising
may result in denial of service, memory disclosure or the execution of
arbitrary code if malformed image files are processed.

For the oldstable distribution (jessie), these problems have been fixed
in version 8:6.8.9.9-5+deb8u11.

We recommend that you upgrade your imagemagick packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/procmailkonversationlynx_curimagemagick_updates_for_debian.html)