Pidgin/Iceweasel Updates for Debian
Posted on: 03/20/2014 10:46 AM

The following two updates are available for Debian:

[DSA 2859-2] pidgin security update
[DSA 2881-1] iceweasel security update

[DSA 2859-2] pidgin security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2859-2 security@debian.org
http://www.debian.org/security/ Raphael Geissert
March 19, 2014 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : pidgin
CVE ID : CVE-2013-6485 CVE-2013-6490

Multiple vulnerabilities have been discovered in pidgin, a multi-protocol
instant messaging client. In addition to fixing the vulnerabilities,
this revision specific to the oldstable distribution (squeeze),
reduces the supported protocols to: IRC, Jabber/XMPP, Sametime, and
SIMPLE.

Users of other protocols are encouraged to either upgrade to the stable
distribution (wheezy) or to use the version in backports. It must be
noted, however, that the latter is not supported by the Security Team.

For reference, the original description of the vulnerabilities from
DSA-2859-1 is quoted below:

CVE-2013-6485

Matt Jones discovered a buffer overflow in the parsing of malformed
HTTP responses.

CVE-2013-6490

Yves Younan discovered a buffer overflow when parsing SIMPLE
headers.

For the oldstable distribution (squeeze), these problems have been fixed in
version 2.7.3-1+squeeze4.

We recommend that you upgrade your pidgin packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/


[DSA 2881-1] iceweasel security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2881-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
March 19, 2014 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : iceweasel
CVE ID : CVE-2014-1493 CVE-2014-1497 CVE-2014-1505 CVE-2014-1508
CVE-2014-1510 CVE-2014-1511 CVE-2014-1512 CVE-2014-1513
CVE-2014-1514

Multiple security issues have been found in Iceweasel, Debian's version
of the Mozilla Firefox web browser: Multiple memory safety errors, out of
bound reads, use-after-frees and other implementation errors may lead to
the execution of arbitrary code, information disclosure, denial of
service.

For the stable distribution (wheezy), these problems have been fixed in
version 24.4.0esr-1~deb7u2.

For the unstable distribution (sid), these problems have been fixed in
version 24.4.0esr-1.

We recommend that you upgrade your iceweasel packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/pidginiceweasel_updates_for_debian.html)