phpMyAdmin Update for openSUSE
Posted on: 12/30/2017 08:38 AM

Updated phpMyAdmin packages has been released for openSUSE:

openSUSE-SU-2017:3448-1: important: Security update for phpMyAdmin
openSUSE-SU-2017:3451-1: important: Security update for phpMyAdmin

openSUSE-SU-2017:3448-1: important: Security update for phpMyAdmin
openSUSE Security Update: Security update for phpMyAdmin
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3448-1
Rating: important
References: #1074066
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update for phpMyAdmin to version 4.7.7 fixes a security issue and
bugs.

The following vulnerability was fixed:

- By deceiving a user to click on a crafted URL, it was possible to
perform harmful database
operations (bsc#1074066, PMASA-2017-09)

This update also contains all upstream improvements and bugfixes in
version 4.7.7:

- various display and UI fixes
- PHP error fixes
- Improved deteciton of MySQL server needing SSL connections
- Support JSON datatype on MariaDB 10.2.7 and newer
- Fix constructing ALTER query with AFTER
- Fix changing password on MariaDB cluster


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1421=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1421=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (noarch):

phpMyAdmin-4.7.7-6.1

- openSUSE Leap 42.2 (noarch):

phpMyAdmin-4.7.7-33.12.1


References:

https://bugzilla.suse.com/1074066


openSUSE-SU-2017:3451-1: important: Security update for phpMyAdmin
openSUSE Security Update: Security update for phpMyAdmin
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3451-1
Rating: important
References: #1074066
Affected Products:
SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update for phpMyAdmin to version 4.7.7 fixes a security issue and
bugs.

The following vulnerability was fixed:

- By deceiving a user to click on a crafted URL, it was possible to
perform harmful database
operations (bsc#1074066, PMASA-2017-09)

This update also contains all upstream improvements and bugfixes in
version 4.7.7:

- various display and UI fixes
- PHP error fixes
- Improved deteciton of MySQL server needing SSL connections
- Support JSON datatype on MariaDB 10.2.7 and newer
- Fix constructing ALTER query with AFTER
- Fix changing password on MariaDB cluster


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Package Hub for SUSE Linux Enterprise 12:

zypper in -t patch openSUSE-2017-1421=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Package Hub for SUSE Linux Enterprise 12 (noarch):

phpMyAdmin-4.7.7-14.1


References:

https://bugzilla.suse.com/1074066






Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/phpmyadmin_update_for_opensuse.html)