PHP Update for Slackware
Posted on: 07/21/2004 06:54 AM

Updated PHP packages are available for Slackware Linux 8.1 - 10.0:

New PHP packages are available for Slackware 8.1, 9.0, 9.1, 10.0, and -current to fix security issues (memory_limit handling and a problem in the strip_tags function). Sites using PHP should upgrade.

More details about this issue may be found in the Common
Vulnerabilities and Exposures (CVE) database:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0594
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0595

Here are the details from the Slackware 10.0 ChangeLog:
+--------------------------+
Tue Jul 20 19:35:16 PDT 2004
patches/packages/php-4.3.8-i486-1.tgz: Upgraded to php-4.3.8. This release fixes two security problems in PHP (memory_limit handling and a problem in the strip_tags function). Sites using PHP should upgrade. For more details, see:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0594
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0595
(* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

Updated package for Slackware 8.1:
ftp://ftp.slackware.com/pub/slackware/slackware-8.1/patches/packages/php-4.3.8-i386-1.tgz

Updated package for Slackware 9.0:
ftp://ftp.slackware.com/pub/slackware/slackware-9.0/patches/packages/php-4.3.8-i386-1.tgz

Updated package for Slackware 9.1:
ftp://ftp.slackware.com/pub/slackware/slackware-9.1/patches/packages/php-4.3.8-i486-1.tgz

Updated package for Slackware 10.0:
ftp://ftp.slackware.com/pub/slackware/slackware-10.0/patches/packages/php-4.3.8-i486-1.tgz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/php-4.3.8-i486-1.tgz


MD5 signatures:
+-------------+

Slackware 8.1 package:
c6734463934818904828833b9e5dce59 php-4.3.8-i386-1.tgz

Slackware 9.0 package:
73055c5395f4c60b7cf4bbdcfab17e72 php-4.3.8-i386-1.tgz

Slackware 9.1 package:
e2d3374f55e85a14a15ac267193ac55e php-4.3.8-i486-1.tgz

Slackware 10.0 package:
7dfa5a85e080d833ea21fcd81b166977 php-4.3.8-i486-1.tgz

Slackware -current package:
7dfa5a85e080d833ea21fcd81b166977 php-4.3.8-i486-1.tgz


Installation instructions:
+------------------------+

First, stop apache:
# apachectl stop

Next, upgrade to the new PHP package:
# upgradepkg php-4.3.8-i486-1.tgz

Finally, restart apache:
# apachectl start


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/php_update_for_slackware.html)