php (SSA:2007-255-03)
Posted on: 09/13/2007 11:05 AM

New PHP5 packages are available for Slackware 10.1, 10.2, 11.0, and 12.0 to fix "several low priority security bugs."

Note that PHP5 was not officially supported in Slackware 10.1 or 10.2 (being in the /testing directory), and was not the default version of PHP for Slackware 11.0 (being in the /extra directory), but updates are being provided anyway.

Here are the details from the Slackware 12.0 ChangeLog:
+--------------------------+
patches/packages/php-5.2.4-i486-1_slack12.0.tgz:
Upgraded to php-5.2.4. The PHP announcement says this version fixes over
120 bugs as well as "several low priority security bugs."
Read more about it here:
http://www.php.net/releases/5_2_4.php
(* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

HINT: Getting slow download speeds from ftp.slackware.com?
Give slackware.osuosl.org a try. This is another primary FTP site
for Slackware that can be considerably faster than downloading
directly from ftp.slackware.com.

Thanks to the friendly folks at the OSU Open Source Lab
(http://osuosl.org) for donating additional FTP and rsync hosting
to the Slackware project! :-)

Also see the "Get Slack" section on http://slackware.com for
additional mirror sites near you.

Updated package for Slackware 10.1:
ftp://ftp.slackware.com/pub/slackware/slackware-10.1/testing/packages/php5/php-5.2.4-i486-1_slack10.1.tgz

Updated package for Slackware 10.2:
ftp://ftp.slackware.com/pub/slackware/slackware-10.2/testing/packages/php5/php-5.2.4-i486-1_slack10.2.tgz

Updated package for Slackware 11.0:
ftp://ftp.slackware.com/pub/slackware/slackware-11.0/extra/php5/php-5.2.4-i486-1_slack11.0.tgz

Updated package for Slackware 12.0:
ftp://ftp.slackware.com/pub/slackware/slackware-12.0/patches/packages/php-5.2.4-i486-1_slack12.0.tgz


MD5 signatures:
+-------------+

Slackware 10.1 package:
ebe9ba4e1b440422215682ef4a63616a php-5.2.4-i486-1_slack10.1.tgz

Slackware 10.2 package:
dc4516fbfff6219fdcc54fdf76fe4f93 php-5.2.4-i486-1_slack10.2.tgz

Slackware 11.0 package:
03d817c5973d882fee648b060d17ac33 php-5.2.4-i486-1_slack11.0.tgz

Slackware 12.0 package:
237ecf6ba490cf0df9fffd6529cae233 php-5.2.4-i486-1_slack12.0.tgz


Installation instructions:
+------------------------+

First, stop Apache:
# apachectl stop

Next, upgrade to the new PHP package:
# upgradepkg php-5.2.4-i486-1_slack12.0.tgz

Finally, restart Apache:
# apachectl start

Or, for Apache 1.3.x versions using SSL:
# apachectl startssl



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/php_ssa2007_255_03.html)