PHP (SSA:2005-095-01)
Posted on: 04/05/2005 06:25 PM

New PHP packages are available for Slackware 8.1, 9.0, 9.1, 10.0, 10.1, and -current to fix security issues.

More details about the issues may be found in the PHP ChangeLogs on the PHP web site:

Here are the details from the Slackware 10.1 ChangeLog:
patches/packages/php-4.3.11-i486-1.tgz: Upgraded to php-4.3.11.
"This is a maintenance release that in addition to over 70 non-critical bug
fixes addresses several security issues inside the exif and fbsql extensions
as well as the unserialize(), swf_definepoly() and getimagesize() functions."
(* Security fix *)
testing/packages/php-5.0.4/php-5.0.4-i486-1.tgz: Upgraded to php-5.0.4.
Fixes various bugs (and security issues.)
(* Security fix *)

Where to find the new packages:

Updated package for Slackware 8.1:

Updated package for Slackware 9.0:

Updated package for Slackware 9.1:

Updated package for Slackware 10.0:

Updated packages for Slackware 10.1:

Updated packages for Slackware -current:

MD5 signatures:

Slackware 8.1 package:
fdc05e23a4132fc5a27e53fe056e8349 php-4.3.11-i386-1.tgz

Slackware 9.0 package:
c39802066035ae18b087059db9e48d33 php-4.3.11-i386-1.tgz

Slackware 9.1 package:
644da7c59b6b707a4e9afd389c595d33 php-4.3.11-i486-1.tgz

Slackware 10.0 package:
0361b80a4b69d35f3cd7b45f6ae801c3 php-4.3.11-i486-1.tgz

Slackware 10.1 packages:
8a62d6953f5a5a08f59daba2b6bb1085 php-4.3.11-i486-1.tgz
843fe926a820cfbaf2360dd65499ccb0 php-5.0.4-i486-1.tgz

Slackware -current packages:
a03e8b481895e80578b93fe57c0510fc php-4.3.11-i486-1.tgz
843fe926a820cfbaf2360dd65499ccb0 php-5.0.4-i486-1.tgz

Installation instructions:

First, stop apache:
# apachectl stop

Next, upgrade to the new PHP package:
# upgradepkg php-4.3.11-i486-1.tgz

Finally, restart apache:
# apachectl start (or: apachectl startssl)


Slackware Linux Security Team

Printed from Linux Compatible (