PHP 7.2.2 for Debian 8/9
Posted on: 02/06/2018 05:26 PM

Ondřej Surý has released PHP 7.2.2 packages for Debian GNU/Linux 8 and 9

Version 7.2.2
01 Feb 2018
Core:
Fixed bug #75742 (potential memleak in internal classes's static members).
Fixed bug #75679 (Path 260 character problem).
Fixed bug #75614 (Some non-portable == in shell scripts).
Fixed bug #75786 (segfault when using spread operator on generator passed by reference).
Fixed bug #75799 (arg of get_defined_functions is optional).
Fixed bug #75396 (Exit inside generator finally results in fatal error).
FCGI:
Fixed bug #75794 (getenv() crashes on Windows 7.2.1 when second parameter is false).
IMAP:
Fixed bug #75774 (imap_append HeapCorruction).
Opcache:
Fixed bug #75720 (File cache not populated after SHM runs full).
Fixed bug #75687 (var 8 (TMP) has array key type but not value type).
Fixed bug #75698 (Using @ crashes php7.2-fpm).
Fixed bug #75579 (Interned strings buffer overflow may cause crash).
PDO:
Fixed bug #75616 (PDO extension doesn't allow to be built shared on Darwin).
PDO MySQL:
Fixed bug #75615 (PDO Mysql module can't be built as module).
PGSQL:
Fixed bug #75671 (pg_version() crashes when called on a connection to cockroach).
Readline:
Fixed bug #75775 (readline_read_history segfaults with empty file).
SAPI:
Fixed bug #75735 ([embed SAPI] Segmentation fault in sapi_register_post_entry).
SOAP:
Fixed bug #70469 (SoapClient generates E_ERROR even if exceptions=1 is used).
Fixed bug #75502 (Segmentation fault in zend_string_release).
SPL:
Fixed bug #75717 (RecursiveArrayIterator does not traverse arrays by reference).
Fixed bug #75242 (RecursiveArrayIterator doesn't have constants from parent class).
Fixed bug #73209 (RecursiveArrayIterator does not iterate object properties).
Standard:
Fixed bug #75781 (substr_count incorrect result).
Fixed bug #75653 (array_values don't work on empty array).
Zip:
Display headers (buildtime) and library (runtime) versions in phpinfo (with libzip >= 1.3.1).


To add the deb.sury.org PHP repository to your Debian installation, run as root:
apt-get install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list'
apt-get update


To install PHP 7.2 with MySQL/MariaDB and php-fpm support:
apt-get install php7.2-cgi php7.2-gd php7.2-curl php7.2-imap php7.2-sqlite3 php7.2-mysql php7.2-tidy php7.2-pspell php7.2-recode php7.2-xml php7.2-intl php7.2-enchant php7.2-gmp php7.2-mbstring php7.2-soap php7.2-xmlrpc php7.2-zip php7.2-fpm

Please note that the mcrypt package is no longer available after the support has been removed from PHP 7.2


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/php_7_2_2_for_debian_89.html)