PHP 5.3.8 Packages for Debian 6.0
Posted on: 08/23/2011 09:52 PM

Dotdeb.org has released PHP 5.3.8 packages for Debian 6.0

Using Dotdeb is very simple:

For the main Dotdeb repository, depending on your distribution (lenny/oldstable or squeeze/stable), add these two lines to your /etc/apt/sources.list file (choosing a mirror near you) :
Squeeze :
deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all
Lenny :
deb http://packages.dotdeb.org oldstable all
deb-src http://packages.dotdeb.org oldstable all
(Optional) If you’re running Debian 5.0 “Lenny” and you want PHP 5.3 instead of the default PHP 5.2, add these two additionnal lines too :
deb http://php53.dotdeb.org oldstable all
deb-src http://php53.dotdeb.org oldstable all
You don’t need this if you’re running Debian 6.0 “Squeeze” : PHP 5.3 is the default branch

Then fetch the appropriate GnuPG key
wget http://www.dotdeb.org/dotdeb.gpg
cat dotdeb.gpg | sudo apt-key add -
Run apt-get update
You should now be able to use the Dotdeb packages with apt-get (or dselect, or aptitude as well…)



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/php_5_3_8_packages_for_debian_6.html)