PHP 5.3.5 and 5.2.17 for Debian 5.0
Posted on: 01/07/2011 11:29 AM

Dotdeb.org has released PHP 5.3.5 and 5.2.17 packages for Debian GNU/Linux 5.0 to address a critical issue, where conversions from string to double might cause the PHP interpreter to hang on systems using x87 FPU registers.

PHP 5.3.5 and 5.2.17 for Debian 5.0


A few days after releasing PHP 5.3.4 and PHP 5.2.16, the PHP group announced an important security update with PHP 5.3.5 and PHP 5.2.17 :

This release resolves a critical issue, reported as PHP bug #53632 and CVE-2010-4645, where conversions from string to double might cause the PHP interpreter to hang on systems using x87 FPU registers.

The problem is known to only affect x86 32-bit PHP processes, regardless of whether the system hosting PHP is 32-bit or 64-bit. You can test whether your system is affected by running this script from the command line.

All users of PHP are strongly advised to update to these versions immediately.

The Dotdeb packages for Debian “Lenny” 5.0 are now available. You really should upgrade.



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/php_535_and_5217_for_debian_50.html)