PHP 4.4
Posted on: 07/12/2005 06:31 AM

PHP 4.4 has been released

PHP Development Team is would like to announce the immediate release of PHP 4.4.0. This is a maintenance release that addresses a serious memory corruption problem within PHP concerning references. If references were used in a wrong way, PHP would often create memory corruptions which would not always surface and be visible. In other cases it can cause variables and objects to change type or class. If you encountered strange behavior like this, this release might fix it. The increased middle digit was required because the fix that corrected the problem with references changed PHP's internal API. Because of this all binary extension modules need to be recompiled for work with this release again.

Besides this reference problem, this release also fixes numerous other bugs, including a small security problem with our bundled shtool. All Users of PHP are strongly encouraged to upgrade to this release.

Change log
Download


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/php_44_271f.html)