OTRS/Tomcat Updates for openSUSE
Posted on: 11/24/2017 04:49 AM

The following updates are available for SUSE:

openSUSE-SU-2017:3054-1: important: Security update for otrs
openSUSE-SU-2017:3069-1: important: Security update for tomcat
SUSE-SU-2017:3059-1: important: Security update for tomcat

openSUSE-SU-2017:3054-1: important: Security update for otrs
openSUSE Security Update: Security update for otrs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3054-1
Rating: important
References: #1068677 #1069391
Cross-References: CVE-2017-15864 CVE-2017-16664
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for otrs fixes the following security issues:

- CVE-2017-15864: Remote authenticated attackers could have caused otrs to
disclose configuration information, including database credentials
(boo#1068677, OSA-2017-06)
- CVE-2017-16664: Remote authenticated attackers could have caused the
execution of shell commands with the permission of the web server user
(boo#1069391, OSA-2017-07)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1291=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1291=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (noarch):

otrs-3.3.20-14.1
otrs-doc-3.3.20-14.1
otrs-itsm-3.3.14-14.1

- openSUSE Leap 42.2 (noarch):

otrs-3.3.20-5.11.1
otrs-doc-3.3.20-5.11.1
otrs-itsm-3.3.14-5.11.1


References:

https://www.suse.com/security/cve/CVE-2017-15864.html
https://www.suse.com/security/cve/CVE-2017-16664.html
https://bugzilla.suse.com/1068677
https://bugzilla.suse.com/1069391


openSUSE-SU-2017:3069-1: important: Security update for tomcat
openSUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3069-1
Rating: important
References: #1019016 #1042910 #1053352 #1059554 #977410

Cross-References: CVE-2017-12617 CVE-2017-5664 CVE-2017-7674

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves three vulnerabilities and has two
fixes is now available.

Description:

This update for tomcat fixes the following issues:

Security issues fixed:

- CVE-2017-5664: A problem in handling error pages was fixed, to avoid
potential file overwrites during error page handling. (bsc#1042910).
- CVE-2017-7674: A CORS Filter issue could lead to client and server side
cache poisoning (bsc#1053352)
- CVE-2017-12617: A remote code execution possibility via JSP Upload was
fixed (bsc#1059554)

Non security bugs fixed:

- Fix tomcat-digest classpath error (bsc#977410)
- Fix packaged /etc/alternatives symlinks for api libs that caused rpm -V
to report link mismatch (bsc#1019016)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1299=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1299=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (noarch):

tomcat-8.0.43-9.1
tomcat-admin-webapps-8.0.43-9.1
tomcat-docs-webapp-8.0.43-9.1
tomcat-el-3_0-api-8.0.43-9.1
tomcat-embed-8.0.43-9.1
tomcat-javadoc-8.0.43-9.1
tomcat-jsp-2_3-api-8.0.43-9.1
tomcat-jsvc-8.0.43-9.1
tomcat-lib-8.0.43-9.1
tomcat-servlet-3_1-api-8.0.43-9.1
tomcat-webapps-8.0.43-9.1

- openSUSE Leap 42.2 (noarch):

tomcat-8.0.43-6.13.1
tomcat-admin-webapps-8.0.43-6.13.1
tomcat-docs-webapp-8.0.43-6.13.1
tomcat-el-3_0-api-8.0.43-6.13.1
tomcat-embed-8.0.43-6.13.1
tomcat-javadoc-8.0.43-6.13.1
tomcat-jsp-2_3-api-8.0.43-6.13.1
tomcat-jsvc-8.0.43-6.13.1
tomcat-lib-8.0.43-6.13.1
tomcat-servlet-3_1-api-8.0.43-6.13.1
tomcat-webapps-8.0.43-6.13.1


References:

https://www.suse.com/security/cve/CVE-2017-12617.html
https://www.suse.com/security/cve/CVE-2017-5664.html
https://www.suse.com/security/cve/CVE-2017-7674.html
https://bugzilla.suse.com/1019016
https://bugzilla.suse.com/1042910
https://bugzilla.suse.com/1053352
https://bugzilla.suse.com/1059554
https://bugzilla.suse.com/977410


SUSE-SU-2017:3059-1: important: Security update for tomcat
SUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:3059-1
Rating: important
References: #1042910 #1053352 #1059551 #1059554 #977410

Cross-References: CVE-2017-12615 CVE-2017-12616 CVE-2017-12617
CVE-2017-5664 CVE-2017-7674
Affected Products:
SUSE Linux Enterprise Server 12-LTSS
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:



Apache Tomcat was updated to 7.0.82 adding features, fixing bugs and
security issues.

This is another bugfix release, for full details see:

https://tomcat.apache.org/tomcat-7.0-doc/changelog.html

Fixed security issues:

- CVE-2017-5664: A problem in handling error pages was fixed, to avoid
potential file overwrites during error page handling. (bsc#1042910).
- CVE-2017-7674: A CORS Filter issue could lead to client and server side
cache poisoning (bsc#1053352)
- CVE-2017-12617: A remote code execution possibility via JSP Upload was
fixed (bsc#1059554)
- CVE-2017-12616: An information disclosure when using VirtualDirContext
was fixed (bsc#1059551)
- CVE-2017-12615: A Remote Code Execution via JSP Upload was fixed
(bsc#1059554)

Non-security issues fixed:

- Fix tomcat-digest classpath error (bsc#977410)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 12-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-2017-1889=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 12-LTSS (noarch):

tomcat-7.0.82-7.16.1
tomcat-admin-webapps-7.0.82-7.16.1
tomcat-docs-webapp-7.0.82-7.16.1
tomcat-el-2_2-api-7.0.82-7.16.1
tomcat-javadoc-7.0.82-7.16.1
tomcat-jsp-2_2-api-7.0.82-7.16.1
tomcat-lib-7.0.82-7.16.1
tomcat-servlet-3_0-api-7.0.82-7.16.1
tomcat-webapps-7.0.82-7.16.1


References:

https://www.suse.com/security/cve/CVE-2017-12615.html
https://www.suse.com/security/cve/CVE-2017-12616.html
https://www.suse.com/security/cve/CVE-2017-12617.html
https://www.suse.com/security/cve/CVE-2017-5664.html
https://www.suse.com/security/cve/CVE-2017-7674.html
https://bugzilla.suse.com/1042910
https://bugzilla.suse.com/1053352
https://bugzilla.suse.com/1059551
https://bugzilla.suse.com/1059554
https://bugzilla.suse.com/977410





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/otrstomcat_updates_for_opensuse.html)