Optipng/Sox Updates for Debian 7 LTS
Posted on: 12/01/2017 06:56 AM

The following updates has been released for Debian GNU/Linux 7 LTS:

DLA 1196-1: optipng security update
DLA 1197-1: sox security update

DLA 1196-1: optipng security update
Package : optipng
Version : 0.6.4-1+deb7u4
CVE ID : CVE-2017-16938
Debian Bug : 878839

optipng, an advanced PNG (Portable Network Graphics) optimizer, has
been found vulnerable to a buffer overflow which allows remote
attackers to cause a denial-of-service attack or other unspecified
impact with a maliciously crafted GIF format file, related to an
uncontrolled loop in the LZWReadByte function of the gifread.c file.

For Debian 7 "Wheezy", these problems have been fixed in version
0.6.4-1+deb7u4.

We recommend that you upgrade your optipng packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS




DLA 1197-1: sox security update



Package : sox
Version : 14.4.0-3+deb7u2
CVE ID : CVE-2017-11332 CVE-2017-11358 CVE-2017-11359
CVE-2017-15370 CVE-2017-15371 CVE-2017-15372
CVE-2017-15642
Debian Bug : 870328 878810 878809 878808 882236 882144

Various security vulnerabilities were discovered in sox, a command
line utility to convert audio formats, that may lead to a
denial-of-service (application crash / infinite loop) or memory
corruptions by processing a malformed input file.

For Debian 7 "Wheezy", these problems have been fixed in version
14.4.0-3+deb7u2.

We recommend that you upgrade your sox packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS






Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/optipngsox_updates_for_debian_7_lts.html)