Opera/Quagga Security Updates for openSUSE
Posted on: 10/25/2011 01:32 PM

Updated Opera and Quagga packages are available for openSUSE

[security-announce] openSUSE-SU-2011:1172-1: important: opera: Release 11.52 to fix memory corruption via SVG content
openSUSE Security Update: opera: Release 11.52 to fix memory corruption via SVG content
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1172-1
Rating: important
References: #724754
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that contains security fixes can now be
installed. It includes one version update.

Description:

This update of Opera fixes a memory flaw in the code that
processes SVG content which could be exploited by attackers
to execute arbitrary code through specially crafted
websites.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch opera-5314

- openSUSE 11.3:

zypper in -t patch opera-5314

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64) [New Version: 11.52]:

opera-11.52-0.2.1
opera-gtk-11.52-0.2.1
opera-kde4-11.52-0.2.1

- openSUSE 11.3 (i586 x86_64) [New Version: 11.52]:

opera-11.52-0.2.1
opera-gtk-11.52-0.2.1
opera-kde4-11.52-0.2.1


References:

https://bugzilla.novell.com/724754


[security-announce] SUSE-SU-2011:1171-1: important: Security update for quagga
SUSE Security Update: Security update for quagga
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:1171-1
Rating: important
References: #718056 #718058 #718059 #718061 #718062
Cross-References: CVE-2011-3323 CVE-2011-3324 CVE-2011-3325
CVE-2011-3326 CVE-2011-3327
Affected Products:

______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:


This update fixes the following security issues in quagga:

* 718056: OSPF6D buffer overflow while decoding Link
State Update with Inter Area Prefix Lsa (CVE-2011-3323)
* 718058: OSPF6D DoS while decoding Database
Description packet (CVE-2011-3324)
* 718059: OSPFD DoS while decoding Hello packet
(CVE-2011-3325)
* 718061: OSPFD DoS while decoding Link State Update
(CVE-2011-3326)
* 718062: DoS while decoding EXTENDED_COMMUNITIES in
Quagga's BGP (CVE-2011-3327)

Security Issue references:

* CVE-2011-3323

* CVE-2011-3324

* CVE-2011-3325

* CVE-2011-3326

* CVE-2011-3327


Indications:

Please install this update.


Package List:


References:

http://support.novell.com/security/cve/CVE-2011-3323.html
http://support.novell.com/security/cve/CVE-2011-3324.html
http://support.novell.com/security/cve/CVE-2011-3325.html
http://support.novell.com/security/cve/CVE-2011-3326.html
http://support.novell.com/security/cve/CVE-2011-3327.html
https://bugzilla.novell.com/718056
https://bugzilla.novell.com/718058
https://bugzilla.novell.com/718059
https://bugzilla.novell.com/718061
https://bugzilla.novell.com/718062
http://download.novell.com/patch/finder/?keywords=b0427e8239de7b04885a01efa30e0599





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/operaquagga_security_updates_for_opensuse.html)