OpenVPN/Open DC Hub Updates for Gentoo
Posted on: 11/20/2013 11:53 AM

The following two security updates has been released for Gentoo Linux: [ GLSA 201311-13 ] OpenVPN: Multiple vulnerabilities and [ GLSA 201311-12 ] Open DC Hub: Arbitrary code execution

[ GLSA 201311-13 ] OpenVPN: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201311-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: OpenVPN: Multiple vulnerabilities
Date: November 20, 2013
Bugs: #293894, #468756
ID: 201311-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in OpenVPN, allowing remote
attackers to read encrypted traffic.

Background
==========

OpenVPN is a multi-platform, full-featured SSL VPN solution.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/openvpn < 2.3.1 >= 2.3.1

Description
===========

Multiple vulnerabilities have been discovered in OpenVPN. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker may be able to recover plaintext from an encrypted
communication. Another vulnerability could allow remote attacker
perform a Man-in-the-Middle attack.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All OpenVPN users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/openvpn-2.3.1"

References
==========

[ 1 ] CVE-2009-3555
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3555
[ 2 ] CVE-2013-2061
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2061

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201311-13.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201311-12 ] Open DC Hub: Arbitrary code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201311-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Open DC Hub: Arbitrary code execution
Date: November 20, 2013
Bugs: #314551
ID: 201311-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Open DC Hub could result in execution of arbitrary
code.

Background
==========

Open DC Hub is the hub software for the Direct Connect file sharing
network.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-p2p/opendchub < 0.8.2 >= 0.8.2

Description
===========

A stack-based buffer overflow flaw has been discovered in the way Open
DC Hub sanitized content of a user's MyINFO message.

Impact
======

A remote authenticated user may be able to execute arbitrary code or
cause a Denial of Service condition via specially crafted MyINFO
message.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Open DC Hub users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-p2p/opendchub-0.8.2"

References
==========

[ 1 ] CVE-2010-1147
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2010-1147

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201311-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/openvpnopen_dc_hub_updates_for_gentoo.html)