Openswan/krb5 Updates for Debian
Posted on: 12/27/2011 11:59 AM

The following two updates are available for Debian GNU/Linux: [SECURITY] [DSA 2375-1] krb5. krb5-appl security update, and [SECURITY] [DSA 2374-1] openswan security update

[SECURITY] [DSA 2375-1] krb5. krb5-appl security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2375-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
December 26, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : krb5, krb5-appl
Vulnerability : buffer overflow
Problem type : remote
Debian-specific: no
CVE ID : CVE-2011-4862

It was discovered that the encryption support for BSD telnetd contains
a pre-authentication buffer overflow, which may enable remote
attackers who can connect to the Telnet port to execute arbitrary code
with root privileges.

For the oldstable distribution (lenny), this problem has been fixed in
version 1.6.dfsg.4~beta1-5lenny7 of the krb5 package.

For the stable distribution (squeeze), this problem has been fixed in
version 1:1.0.1-1.2 of the krb5-appl package.

For the testing distribution (wheezy) and the unstable distribution
(sid), this problem will be fixed soon.

We recommend that you upgrade your krb5 and krb5-appl packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA 2374-1] openswan security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2374-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
December 26, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : openswan
Vulnerability : implementation error
Problem type : remote
Debian-specific: no
CVE ID : CVE-2011-4073
Debian Bug : 650674

The information security group at ETH Zurich discovered a denial of
service vulnerability in the crypto helper handler of the IKE daemon
pluto. More information can be found in the upstream advisory at
http://openswan.org/download/CVE-2011-4073/CVE-2011-4073.txt

For the oldstable distribution (lenny), this problem has been fixed in
version 1:2.4.12+dfsg-1.3+lenny4.

For the stable distribution (squeeze), this problem has been fixed in
version 1:2.6.28+dfsg-5+squeeze1.

For the unstable distribution (sid), this problem has been fixed in
version 1:2.6.37-1.

We recommend that you upgrade your openswan packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/openswankrb5_updates_for_debian.html)