openSUSE-SU-2012:0107-1: important: libxml2: fixing heap-based buffer overflow (CVE-2011-3919)
Posted on: 01/19/2012 09:31 PM

A libxml2 update has been released for openSUSE 11.3 and 11.4

openSUSE Security Update: libxml2: fixing heap-based buffer overflow (CVE-2011-3919)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0107-1
Rating: important
References: #739894
Cross-References: CVE-2011-3919
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

A heap-based buffer overflow during decoding of entity
references with overly long names has been fixed.
CVE-2011-3919 has been assigned.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libxml2-5659

- openSUSE 11.3:

zypper in -t patch libxml2-5659

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

libxml2-2.7.8-16.21.1
libxml2-devel-2.7.8-16.21.1

- openSUSE 11.4 (x86_64):

libxml2-32bit-2.7.8-16.21.1
libxml2-devel-32bit-2.7.8-16.21.1

- openSUSE 11.4 (noarch):

libxml2-doc-2.7.8-16.21.1

- openSUSE 11.3 (i586 x86_64):

libxml2-2.7.7-4.11.1
libxml2-devel-2.7.7-4.11.1

- openSUSE 11.3 (x86_64):

libxml2-32bit-2.7.7-4.11.1
libxml2-devel-32bit-2.7.7-4.11.1

- openSUSE 11.3 (noarch):

libxml2-doc-2.7.7-4.11.1


References:

http://support.novell.com/security/cve/CVE-2011-3919.html
https://bugzilla.novell.com/739894



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/opensuse_su_20120107_1_important_libxml2_fixing_heap_based_buffer_overflow_cve_2011_3919.html)