openSUSE-SU-2011:0884-1: important: apache2-mod_fcgid: fixed possible stack overflow due to wrong pointer arithmetic (CVE-2010-3872)
Posted on: 08/10/2011 03:52 PM

An Apache2-mod_fcgid security update has been released for openSUSE 11.3


Announcement ID: openSUSE-SU-2011:0884-1
Rating: important
References: #656092
Cross-References: CVE-2010-3872
Affected Products:
openSUSE 11.3

An update that fixes one vulnerability is now available.


A possible stack overflow in apache2-mod_fcgid due to wrong
pointer arithmetic has been fixed. CVE-2010-3872 has been
assigned to this issue.

Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch apache2-mod_fcgid-4933

To bring your system up-to-date, use "zypper patch".

Package List:

- openSUSE 11.3 (i586 x86_64):



Printed from Linux Compatible (