OpenOffice/Ikiwiki Updates for Debian
Posted on: 05/17/2012 09:02 AM

The following two updates has been released for Debian GNU/Linux: [SECURITY] [DSA 2474-1] ikiwiki security update and [SECURITY] [DSA 2473-1] openoffice.org security update

[SECURITY] [DSA 2474-1] ikiwiki security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2474-1 security@debian.org
http://www.debian.org/security/ Raphael Geissert
May 16, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : ikiwiki
Vulnerability : cross-site scripting
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-0220

Raúl Benencia discovered that ikiwiki, a wiki compiler, does not
properly escape the author (and its URL) of certain metadata, such as
comments. This might be used to conduct cross-site scripting attacks.

For the stable distribution (squeeze), this problem has been fixed in
version 3.20100815.9.

For the testing distribution (wheezy), this problem will be fixed soon.

For the unstable distribution (sid), this problem has been fixed in
version 3.20120516.

We recommend that you upgrade your ikiwiki packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA 2473-1] openoffice.org security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2473-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
May 16, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : openoffice.org
Vulnerability : buffer overflow
Problem type : local (remote)
Debian-specific: no
CVE ID : CVE-2012-1149

Tielei Wang discovered that OpenOffice.org does not allocate a large
enough memory region when processing a specially crafted JPEG object,
leading to a heap-based buffer overflow and potentially arbitrary code
execution.

For the stable distribution (squeeze), this problem has been fixed in
version 1:3.2.1-11+squeeze5.

For the testing distribution (wheezy) and the unstable distribution
(sid), this problem has been fixed in version 1:3.4.5-1 of the
libreoffice package.

We recommend that you upgrade your openoffice.org packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/openofficeikiwiki_updates_for_debian.html)