OpenJPEG/Asterisk Updates for Gentoo
Posted on: 06/21/2012 07:58 AM

Security updates for OpenJPEG and Asterisk are available for Gentoo Linux

[ GLSA 201206-06 ] OpenJPEG: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201206-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: OpenJPEG: User-assisted execution of arbitrary code
Date: June 21, 2012
Bugs: #409203
ID: 201206-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in OpenJPEG could result in execution of arbitrary
code.

Background
==========

OpenJPEG is an open-source JPEG 2000 library.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/openjpeg < 1.5.0 >= 1.5.0

Description
===========

An error in jp2.c of OpenJPEG could allow an out-of-bounds write error.

Impact
======

A remote attacker could entice a user to open a specially crafted JPEG
file, possibly resulting in execution of arbitrary code or a Denial of
Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All OpenJPEG users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/openjpeg-1.5.0"

References
==========

[ 1 ] CVE-2012-1499
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1499

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201206-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201206-05 ] Asterisk: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201206-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Asterisk: Multiple vulnerabilities
Date: June 21, 2012
Bugs: #413353, #418189, #418191
ID: 201206-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in Asterisk might allow remote attackers to
execute arbitrary code.

Background
==========

Asterisk is an open source telephony engine and toolkit.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/asterisk < 1.8.12.1 >= 1.8.12.1

Description
===========

Multiple vulnerabilities have been found in Asterisk:

* An error in manager.c allows shell access through the MixMonitor
application, GetVar, or Status (CVE-2012-2414).
* An error in chan_skinny.c could cause a heap-based buffer overflow
(CVE-2012-2415).
* An error in chan_sip.c prevents Asterisk from checking if a channel
exists before connected line updates (CVE-2012-2416).
* An error in chan_iax2.c may cause an invalid pointer to be called
(CVE-2012-2947).
* chan_skinny.c contains a NULL pointer dereference (CVE-2012-2948).

Impact
======

A remote attacker could execute arbitrary code with the privileges of
the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Asterisk users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.12.1"

References
==========

[ 1 ] CVE-2012-2414
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2414
[ 2 ] CVE-2012-2415
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2415
[ 3 ] CVE-2012-2416
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2416
[ 4 ] CVE-2012-2947
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2947
[ 5 ] CVE-2012-2948
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2948

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201206-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/openjpegasterisk_updates_for_gentoo.html)