Nginx/cURL updates for Gentoo
Posted on: 06/23/2014 08:22 AM

The following two updates has been released for Gentoo Linux:

[ GLSA 201406-20 ] nginx: Arbitrary code execution
[ GLSA 201406-21 ] cURL: Multiple vulnerabilities

[ GLSA 201406-20 ] nginx: Arbitrary code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201406-20
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: nginx: Arbitrary code execution
Date: June 22, 2014
Bugs: #505018
ID: 201406-20

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been found in nginx which may allow execution of
arbitrary code.

Background
==========

nginx is a robust, small, and high performance HTTP and reverse proxy
server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-servers/nginx < 1.4.7 >= 1.4.7

Description
===========

A bug in the SPDY implementation in nginx was found which might cause a
heap memory buffer overflow in a worker process by using a specially
crafted request. The SPDY implementation is not enabled in default
configurations.

Impact
======

A remote attacker could cause execution of arbitrary code by using a
specially crafted request.

Workaround
==========

Disable the spdy module in NGINX_MODULES_HTTP.

Resolution
==========

All nginx users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/nginx-1.4.7"

References
==========

[ 1 ] CVE-2014-0133
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0133

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201406-20.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5





[ GLSA 201406-21 ] cURL: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201406-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: cURL: Multiple vulnerabilities
Date: June 22, 2014
Bugs: #505864
ID: 201406-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in cURL, the worst of
which could lead to man-in-the-middle attacks.

Background
==========

cURL is a command line tool for transferring files with URL syntax,
supporting numerous protocols.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/curl < 7.36.0 >= 7.36.0

Description
===========

Multiple vulnerabilities have been discovered in cURL. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could cause a man-in-the-middle attack via a crafted
certificate issued by a legitimate certification authority.
Furthermore, a context-dependent attacker may be able to bypass
security restrictions by connecting as other users.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All cURL users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/curl-7.36.0"

References
==========

[ 1 ] CVE-2014-0138
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0138
[ 2 ] CVE-2014-0139
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0139

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201406-21.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5








Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/nginxcurl_updates_for_gentoo.html)