NGINX Update for Gentoo Linux
Posted on: 06/18/2016 09:41 AM

A NGINX security update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201606-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: nginx: Multiple vulnerabilities
Date: June 17, 2016
Bugs: #560854, #573046, #584744
ID: 201606-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in nginx, the worst of which
may allow a remote attacker to cause a Denial of Service.

Background
==========

nginx is a robust, small, and high performance HTTP and reverse proxy
server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-servers/nginx < 1.10.1 >= 1.10.1

Description
===========

Multiple vulnerabilities have been discovered in nginx. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly cause a Denial of Service condition
via a crafted packet.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All nginx users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/nginx-1.10.1"

References
==========

[ 1 ] CVE-2013-3587
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-3587
[ 2 ] CVE-2016-0742
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0742
[ 3 ] CVE-2016-0746
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0746
[ 4 ] CVE-2016-0747
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0747
[ 5 ] CVE-2016-4450
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-4450
[ 6 ] CVE-2016-4450
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-4450

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201606-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2016 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/nginx_update_for_gentoo_linux.html)