New postgresql-8.3/poppler Updates for Debian
Posted on: 10/13/2010 11:33 AM

Two new security updates are available for Debian GNU/Linux:

- [DSA 2120-1] New postgresql-8.3 packages fix privilege escalation
- [DSA 2116-1] New poppler packages fix several vulnerabilities

[SECURITY] [DSA 2120-1] New postgresql-8.3 packages fix privilege escalation
- ------------------------------------------------------------------------
Debian Security Advisory DSA-2120-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
October 12, 2010 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : postgresql-8.3
Vulnerability : privilege escalation
Problem type : remote
Debian-specific: no
CVE Id(s) : CVE-2010-3433

Tim Bunce discovered that PostgreSQL, a database server software, does
not properly separate interpreters for server-side stored procedures
which run in different security contexts. As a result, non-privileged
authenticated database users might gain additional privileges.

Note that this security update may impact intended communication through
global variables between stored procedures. It might be necessary to
convert these functions to run under the plperlu or pltclu languages,
with database superuser privileges.

This security update also includes unrelated bug fixes from PostgreSQL
8.3.12.

For the stable distribution (lenny), this problem has been fixed in
version 8.3_8.3.12-0lenny1.

For the unstable distribution (sid), this problem has been fixed in
version 8.4.5-1 of the postgresql-8.4 package.

We recommend that you upgrade your PostgreSQL packages.

Upgrade instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Source archives:

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1.dsc
Size/MD5 checksum: 2313 1663c4c9915f51a31ff6e6b7b3bda545
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12.orig.tar.gz
Size/MD5 checksum: 13955500 03b56e23c3bcdc36eee3156334b8b97b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1.diff.gz
Size/MD5 checksum: 52479 e39048a272b6085ad0dce1933a1b1f5b

Architecture independent packages:

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-doc_8.3.12-0lenny1_all.deb
Size/MD5 checksum: 273756 95f2dc5525e464769715c302d9141df4
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib_8.3.12-0lenny1_all.deb
Size/MD5 checksum: 273824 0c762a2fed4bf2b85120b4fc6a3c5d09
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-doc-8.3_8.3.12-0lenny1_all.deb
Size/MD5 checksum: 2213230 61228c350de23b18674fc3a2b0d11e44
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql_8.3.12-0lenny1_all.deb
Size/MD5 checksum: 273944 b89079dac539bbbaed5794bee7f4d3c3
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client_8.3.12-0lenny1_all.deb
Size/MD5 checksum: 273928 744cf8e343f7c1c658eb64f976797736

alpha architecture (DEC Alpha)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 293706 41c14c7e0ea6dc1f6b4015fa0b3bdc9a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 638416 e3c55350fc57d889281157d9047da119
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 498186 27c76b0e919d5d98d5573dd3cf8a29b4
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 1720192 853975a17102b21ae9bcfe8ada0e8f20
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 412750 6514158a601f1f553c2930a647f777a1
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 282464 ceca3e409d28a80f4fc409a01f605065
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 292584 0435ab52cdf05454cc911432c03276fa
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 850022 2ff3573cbdd9dd0d89666a619c7e43b9
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 302546 e1dfd28c264c5f99ce6e6e7b25500b61
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 496608 e75ba2ed5ddbc07fda238362eb338704
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 303562 63f271eb8cce73be1f042c6c31e2224f
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 5292026 c90ade8e22f2a466495af72b640582b0
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_alpha.deb
Size/MD5 checksum: 303396 1048e079e19085fb49d8e8879b0c7682

amd64 architecture (AMD x86_64 (AMD64))

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 845666 571a85c907cd1049eb69c0a173ea229c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 303486 1f72dfeb519ddbd0bbcda4adc7ac9fcd
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 480076 4fb675f2161719be5c34e6a3ae3f493a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 5396674 fb795f5e2f82bd737dc5b683ae762f2c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 295840 bb76af77727dba4e073015558c2d0d3f
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 281942 c26daa35278a30b9a24d2ec3eeb1b36e
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 638362 6640776b67da831335bff1c416c078f0
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 303242 0fa23a3b0d13ad45f44abbb8e12b8ae5
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 293468 21691ffbf4b375416cb6a373acca3c5d
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 493324 4edc87e5bf26ae5741deec0a4f98f4f5
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 1719356 c8d1430b1c726bfc14099a3385caa738
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 410660 16bdc75eb32b9ce92b073687fc3a0964
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_amd64.deb
Size/MD5 checksum: 303432 f7ba00803839065631bfe1d1774dbfaa

arm architecture (ARM)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 301112 a5df14f8691ad685492dafd63dc40a9a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 596638 6a0ad22877f25451441d1a2ac6290d63
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 483586 a07be84ebcbda4a5b66f369db5627609
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 294428 e8588b0615f24a8e1f59639d79dcc58c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 846312 15aad136f44666278e3abd53d81ca6cf
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 292710 14405d350edd9785f50995c42af99ef6
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 280242 3cc152007f25c3e5e67ae2d76ae88ec8
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 402520 eb0b6808eff4627537ee849f85aa2022
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 467094 6d650f632413b6355d8ba2f723bace7a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 1675396 9e06b75311d15c3c5be9c70247209223
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 299930 e65d0b6236715895ddca25c25dd3b97b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 5259654 be81383c46ca9ce3078f466437e1e9a3
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_arm.deb
Size/MD5 checksum: 300516 320cc1a688d67ab0253e72f82d6837ed

armel architecture (ARM EABI)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 292748 ee53aaa6f7fa8b32093780bb4d33cde5
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 404396 2fe5eb94911d6a90b2a9aa08c38b5070
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 302472 f4b14a63544be2869b0bea6eef7dd01b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 468264 ace0d30bb34ab6ed6e6230d88b20385e
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 5261738 338f5f6b2b138851a68a15e4a82d7d44
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 304418 195fed8762913959c76ea6fce419f8ba
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 843082 761ef8055bce9b3c4d5ab8bbb0fec39d
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 617904 8fc6039c1f55341393731d17fa3cbc9c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 301354 32f116f03847bdeb445ef53a1a64392d
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 1680462 00eaa8242cc38c6858f02aa6010b0be5
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 487118 60c101e156db1215276acbe6b2e91662
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 280808 f034ebbc37a1141201b0642b1c5ce609
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_armel.deb
Size/MD5 checksum: 294648 7c5feb74879f345288d413dfc404e189

hppa architecture (HP PA RISC)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 652494 bdd549260649ec5216b767e6670d453c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 282482 ed9acc19f9bd4c2b9e0318e5301ec21b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 1754106 db3846471aa183611a8e22b1df814f4f
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 850706 c0d159121b84584dc6ee9084feef81dc
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 499172 0f920d4319ad9fadfaa17b42eaebeef6
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 297456 8b13d9c765d306d3948537aca5d7f60c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 295136 2332f6e0d585899ee20c9bf891fd2c85
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 415660 4a6f05536add8e230dff66d8e1477ca6
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 485490 70898c3aa18cd89b5850823fe88a823b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 308126 67f3cfbc784cf391eca9363171af7a66
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 306406 ca1829e26effaa6db3a664a1bcf6ed31
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 5846118 309f6cf75f5191917618a1d6cc9c88a6
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_hppa.deb
Size/MD5 checksum: 305492 d557255266eddd72e0e0f3e0cf3f0350

i386 architecture (Intel ia32)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 846276 8904e921f569d49c48898455616a225b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 302160 fce517b813ec95bdb4dc91e4afac6afb
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 301522 c692bc93def91950e4c0d1fc85284b19
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 601598 3102a66a1ef9f734d9567695c1395ea5
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 484238 3db017b7a0fb7f8b654026bfb9cac2b3
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 302654 0142e27f71eb4da69f30f21dbc3de996
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 293110 c1dfb0b0fb38eb5072cae1c0394d65ab
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 403946 36fce4dedbb3f6bf4ab3e794e1b2dff7
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 292790 bfc13b64b9a25c8d2546c2a6e2967fa2
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 1688248 22fa912a6476c73143d0b3211fb50d69
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 281106 63baba2ede2a73df82db984ea552eaba
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 471074 b016f3701bf1399bde859ad7ec66797e
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_i386.deb
Size/MD5 checksum: 5271840 8050cbafd4da41bdd9850fad342f97cb

ia64 architecture (Intel ia64)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 319174 bd93cfb6285d8caf545ac9014a973f47
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 6297724 974938f16dac005b5a0ee07ff1ea2921
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 519614 c2517331838f591f6fdd436a3b45732a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 284402 5380c1aab98a54095130b4781f3a5bd6
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 299858 93ccd26207962d4fb7d9a9a551d12dae
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 435312 78bb55475e05c7e74db059efbbc4fbfd
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 308564 5a680205b9fc3ef3b94cbfb8a3b6778b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 545066 f31ea097ca6fb7fe777b1ea587286146
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 317924 aa46b5e43a77e999344e1720a7f1cc23
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 754168 015d6208e1ad03c5806ee9a58a930fb3
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 1900298 c1be7fc4b7fc67547603a483af7f01eb
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 314322 1016a0a61fa12791f13318561e9b97f2
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_ia64.deb
Size/MD5 checksum: 855894 08340a83f05b433bca4443dd0be900c0

mips architecture (MIPS (Big Endian))

http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 280824 9d737d0dc0acf9055ecc657118aa9c7e
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 292294 08d42e146a89f7132c82f2ae67cf1698
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 483634 08cd152ce9fd63e3eeece599df1449b7
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 604048 3548964a83f2f69174f3693541c46527
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 304730 d88a4b1eaca75777f183d1b3805e5fd1
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 293740 de528828c800bfa0bed5836d21704eb6
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 5609952 98207f66229a7cba96dbff6edfdcdb4a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 481756 8ea690b4c4daa0460c2e3412272bd104
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 1691686 f134df5ae470e2bb8b2dd6ca8e3d8779
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 297262 4bd8ae165343e6489a1f5b9a6a5cd4da
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 301784 b0d15ff913d66b760fa9000a83d3ab27
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 402942 ff630be7e9e6229695994df4e25e11ee
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_mips.deb
Size/MD5 checksum: 848336 1b932203bd8e8baf5a4307a5b7778e2f

mipsel architecture (MIPS (Little Endian))

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 1696030 3b0829b86399ce53dbe1188e70c1a78c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 301480 472e2c684007f77c9ecfe9fa42bd7686
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 404854 a35bd48eea687ea6c9a3331bf55adaf1
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 5252282 110beaf8d7f557dd3ef97b804136c15c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 482706 af03252ce37654b85caaf41ebfca1196
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 293424 2374fc8f0514c65204d2ee0a5c3465e9
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 598974 a5d5e7189d6db741c7c28fe6bfac05db
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 848560 107e8cdbdcfe6622efd3b7ec4471716a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 304488 0978c16fe8881b831f5f785d2f0444b6
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 292364 b3fdce319c64a2b1bcecb425af52ffbf
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 280606 a4157b04e7d3976b9a7d8a92e1d3c97f
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 296948 cd95f5279997623df7403ae1b58dbe65
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_mipsel.deb
Size/MD5 checksum: 480668 fc5e08f5421bc87007892520cf4d114b

powerpc architecture (PowerPC)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 687120 b5ba0ecb169616cbc705e4fe1dbc1187
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 304296 e74dd35d64343055f062086b09458010
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 843038 18630957eeed0e693346d3695aee7a94
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 5739044 b4c701814ffaa5738894c882fcf7b74e
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 304202 e07ea8c0c416911cebe11c347827b396
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 305960 ef4634ffa4c421b1ce6c9fdc58bbae3d
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 1752696 18078a6649670a81cbad13a6044d7ff0
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 407580 cbf28cbd152557d69861e2cb830e7e35
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 281662 6909aed0f1c3d789e2ab67ca5373379b
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 487876 828a499f5cd567d4cf88e2775f1d0aaf
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 295514 b45b1f88d3e4cc6f7d00d0e0bbac8705
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 478762 bae27b622ad03ea1a382f03eac528dbb
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_powerpc.deb
Size/MD5 checksum: 297176 f65f4b053bc0892e6a2ba0ca914d880f

s390 architecture (IBM S/390)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 1730350 f41be22f8262af1f4540ca4bc1680677
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 300668 d1a5bc25e9d7819ad1049ea95f6d80ce
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 5796748 9e2883b18efac7b7d4b875e5697d37de
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 481518 63f8d61e524d4b8b94af08e036a12e81
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 295090 e44711502d6d684e63e55702c3d1d438
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 292752 e653df75aebf4c4f548cd1cc6dd160c1
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 282056 2d3e049ffe56d4280534d4999c76a514
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 414580 9755bc36a4267a6988fe2a2659fa26e9
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 497266 b284f4f919ea45236ec8dd90f3f7a8d2
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 304866 bae622095d30e03e51c547f1ec1c04f8
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 849306 cee8eba1376290a93293923eff962121
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 646130 5f66bac15cd9537700ce003406803f66
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_s390.deb
Size/MD5 checksum: 305020 47a362712b7ce51493d0a510747c38ea

sparc architecture (Sun SPARC/UltraSPARC)

http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-pltcl-8.3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 292390 94c2fe6bae397b7910a1c10200beca96
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-dev_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 473472 7ac8248b22829c242878814537e7c712
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plpython-8.3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 292982 c2ef03503fcc65c3ee403bd8dc51715a
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-client-8.3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 1681186 7acead68688cc16aea9dadb1e780a573
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq-dev_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 467672 effc94bc0e2018019db0178bb7082c45
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg6_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 300226 78d2bff499903a85ac5fc8ba511e3c4c
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-contrib-8.3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 596644 15110cbb7fe05a914a0bc0b3d10bd9ba
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpgtypes3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 299990 2e85957a1d5fc8a64b3e4fcbf6e7419f
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-8.3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 5477262 4936b523621fb3649ae954d6e976c4b5
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-plperl-8.3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 299960 f57156b77889e5609b21e976f5e5dfca
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libecpg-compat3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 280610 848619c9979ce9cf01617fb121806c68
http://security.debian.org/pool/updates/main/p/postgresql-8.3/postgresql-server-dev-8.3_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 847044 d8a3d848480065d37ffb8b74b0e6aa07
http://security.debian.org/pool/updates/main/p/postgresql-8.3/libpq5_8.3.12-0lenny1_sparc.deb
Size/MD5 checksum: 405166 67621bc140b8ec8ed100586bbb9433a0


These files will probably be moved into the stable distribution on
its next update.


[SECURITY] [DSA 2116-1] New poppler packages fix several vulnerabilities
- ------------------------------------------------------------------------
Debian Security Advisory DSA-2116-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
October 12, 2010 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : poppler
Vulnerability : several
Problem type : local(remote)
Debian-specific: no
CVE Id(s) : CVE-2010-3702 CVE-2010-3704
Debian Bug : 599165

Joel Voss of Leviathan Security Group discovered two vulnerabilities in
the Poppler PDF rendering library, which may lead to the execution of
arbitrary code if a malformed PDF file is opened.

For the stable distribution (lenny), these problems have been fixed in
version 0.8.7-4.

For the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your poppler packages.

Upgrade instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Stable updates are available for alpha, amd64, arm, armel, hppa, i386, ia64, mips, mipsel, powerpc, s390 and sparc.

Source archives:

http://security.debian.org/pool/updates/main/p/poppler/poppler_0.8.7.orig.tar.gz
Size/MD5 checksum: 1469587 9af81429d6f8639c357a5eed25583365
http://security.debian.org/pool/updates/main/p/poppler/poppler_0.8.7-4.diff.gz
Size/MD5 checksum: 23876 219c5db15e7e0ad3ce01c45b5d2d17b5
http://security.debian.org/pool/updates/main/p/poppler/poppler_0.8.7-4.dsc
Size/MD5 checksum: 1481 a2d28a0e06fd0b226e9e87d88aab52e8

alpha architecture (DEC Alpha)

http://security.debian.org/pool/updates/main/p/poppler/libpoppler3_0.8.7-4_alpha.deb
Size/MD5 checksum: 891456 eecf847b41f68e67cfa250c239ab95ff
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-glib3_0.8.7-4_alpha.deb
Size/MD5 checksum: 220410 cdc18593a727b1a80279ad941a929dee
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt4-3_0.8.7-4_alpha.deb
Size/MD5 checksum: 329946 83a82f4a995727adac2a9cbb19cd0705
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-glib-dev_0.8.7-4_alpha.deb
Size/MD5 checksum: 303118 8407f059f1395ad93f765cdcf70f6246
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt2_0.8.7-4_alpha.deb
Size/MD5 checksum: 180578 f625e16840c1262de1e33579bfff3e00
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt-dev_0.8.7-4_alpha.deb
Size/MD5 checksum: 197172 2573621fc79b03251735690bfd818f5e
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-dev_0.8.7-4_alpha.deb
Size/MD5 checksum: 1334994 5fbda5e9f2b3824d3d7ccbb1bcf000d0
http://security.debian.org/pool/updates/main/p/poppler/poppler-dbg_0.8.7-4_alpha.deb
Size/MD5 checksum: 3204616 7c7c37da8b894e462b2758524365ca46
http://security.debian.org/pool/updates/main/p/poppler/poppler-utils_0.8.7-4_alpha.deb
Size/MD5 checksum: 234854 06e4977b32fb63577a918c110147e5f6
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt4-dev_0.8.7-4_alpha.deb
Size/MD5 checksum: 452718 751233edf2ec85fd1e095893124f8909

amd64 architecture (AMD x86_64 (AMD64))

http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt-dev_0.8.7-4_amd64.deb
Size/MD5 checksum: 184848 ed2abc9b1edd4cde56eb40b9b775cf45
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-dev_0.8.7-4_amd64.deb
Size/MD5 checksum: 1119492 16725109ae348df90c30896be4a0c5de
http://security.debian.org/pool/updates/main/p/poppler/poppler-utils_0.8.7-4_amd64.deb
Size/MD5 checksum: 232702 2e7740b7098cd91493f178745b966d4a
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt2_0.8.7-4_amd64.deb
Size/MD5 checksum: 178414 497a3f7cbff9acdb0b01d58aae33415a
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt4-dev_0.8.7-4_amd64.deb
Size/MD5 checksum: 358376 461a59da2c6b0c7531bba1a385f3607d
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-glib-dev_0.8.7-4_amd64.deb
Size/MD5 checksum: 275318 3c6b86fb8a57e9f17fbe058a36fa426e
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt4-3_0.8.7-4_amd64.deb
Size/MD5 checksum: 314086 3381ccceeaa1d2727f331d92b59818dd
http://security.debian.org/pool/updates/main/p/poppler/poppler-dbg_0.8.7-4_amd64.deb
Size/MD5 checksum: 3148992 c1f76eb6ca390ef674647dc5def03c40
http://security.debian.org/pool/updates/main/p/poppler/libpoppler3_0.8.7-4_amd64.deb
Size/MD5 checksum: 840444 bc302d9fba4a4469b0d1902f5bb9777e
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-glib3_0.8.7-4_amd64.deb
Size/MD5 checksum: 217654 7008780b0aea027507fb70fe7c55af15

arm architecture (ARM)

http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt4-dev_0.8.7-4_arm.deb
Size/MD5 checksum: 390130 993386a0e413c10df447dc83ccb3ca15
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt-dev_0.8.7-4_arm.deb
Size/MD5 checksum: 184796 2e3eeb3b7a744a268dad95cae33d6146
http://security.debian.org/pool/updates/main/p/poppler/poppler-dbg_0.8.7-4_arm.deb
Size/MD5 checksum: 3115978 784d8f1cef1f6536b979e6c52baedbd0
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt2_0.8.7-4_arm.deb
Size/MD5 checksum: 178194 8bc04420f3e45f0d9f0e2c70abe9f805
http://security.debian.org/pool/updates/main/p/poppler/poppler-utils_0.8.7-4_arm.deb
Size/MD5 checksum: 226694 e9cad6f85ee41ad40d6cf5cd4accc5aa
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-glib-dev_0.8.7-4_arm.deb
Size/MD5 checksum: 270650 d5bc5732bbe002e3db1425835848626f
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-qt4-3_0.8.7-4_arm.deb
Size/MD5 checksum: 341936 e13e6c29d90f909c81e0b06bdf131a61
http://security.debian.org/pool/updates/main/p/poppler/libpoppler-dev_0.8.7-4_arm.deb
Size/MD5 checksum: 1096786 1bbed300b089de228c0b9a5cc4d1a7f6
Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/new_postgresql_83poppler_updates_for_debian.html)