ncftp (SSA:2005-135-02)
Posted on: 05/16/2005 08:23 AM

New ncftp packages are available for Slackware 10.0, 10.1, and -current to fix security issues.

More details about this issue may be found on the NcFTP site:

Here are the details from the Slackware 10.1 ChangeLog:
patches/packages/ncftp-3.1.9-i486-1.tgz: Upgraded to ncftp-3.1.9.
This corrects a vulnerability where a download from a hostile FTP server
might be written to an unintended location potentially compromising system
security or causing a denial of service.
For more details, see:
(* Security fix *)

Where to find the new packages:

Updated package for Slackware 10.0:

Updated package for Slackware 10.1:

Updated package for Slackware -current:

MD5 signatures:

Slackware 10.0 package:
153e4eff85919531ee58cc445b1c3c93 ncftp-3.1.9-i486-1.tgz

Slackware 10.1 package:
aac0389bd0bff8543a5fe8fdc305a50c ncftp-3.1.9-i486-1.tgz

Slackware -current package:
c3ce5f147fd8ea8fa442071008a54cff ncftp-3.1.9-i486-1.tgz

Installation instructions:

Upgrade the package as root:
# upgradepkg ncftp-3.1.9-i486-1.tgz


Slackware Linux Security Team

Printed from Linux Compatible (