MozillaFirefox Update for openSUSE
Posted on: 11/17/2017 05:31 AM

Updated Firefox packages has been released for openSUSE Leap 42.2 and 42.3

MozillaFirefox Update for openSUSE


openSUSE Security Update: Security update for MozillaFirefox
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3027-1
Rating: important
References: #1061207 #1068101
Cross-References: CVE-2017-7826 CVE-2017-7828 CVE-2017-7830

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:



MozillaFirefox was updated to 52.5.0esr (boo#1068101)

MFSA 2017-25

* CVE-2017-7828: Fixed a use-after-free of PressShell while restyling
layout
* CVE-2017-7830: Cross-origin URL information leak through Resource Timing
API
* CVE-2017-7826: Memory safety bugs fixed in Firefox 57 and Firefox ESR
52.5

Also fixed:

- Correct plugin directory for aarch64 (boo#1061207). The wrapper script
was not detecting aarch64 as a 64 bit architecture, thus used
/usr/lib/browser-plugins/.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1279=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1279=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

MozillaFirefox-52.5.0-66.1
MozillaFirefox-branding-upstream-52.5.0-66.1
MozillaFirefox-buildsymbols-52.5.0-66.1
MozillaFirefox-debuginfo-52.5.0-66.1
MozillaFirefox-debugsource-52.5.0-66.1
MozillaFirefox-devel-52.5.0-66.1
MozillaFirefox-translations-common-52.5.0-66.1
MozillaFirefox-translations-other-52.5.0-66.1

- openSUSE Leap 42.2 (i586 x86_64):

MozillaFirefox-52.5.0-57.21.1
MozillaFirefox-branding-upstream-52.5.0-57.21.1
MozillaFirefox-buildsymbols-52.5.0-57.21.1
MozillaFirefox-debuginfo-52.5.0-57.21.1
MozillaFirefox-debugsource-52.5.0-57.21.1
MozillaFirefox-devel-52.5.0-57.21.1
MozillaFirefox-translations-common-52.5.0-57.21.1
MozillaFirefox-translations-other-52.5.0-57.21.1


References:

https://www.suse.com/security/cve/CVE-2017-7826.html
https://www.suse.com/security/cve/CVE-2017-7828.html
https://www.suse.com/security/cve/CVE-2017-7830.html
https://bugzilla.suse.com/1061207
https://bugzilla.suse.com/1068101



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/mozillafirefox_update_for_opensuse.html)